[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#253102: Installation on a recent ibook G4 (Beta 4)



Package: installation-reports

Debian-installer-version: Beta4-Installer from installer web page
uname -a: Linux thirtyto 2.4.25-ben1 #1 Mo Mai 10 21:45:41 CEST 2004 ppc GNU/Linux
Date: May 1st, 2004
Method: Booted off downloaded ISO, packages installed from net. No proxy or similar thing
      

Machine: ibook G4
Processor: unknown (80030101) (according to /proc/cpuinfo)
Memory:768 MB
Root Device: Internal IDE (hda)
Root Size/partition table: 

proc	/proc	proc	defaults	0	0	
/dev/hda4	/	ext3	defaults,errors=remount-ro	0	1
/dev/system_vg/var_lv	/var	ext3	defaults,nodev	0	2
/dev/system_vg/usr_lv	/usr	ext2	defaults,nodev	0	2
/dev/system_vg/tmp_lv	/tmp	ext2	defaults,nodev	0	2
/dev/system_vg/home_lv	/home	ext3	defaults,nodev	0	2
/dev/system_vg/build_lv	/scr/build	ext3	defaults,nodev	0	2
/dev/system_vg/uni_lv	/home/helge/uni	ext3	noauto,loop,encryption=aes,user	0	0
devpts	/dev/pts	rw,gid=5,mode=620	0	0
tmpfs	/dev/shm	rw	0	0
usbfs	/proc/bus/usb	rw	0	0
Output of lspci:

Base System Installation Checklist:

Initial boot worked:    [E]
Configure network HW:   [O]
Config network:         [O]
Detect CD:              [ ]
Load installer modules: [O]
Detect hard drives:     [ ]
Partition hard drives:  [E]
Create file systems:    [O]
Mount partitions:       [O]
Install base system:    [E]
Install boot loader:    [E]
Reboot:                 [E]
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it

Comments/Problems:

1. Initial boot only worked with "expert-safe" (framebuffer unusuable otherwise)

2. I could not get the installer to install LVM. Manually going to a shell and creating
   the volume group and afterwards the logical volumes worked. The
   installer then proceede to format and mount the partitions without
   problems.

3. Base system did not install lvm-tools. Hence I was unable to use
   the system. Solved by reinstalling into swap, booting into "swap",
   installing lvm10, chrooting into previous install, installing lvm10
   there, and finally rebooting into installed system.

4. Boot-Loader installation went fine, except that I was unable to set
   "video=ofonly". I could change it, but I could not run ybin to
   install the change (after I realized what exactly the error
   caused). The only way around this was to explicitly boot with

   hd:4,/vmlinux root=/dev/hda4 ro video=ofonly

5. With video=ofonly I do not get X. For 2.6 I got some patches from
   the PPC-list, which "work" (i.e. I get to the gray background) but
   as the system is installed (I added udev), there are some
   permission problems preventing from anything else. An unpatched 2.6
   or the 2.4 as installed/as build from ben's sources only makes nice
   graphic effects when trying to start X.

   I reported these patches as
   http://bugs.debian.org/cgi-bin/pkgreport.cgi?pkg=kernel-patch-powerpc-2.6.6

   A similar patch for 2.4 would be most welcome, because the default
   (and I know how it works) kernel is 2.4. 

Additional information can be found here:
http://lists.debian.org/debian-powerpc/2004/05/msg00013.html

and replies. As I understood, 4 is being worked on by Colin Watson. 

And, the debian-installer web page should make it IMHO more clear that
installation-reports are still welcome (and should not (solely)
directed to mailinglists).

Finally, for future the installation of encrypted partitions would be
great, as this should be the default for laptops. I did it manually,
which worked only with AES.

Otherwiese: Great work!

-- 
Helge Kreutzmann, Dipl.-Phys.               Helge.Kreutzmann@itp.uni-hannover.de
  gpg signed mail preferred    gpg-key: finger kreutzm@zibal.itp.uni-hannover.de
    64bit GNU powered                  http://www.itp.uni-hannover.de/~kreutzm
       Help keep free software "libre": http://www.freepatents.org/

Attachment: pgp8cQ1Sm7k0s.pgp
Description: PGP signature


Reply to: