[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#251020: xfree86 doesn't recognize horiz&vert rates + cat /proc/bus/usb/devices hangs, and so discover does

Package: installation-reports


Debian-installer-version: http://cdimage.debian.org/pub/cdimage-testing/daily/i386/20040525/sarge-i386-netinst.iso uname -a: Linux roller.fmi.uni-sofia.bg 2.6.5-1-386 #2 Fri Apr 30 20:13:30 EST 2004 i686 GNU/Linux (the second install)
Date: 2004-05-26
Method: netinst

Processor: 2 x Pentium III 933 MHz
Memory: 256M
Root Device: IDE
Root Size/partition table:  / on 10G, 1G swap
Output of lspci and lspci -n:

0000:00:00.0 Host bridge: VIA Technologies, Inc. VT82C693A/694x [Apollo PRO133x] (rev c4) 0000:00:01.0 PCI bridge: VIA Technologies, Inc. VT82C598/694x [Apollo MVP3/Pro133x AGP] 0000:00:07.0 ISA bridge: VIA Technologies, Inc. VT82C686 [Apollo Super South] (rev 40) 0000:00:07.1 IDE interface: VIA Technologies, Inc. VT82C586A/B/VT82C686/A/B/VT823x/A/C/VT8235 PIPC Bus Master IDE (rev 06) 0000:00:07.2 USB Controller: VIA Technologies, Inc. VT6202 [USB 2.0 controller] (rev 16) 0000:00:07.3 USB Controller: VIA Technologies, Inc. VT6202 [USB 2.0 controller] (rev 16) 0000:00:07.4 SMBus: VIA Technologies, Inc. VT82C686 [Apollo Super ACPI] (rev 40) 0000:00:0b.0 Multimedia audio controller: C-Media Electronics Inc CM8738 (rev 10) 0000:00:0c.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10) 0000:01:00.0 VGA compatible controller: ATI Technologies Inc Radeon RV100 QY [Radeon 7000/VE]

0000:00:00.0 Class 0600: 1106:0691 (rev c4)
0000:00:01.0 Class 0604: 1106:8598
0000:00:07.0 Class 0601: 1106:0686 (rev 40)
0000:00:07.1 Class 0101: 1106:0571 (rev 06)
0000:00:07.2 Class 0c03: 1106:3038 (rev 16)
0000:00:07.3 Class 0c03: 1106:3038 (rev 16)
0000:00:07.4 Class 0c05: 1106:3057 (rev 40)
0000:00:0b.0 Class 0401: 13f6:0111 (rev 10)
0000:00:0c.0 Class 0200: 10ec:8139 (rev 10)
0000:01:00.0 Class 0300: 1002:5159

Base System Installation Checklist:
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it

Initial boot worked:    [O]
Configure network HW:   [O]
Config network:         [O]
Detect CD:              [O]
Load installer modules: [O]
Detect hard drives:     [O]
Partition hard drives:  [O]
Create file systems:    [O]
Mount partitions:       [O]
Install base system:    [O]
Install boot loader:    [O]
Reboot:                 [O]


First I installed with Linux 2.4. The only problem with it was that XFree86 asked me if horizontal and vertical refresh rate are taken from DDC and I answered yes. But values for these rates were set to some generic values. I had to view /var/log/XFree.0.log, read the rates from there and put them in /etc/X11/XF86Config-4 manually.

My second install was with Linux 2.6. All went fine until all packages are downloaded and debconf tried to configure xfree86 (XFree86 again, huh?). The installation hangs just after all packages are downloaded and they are started to be configured. The problem was that discover hangs. I installed strace manually and run "strace discover" -- the process hangs while trying to read from /proc/bus/usb/devices. "cat /proc/bus/usb/devices" hangs too. I didn't continue with installation.

Install logs and other status info is available in /var/log/debian-installer/.
Once you have filled out this report, mail it to submit@bugs.debian.org.

Reply to: