[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

SUMMARY: woes installing woody on IBM x205 Server

Hello List,

i've sent this mail to the list a few days ago
unfortunately withotu receiving any feedback at all. I
take it noone knows what the problem here could be. So
i installed using the unofficial testing images and it
works more or less ok now with the exception of the
boot partition not being flagged bootable and the NIC
not being set up.

 --- Trollcollect <trollcollect@yahoo.de> schrieb: >
Hello list,
> i was possibly mistaken to send the attached mail to
> debian-users yesterday; havent received any reply
> yet.
> I'd appreciate each and any input. Please Cc:
> answers
> to my email address as i cannot sign up for the
> list.
> --------------------------------
> i've put several hours, if not days into this
> attempt
> to install woody and i am at my wits end now. If you
> can , please help. As i cant follow the list, please
> cc: this address in any reply.
> I have bought an IBM x205 server and additionally
> ordered a ServeRaid 4lx raid controller as
> recommended
> by the hardware distributor (returning the items is
> not an option; they offered to install linux
> (redhat)
> and i refused; turns out redhat and suse support all
> devices that cause me trouble now). I have a problem
> now with getting the raid controller to work, as
> well
> as the Gigabit ethernet card that is onBoard
> (e1000).
> It seems as if there used to be an extended driver
> set
> on a boot floppy provided by "blade" at on
> http://people.debian.org/~blade/install/preload/
> however when i go there, it tells me that the
> drivers
> are possibly (and most likely) have been corruped
> during the hacking of the debian server, and that
> the
> maintainer of that inofficial package has no
> interest
> in keeping it up to date. I can only open the
> archive
> after typing in a password saying "Yes i want to
> screw
> my system with hacked code!" or such. Naturally i
> prefer not to use them.
> Next i got myself the original kernel sources and
> headers for the bf24 kernel and built the module for
> the controller (ips.o) on another debian system. Put
> it on a floppy (into the /boot directory of course)
> and then tried to "Add additional drivers from
> floppy"
> when booting from the woody disk 1 (of course with
> kernel bf24). When i tell the dialog to insert that
> module, it will hang forever.
> If, instead , i open a terminal, manually mount the
> floppy, copy the module into the right place
> (/lib/modules/2.4something/kernel/drivers/scsi) and
> then do an insmod, it tells me the module is not
> built
> for that kernel. If finally i do a insmod -f ( that
> is
> what the dialog is doing, too) it tells me that the
> kernel is being tained, and it hangs forever. At
> other
> occasions, i saw that while the dialog is hanging,
> lsmod reports the module as being loaded (and
> initializing).
> I hope i am missing the "right" way to install woody
> on that system. Can anyone point me to some document
> that could help me with the installation?
> By the way googling pointed me to a dubious
> "boot-floppies" package all the time. On my other
> system i have repeatedly tried to apt-get or
> apt-cache
> search for that package without success. Would that
> solve my problems? Where could i get it?
> Out of curiosity i tried blade's boot floppy just to
> see wether the module would load cleanly (unlike the
> one i built). It indeed does. Boiling my problem
> down
> to: how did he make those modules? I really dont
> want
> to use the modules on the floppy as he himself says
> they could easily be compromised and this system i
> am
> working on is obviously a bit sensitive (hence the
> raid controller). Any hints on how to make a module
> that will actually load, or why my module just
> hangs?
> TIA,
> Daniel
> 		Mit schönen Grüßen von Yahoo! Mail.
> Mit dem Yahoo! Messenger können Sie Freunde noch
> schneller erreichen! 


Mit schönen Grüßen von Yahoo! Mail - http://mail.yahoo.de

Reply to: