[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#246841: marked as done (partman-newworld: doesn't set filesystem properly)



Your message dated Mon, 10 May 2004 13:32:15 -0400
with message-id <E1BNEdT-0007rW-00@newraff.debian.org>
and subject line Bug#246841: fixed in partman-newworld 5
has caused the attached Bug report to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what I am
talking about this indicates a serious mail system misconfiguration
somewhere.  Please contact me immediately.)

Debian bug tracking system administrator
(administrator, Debian Bugs database)

--------------------------------------
Received: (at submit) by bugs.debian.org; 1 May 2004 17:40:20 +0000
>From jonathan@kaolin.hn.org Sat May 01 10:40:20 2004
Return-path: <jonathan@kaolin.hn.org>
Received: from smtp3.adl2.internode.on.net [203.16.214.203] 
	by spohr.debian.org with esmtp (Exim 3.35 1 (Debian))
	id 1BJyTM-0000nz-00; Sat, 01 May 2004 10:40:20 -0700
Received: from stapler-internal.kaolin.hn.org (ppp162-136.lns1.bne3.internode.on.net [150.101.162.136])
	by smtp3.adl2.internode.on.net (8.12.9/8.12.9) with ESMTP id i41HeGk2038035
	for <submit@bugs.debian.org>; Sun, 2 May 2004 03:10:17 +0930 (CST)
Received: from jonathan by stapler-internal.kaolin.hn.org with local (Exim 4.30)
	id 1BJyTe-0004oN-8T
	for submit@bugs.debian.org; Sun, 02 May 2004 03:40:38 +1000
Date: Sun, 2 May 2004 03:40:37 +1000
To: submit@bugs.debian.org
Subject: qualified success on iBook G4
Message-ID: <20040501174037.GA17174@kaolin.hn.org>
Mime-Version: 1.0
Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline
X-Represent-the-Ocean: Yes
User-Agent: Mutt/1.5.5.1+cvs20040105i
From: Jonathan Matthew <jonathan@kaolin.hn.org>
Delivered-To: submit@bugs.debian.org
X-Spam-Checker-Version: SpamAssassin 2.60-bugs.debian.org_2004_03_25 
	(1.212-2003-09-23-exp) on spohr.debian.org
X-Spam-Status: No, hits=-7.0 required=4.0 tests=BAYES_00,HAS_PACKAGE 
	autolearn=no version=2.60-bugs.debian.org_2004_03_25
X-Spam-Level: 
X-CrossAssassin-Score: 1

Package: installation-reports

Debian-installer-version: beta 4
uname -a: Linux turnip 2.4.25-powerpc #1 mer avr 14 15:38:38 CEST 2004 ppc GNU/Linux
Date: 1 May 2004
Method: businesscard CD, packages downloaded from FTP mirror

Machine: Apple iBook G4 12"
Processor: 1GHz G4
Memory: 256MB
Root Device: 40G IDE disk
Root Size/partition table: 12G ext3 root partition
Output of lspci:

0000:00:0b.0 Host bridge: Apple Computer Inc. UniNorth 2 AGP
0000:00:10.0 VGA compatible controller: ATI Technologies Inc RV250 5c63 [Radeon Mobility 9200 M9+] (rev 01)
0000:10:0b.0 Host bridge: Apple Computer Inc. UniNorth 2 PCI
0000:10:12.0 Network controller: Broadcom Corporation BCM94306 802.11g (rev 03)
0000:10:17.0 Class ff00: Apple Computer Inc. KeyLargo/Intrepid Mac I/O
0000:10:18.0 USB Controller: Apple Computer Inc. KeyLargo/Intrepid USB
0000:10:19.0 USB Controller: Apple Computer Inc. KeyLargo/Intrepid USB
0000:10:1a.0 USB Controller: Apple Computer Inc. KeyLargo/Intrepid USB
0000:10:1b.0 USB Controller: NEC Corporation USB (rev 43)
0000:10:1b.1 USB Controller: NEC Corporation USB (rev 43)
0000:10:1b.2 USB Controller: NEC Corporation USB 2.0 (rev 04)
0000:20:0b.0 Host bridge: Apple Computer Inc. UniNorth 2 Internal PCI
0000:20:0d.0 Class ff00: Apple Computer Inc. UniNorth/Intrepid ATA/100
0000:20:0e.0 FireWire (IEEE 1394): Apple Computer Inc. UniNorth 2 FireWire (rev 81)
0000:20:0f.0 Ethernet controller: Apple Computer Inc. UniNorth 2 GMAC (Sun GEM) (rev 80)


Base System Installation Checklist:

Initial boot worked:    [O]
Configure network HW:   [O]
Config network:         [O]
Detect CD:              [O]
Load installer modules: [O]
Detect hard drives:     [O]
Partition hard drives:  [E]
Create file systems:    [O]
Mount partitions:       [O]
Install base system:    [O]
Install boot loader:    [E]
Reboot:                 [O]
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it

Comments/Problems:

I had to use the 'install-safe' boot option, otherwise the display
didn't work.

When choosing a mirror to download from, I found I had to back out of
the country list before I could choose to use FTP.  I guess this isn't
a problem if you choose a mirror from the list, or (I assume) the 
mirror name begins with 'ftp', but neither of those is true for me.

I chose manual partitioning in order to leave some space for a certain
proprietary operating system.  Partitioning itself worked well, but
when exiting the partitioner, it refused to believe that I'd created
the bootstrap partition.  I messed around with the size a bit, but it 
didn't help. I tried creating the bootstrap partition using mac-fdisk, 
and that didn't work either.  I eventually ignored the warning and 
carried on.  The message I was getting here was 
partman-newworld/no_newworld, not partman-newworld/wrong_size.

I don't know if it's possible to do this check inside the partition 
editor, so you don't need to write the partition table to disk before 
you find out you've got to go back and fix it, but that'd be nice.

When installing the boot loader, the same message appeared.  I started
a shell, chrooted into /target, mounted /proc, ran ybin, and it worked.

Those things aside, everything worked fine.  

In the two installs I've done using d-i now (this one and an earlier
i386 install I don't seem to have bothered reporting on), what's
impressed me most hasn't been how simple it is, but rather how, when
it does break, I can bash it until it works.


---------------------------------------
Received: (at 246841-close) by bugs.debian.org; 10 May 2004 17:38:32 +0000
>From katie@ftp-master.debian.org Mon May 10 10:38:32 2004
Return-path: <katie@ftp-master.debian.org>
Received: from newraff.debian.org [208.185.25.31] (mail)
	by spohr.debian.org with esmtp (Exim 3.35 1 (Debian))
	id 1BNEjY-0002LY-00; Mon, 10 May 2004 10:38:32 -0700
Received: from katie by newraff.debian.org with local (Exim 3.35 1 (Debian))
	id 1BNEdT-0007rW-00; Mon, 10 May 2004 13:32:15 -0400
From: Colin Watson <cjwatson@debian.org>
To: 246841-close@bugs.debian.org
X-Katie: $Revision: 1.49 $
Subject: Bug#246841: fixed in partman-newworld 5
Message-Id: <E1BNEdT-0007rW-00@newraff.debian.org>
Sender: Archive Administrator <katie@ftp-master.debian.org>
Date: Mon, 10 May 2004 13:32:15 -0400
Delivered-To: 246841-close@bugs.debian.org
X-Spam-Checker-Version: SpamAssassin 2.60-bugs.debian.org_2004_03_25 
	(1.212-2003-09-23-exp) on spohr.debian.org
X-Spam-Status: No, hits=-5.0 required=4.0 tests=BAYES_00,HAS_BUG_NUMBER 
	autolearn=no version=2.60-bugs.debian.org_2004_03_25
X-Spam-Level: 
X-CrossAssassin-Score: 1

Source: partman-newworld
Source-Version: 5

We believe that the bug you reported is fixed in the latest version of
partman-newworld, which is due to be installed in the Debian FTP archive:

partman-newworld_5.dsc
  to pool/main/p/partman-newworld/partman-newworld_5.dsc
partman-newworld_5.tar.gz
  to pool/main/p/partman-newworld/partman-newworld_5.tar.gz
partman-newworld_5_powerpc.udeb
  to pool/main/p/partman-newworld/partman-newworld_5_powerpc.udeb



A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 246841@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Colin Watson <cjwatson@debian.org> (supplier of updated partman-newworld package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.7
Date: Mon, 10 May 2004 18:12:43 +0100
Source: partman-newworld
Binary: partman-newworld
Architecture: source powerpc
Version: 5
Distribution: unstable
Urgency: low
Maintainer: Debian Install System Team <debian-boot@lists.debian.org>
Changed-By: Colin Watson <cjwatson@debian.org>
Description: 
 partman-newworld - partman support for new-world PowerMac boot partitions (udeb)
Closes: 246841
Changes: 
 partman-newworld (5) unstable; urgency=low
 .
   * Colin Watson
     - Clarify partman-newworld/no_newworld text a little.
     - Load the hfs module during initialization.
     - Add a valid_filesystems script for newworld again, so that partitions
       are properly created as hfs (closes: #246841).
     - Talk about "819200 bytes" rather than the confusing "820KB" (see
       #248116).
   * Updated translations:
     - Bulgarian (bg.po) by Ognyan Kulev
     - Czech (cs.po) by Miroslav Kure
     - Danish (da.po) by Claus Hindsgaul
     - Greek (el.po) by Konstantinos Margaritis
     - Spanish (es.po) by Javier Fernandez-Sanguino Peña
     - Basque (eu.po) by Piarres Beobide Egaña
     - French (fr.po) by Christian Perrier
     - Japanese (ja.po) by Kenshi Muto
     - Korean (ko.po) by Changwoo Ryu
     - Dutch (nl.po) by Bart Cornelis
     - Norwegian (nn.po) by HÃ¥vard Korsvoll
     - Polish (pl.po) by Bartosz Fenski
     - Portuguese (pt.po) by Miguel Figueiredo
     - Portuguese (Brazil) (pt_BR.po) by André Luís Lopes
     - Romanian (ro.po) by Eddy Petrisor
     - Slovak (sk.po) by Peter KLFMANiK Mann
     - Albanian (sq.po) by Elian Myftiu
     - Swedish (sv.po) by André Dahlqvist
     - Turkish (tr.po) by Recai OktaÅ?
     - Ukrainian (uk.po) by Eugeniy Meshcheryakov
     - Simplified Chinese (zh_CN.po) by Carlos Z.F. Liu
Files: 
 eaf0748a1b8cf0a90fdca4eaf6bc69b3 670 debian-installer standard partman-newworld_5.dsc
 e941c4f7966772e26843350b2eba88fa 16480 debian-installer standard partman-newworld_5.tar.gz
 29e8f7c80e9922aa83b0c0456fcd9c46 6460 debian-installer standard partman-newworld_5_powerpc.udeb
package-type: udeb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.2 (GNU/Linux)
Comment: Colin Watson <cjwatson@debian.org> -- Debian developer

iD8DBQFAn7hQ9t0zAhD6TNERAuSeAJ9pb410ZVJ8QeM6k0pmYe6brM2iuACeOuLv
a9jbbNrT4Mgp1PnHw2mCNlo=
=fm1F
-----END PGP SIGNATURE-----



Reply to: