[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#224661: marked as done (please switch to lvm2)

Your message dated Sat, 08 May 2004 22:17:02 -0400
with message-id <E1BMdsE-0005Fm-00@newraff.debian.org>
and subject line Bug#224661: fixed in lvmcfg 0.26
has caused the attached Bug report to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what I am
talking about this indicates a serious mail system misconfiguration
somewhere.  Please contact me immediately.)

Debian bug tracking system administrator
(administrator, Debian Bugs database)

Received: (at submit) by bugs.debian.org; 20 Dec 2003 18:06:08 +0000
>From tbm@cyrius.com Sat Dec 20 12:05:59 2003
Return-path: <tbm@cyrius.com>
Received: from bangpath.uucico.de [] 
	by master.debian.org with esmtp (Exim 3.35 1 (Debian))
	id 1AXl0u-0000cq-00; Sat, 20 Dec 2003 11:35:40 -0600
Received: by bangpath.uucico.de (Postfix, from userid 10)
	id 873EE26B27; Sat, 20 Dec 2003 18:35:39 +0100 (CET)
Received: by deprecation.cyrius.com (Postfix, from userid 1000)
	id 0B6B0FEAE; Sat, 20 Dec 2003 18:33:56 +0100 (CET)
Date: Sat, 20 Dec 2003 18:33:56 +0100
From: Martin Michlmayr <tbm@cyrius.com>
To: submit@bugs.debian.org
Subject: dhcp & lvm problems, partconf & GRUB wishlist
Message-ID: <20031220173355.GA5849@deprecation.cyrius.com>
Mime-Version: 1.0
Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline
User-Agent: Mutt/1.5.4i
Delivered-To: submit@bugs.debian.org
X-Spam-Checker-Version: SpamAssassin 
	(1.212-2003-09-23-exp) on master.debian.org
X-Spam-Status: No, hits=-5.0 required=4.0 tests=HAS_PACKAGE autolearn=no 

Package: installation-reports


Debian-installer-version: daily built from 17-Dec-2003
sarge-i386-netinst.iso      17-Dec-2003 07:34   120M
uname -a: 2.4.22
Date: Sat Dec 20 18:07:00 CET 2003
Method: boot from IDE CD-ROM, using netinst ISO

Machine: No-name desktop PC
Processor: K6-2 400 MHz
Memory: 128 MB
Root Device: IDE, also has a SCSI CD-ROM

Base System Installation Checklist:

Initial boot worked:    [O]
Configure network HW:   [O]
Config network:         [E]
Detect CD:              [O]
Load installer modules: [O]
Detect hard drives:     [O]
Partition hard drives:  [O]
Create file systems:    [O]
Mount partitions:       [O]
Install base system:    [O]
Install boot loader:    [O]
Reboot:                 [O]
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it


Why do you ask for the debconf priority at the beginning?  I think it
should just be "high" by default and people who want something lower can
pass "DEBCONF_PRIORITY".  I guess/hope this is currently only asked for
testing, and that it will be disabled later.  I chose "high".

Apparently, it looks for DHCP automatically.  While the PC had a network
card, it was not connected anywhere.  So I got the following error:

  Configure the network using dynamic addressing (DHCP)
  An error occured and the network configuration process has been aborted.

Since I didn't chose DHCP, it would be good if a short explanation could be
offered.  What DHCP is and why we tried to use it.  Some people might not
know what DHCP is.

Since I didn't have or want a network, I wanted to choose "Detect and mount
CD-ROM" next.  However, that would show the DHCP error again.  I could only
continue after manually configuring an IP address.  Please don't assume I
want a network just because I have a network card.  Also, why is the
"manually configure network" so much further down the menu?

At some point I went into the partition a hard drive menu.  It showed me:
    <info on my hard drive>
I chose my hard drive, got into cfdisk, did my stuff and quit.  After that,
the menu was on the hard drive again.  I think it should be one menu item
further down (on "Finish" in my case, or on the 2nd hard drive if I had one).

Before formating the hard drive, I got:
    WARNING: This will destroy all data on the partitions you have assigned
    file systems to.
    Ready to create file systems and mount partitions

I told partconf to format one partition (/dev/hda1) while leaving the rest
alone (/dev/hda5 was to be mounted as /home; this was a hard drive which
had some Linux stuff on it already).  So obviously it is only going to
format _one_ partition, while mounting more than one.  It would be nice if
this warning would show me exactly which partitions it is going to format.
   Formating and mounting:
       /dev/hda1 (ext3)
   Just mounting:

(It did the right thing, though, and only formated the first partition.)

Why is LILO installed by default?  I thought the decision was to go with

After rebooting:

/etc/mailname was "(none)" even though /etc/hosts contained the name of my
machine.  Also, /etc/hostname contained "localhost" instead of the correct

The <up> key does not work in debconf to go to the last menu item.  I never
noticed this before, but this is really annoying.

No install-report.template file was in /root.


OK, then I tried another installation on the same box, this time with
debconf priority "medium".

I chose the lvm udeb, but when I wanted to create LVM partitions it told
me: The current kernel doesn't support the Logical Volume Manager.
And yes, there was no lvm-mod module anywhere.

Also, why is lvm10 used instead of lvm2?  2.4.23-1 will have the
device-mapper patch included so I hope we can switch to lvm2 then.

I chose GRUB this time; it asked me on which device I want to install it.
It gave me (hd0) as default and had some info about GRUB having a different
device schema as Linux.  Who cares?  It would be much nicer if it would
display a list of hard drives (a la partconf) and then translated it to
GRUB's name itself.

I chose reiserfs for the root partition this time.  After reboot, I saw:
    fsck.reiserfs: not found
I guess reiserfsprogs should be installed if any reiserfs partition is

Also, from LVM I got "modprobe: modprobe: Can't locate module block-major-114".
dmesg said:
    loop: loaded (max 8 devices)
    md: md driver 9.90.0 MAX_MD_DEVS=256, MD_SB_DISK=27
    modprobe: modprobe: Can't locate module block-major-114
    [repeat ~40-50 times]
    vgcan -- "/etc/lvmtab" and "/etc/lvmtab.d" succesfully created

Martin Michlmayr

Received: (at 224661-close) by bugs.debian.org; 9 May 2004 02:23:06 +0000
>From katie@ftp-master.debian.org Sat May 08 19:23:06 2004
Return-path: <katie@ftp-master.debian.org>
Received: from newraff.debian.org [] (mail)
	by spohr.debian.org with esmtp (Exim 3.35 1 (Debian))
	id 1BMdy5-0005sp-00; Sat, 08 May 2004 19:23:06 -0700
Received: from katie by newraff.debian.org with local (Exim 3.35 1 (Debian))
	id 1BMdsE-0005Fm-00; Sat, 08 May 2004 22:17:02 -0400
From: Martin Michlmayr <tbm@cyrius.com>
To: 224661-close@bugs.debian.org
X-Katie: $Revision: 1.49 $
Subject: Bug#224661: fixed in lvmcfg 0.26
Message-Id: <E1BMdsE-0005Fm-00@newraff.debian.org>
Sender: Archive Administrator <katie@ftp-master.debian.org>
Date: Sat, 08 May 2004 22:17:02 -0400
Delivered-To: 224661-close@bugs.debian.org
X-Spam-Checker-Version: SpamAssassin 2.60-bugs.debian.org_2004_03_25 
	(1.212-2003-09-23-exp) on spohr.debian.org
X-Spam-Status: No, hits=-5.0 required=4.0 tests=BAYES_00,HAS_BUG_NUMBER 
	autolearn=no version=2.60-bugs.debian.org_2004_03_25
X-CrossAssassin-Score: 1

Source: lvmcfg
Source-Version: 0.26

We believe that the bug you reported is fixed in the latest version of
lvmcfg, which is due to be installed in the Debian FTP archive:

  to pool/main/l/lvmcfg/lvmcfg-utils_0.26_all.udeb
  to pool/main/l/lvmcfg/lvmcfg_0.26.dsc
  to pool/main/l/lvmcfg/lvmcfg_0.26.tar.gz
  to pool/main/l/lvmcfg/lvmcfg_0.26_all.udeb

A summary of the changes between this version and the previous one is

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 224661@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
Martin Michlmayr <tbm@cyrius.com> (supplier of updated lvmcfg package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)

Hash: SHA1

Format: 1.7
Date: Sun, 09 May 2004 02:58:39 +0100
Source: lvmcfg
Binary: lvmcfg lvmcfg-utils
Architecture: source all
Version: 0.26
Distribution: unstable
Urgency: low
Maintainer: Debian Install System Team <debian-boot@lists.debian.org>
Changed-By: Martin Michlmayr <tbm@cyrius.com>
 lvmcfg     - Configure the Logical Volume Manager (udeb)
 lvmcfg-utils - lvmcfg without the main menu item (udeb)
Closes: 224661 247147 247995
 lvmcfg (0.26) unstable; urgency=low
   * Martin Michlmayr
     - Support LVM1 and LVM2.
     - Switch to LVM2.  Closes: #224661
     - Honour the "Go Back" button in the PV selection menu.
     - Honour the "Go Back" button in the VG and LV creation menu when
       asking for the name.
     - Print an error when no name for a new VG or LV is given.
       Closes: #247147
     - Use a more reliable method to find out whether to install the
       LVM tools.
     - Fix a typo, noticed by Vince Sanders.
     - Mark more strings for translation, thanks Eugeniy Meshcheryakov.
       Closes: #247995
   * Updated translations:
     - Bulgarian (bg.po) by Ognyan Kulev
     - Czech (cs.po) by Miroslav Kure
     - Danish (da.po) by Claus Hindsgaul
     - German (de.po) by Alwin Meschede
     - Greek (el.po) by Konstantinos Margaritis
     - Spanish (es.po) by Javier Fernandez-Sanguino Peña
     - Basque (eu.po) by Piarres Beobide Egaña
     - French (fr.po) by Michel Grentzinger
     - Japanese (ja.po) by Kenshi Muto
     - Korean (ko.po) by Changwoo Ryu
     - Dutch (nl.po) by Bart Cornelis
     - Norwegian (nn.po) by HÃ¥vard Korsvoll
     - Polish (pl.po) by Bartosz Fenski
     - Portuguese (pt.po) by Miguel Figueiredo
     - Portuguese (Brazil) (pt_BR.po) by André Luís Lopes
     - Romanian (ro.po) by Eddy Petrisor
     - Slovak (sk.po) by Peter KLFMANiK Mann
     - Albanian (sq.po) by Elian Myftiu
     - Ukrainian (uk.po) by Eugeniy Meshcheryakov
     - Simplified Chinese (zh_CN.po) by Carlos Z.F. Liu
 967d5db05fb67918a1fd9a3a437858e4 633 debian-installer optional lvmcfg_0.26.dsc
 e6bb6395324fbd7422211b9ba53eb80c 82682 debian-installer optional lvmcfg_0.26.tar.gz
 b2d806aade089fa9072e3846ce11dbad 2048 debian-installer optional lvmcfg_0.26_all.udeb
 d74936fe5598ff4ff581dfc9b11cfbce 68162 debian-installer optional lvmcfg-utils_0.26_all.udeb
package-type: udeb

Version: GnuPG v1.2.4 (GNU/Linux)


Reply to: