[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#242064: Kernel doesn't like my IDE chipset

Martin Michlmayr, 2004-05-03 02:13:36 +0100 :

> * Roland Mas <lolando@debian.org> [2004-04-04 17:32]:
>> When loading the ide-detect module, the kernel logs show that the hard
>> disk and CD-ROM drive are correctly detected, but then I get lots of
>> "hda: lost interrupt" (same with hdc).  From then on, no hard disk or
>> CD-ROM access manages to get through.  I tried not loading the sis5513
>> module, using the generic module instead, I also tried without even
>> the generic module, no better.  LKML tells me I should try and disable
>> DMA at boot time, but I haven't been able to guess how to do that (I
>> get the same results when using "linux nodma ide=nodma hda=nodma
>> idebus=nodma" and disabling DMA from the BIOS's setup).
> Do Herbert's 2.4.26 or 2.6.5 packages work better?  If not, I'll
> reassign this bug to the kernel package and let Herbert sort it out
> with you.

2.6.5 works fine, 2.4.26 doesn't (although I didn't try all these
nodma voodo rites).

I just tried d-i beta4 (sarge-i386-netinst.iso), and the linux26
method works, but the default one (2.4.something, I supose) still
doesn't.  Again, I didn't try dancing the nodma dance.

Roland Mas

It would be hard to be deader without special training.
  -- in Theatre of Cruelty (Terry Pratchett)

Reply to: