[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#244956: marked as done (Selecting 'Mac Keyboard' fails (expert mode))

Your message dated Tue, 04 May 2004 19:54:36 +0100
with message-id <1083696876.3814.7.camel@coll>
and subject line closing
has caused the attached Bug report to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what I am
talking about this indicates a serious mail system misconfiguration
somewhere.  Please contact me immediately.)

Debian bug tracking system administrator
(administrator, Debian Bugs database)

Received: (at submit) by bugs.debian.org; 20 Apr 2004 17:37:42 +0000
>From giuseppe@eppesuigoccas.homedns.org Tue Apr 20 10:37:42 2004
Return-path: <giuseppe@eppesuigoccas.homedns.org>
Received: from vsmtp1b.tin.it (vsmtp1.tin.it) [] 
	by spohr.debian.org with esmtp (Exim 3.35 1 (Debian))
	id 1BFzBm-00018Z-00; Tue, 20 Apr 2004 10:37:42 -0700
Received: from eppesuigoccas.homedns.org ( by vsmtp1.tin.it (7.0.027) (authenticated as giuseppe.sacco17@tin.it)
        id 407D46DF0010B29B for submit@bugs.debian.org; Tue, 20 Apr 2004 19:37:11 +0200
Received: from giuseppe by eppesuigoccas.homedns.org with local (Exim 3.35 #1 (Debian))
	id 1BFzBL-0006qp-00; Tue, 20 Apr 2004 19:37:15 +0200
Content-Type: text/plain; charset="us-ascii"
MIME-Version: 1.0
Content-Transfer-Encoding: 7bit
From: Giuseppe Sacco <giuseppe@eppesuigoccas.homedns.org>
To: Debian Bug Tracking System <submit@bugs.debian.org>
Subject: installation-reports: partman doesn't work on powerpc
X-Mailer: reportbug 2.56
Date: Tue, 20 Apr 2004 19:37:15 +0200
Message-Id: <E1BFzBL-0006qp-00@eppesuigoccas.homedns.org>
Delivered-To: submit@bugs.debian.org
X-Spam-Checker-Version: SpamAssassin 2.60-bugs.debian.org_2004_03_25 
	(1.212-2003-09-23-exp) on spohr.debian.org
X-Spam-Status: No, hits=-7.0 required=4.0 tests=BAYES_00,HAS_PACKAGE 
	autolearn=no version=2.60-bugs.debian.org_2004_03_25
X-CrossAssassin-Score: 1

Package: installation-reports
Version: daily 20040419
Severity: important


Debian-installer-version: daily 20040419
uname -a: 
Date: 2004-apr-20 18:00 CET
Method: netinst CD image
Machine: Apple PowerBook G4 15"
Processor: 1 PowerPC @ 867Mhz
Memory: 512Mb
Root Device: 
Root Size/partition table:
Output of lspci:
Base System Installation Checklist:

Initial boot worked:    [O]
Configure network HW:   [O]
Config network:         [O]
Detect CD:              [O]
Load installer modules: [O]
Detect hard drives:     [O]
Partition hard drives:  [E]
Create file systems:    [ ]
Mount partitions:       [ ]
Install base system:    [ ]
Install boot loader:    [ ]
Reboot:                 [ ]
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it


I selected 'expert' installation and went trhough the selection of language,
territory and keyboard.

This step isn't working since when I select 'Mac Keyboard' then I get the
'Installation step failed' message.

Both the network adapter (SUNGEM) and the wireless network adapter were found.
I used the cable connection.

Then I went to the partition step. I deleted all my partition and had
40Gb of free space. Then I select 'automatically partition the free space',
I selected 'only one partition' and got a 39.4Gb for / and 512.7Mb for swap.

I then selected 'finish and save' (or something similar) and the new
message was the error 'Partition map has no partition map entry' with
two options. I selected the 'fix' option and got a new error: 'unable to
satisfy all constraints on the partition'. Then I select continue.

The the root partition was formatted as ext3 and I got a new error message:
'the ext3 file system creation in partition #1 of IDE1 master failed.'

At this moment I went back to 'partition disks' menu that was showing me
my selected schema: one root and one swap partition.

I selected again 'finish and write..' and at the next screen I selected 'No',
so I was back at the main menu.

Here i selected again the 'partition disks' menu item and I got again my former
schema! The one I deleted! (Apple, MacOSX. swap, root, home)

So, starting from scrach, I dedided to partition manually my disk: deleted
all partitions again and created all partitions manually, but I then got
the same error about the 'partition map'

At the end I selecte the menu 'configure and mount partition' that lead me
to something like fdisk (but I still had the wrong keyboard layout!) and
'i'installed an partition map. I then went back to 'partition disks' and
found a partition called 'Apple' of 32kb. I think this is the partition map
that I delete previously. It is *very* important that partman will *not*
allow people to remove this partition.

Then I selected to automatically partition the free space and it used the
same schema as before: 39G / and 512M swap. It formatted all partitions and
complained about a missing 'apple_boot' partition required by yaboot. I think
that the automatic partition should create such partition too.

I finally managed to create all partitions but I missed the LVM: while it is
present in the partman menu, it is not possible to mark created partition
as available for LVM. so when I call the LVM menu it complains about missing

When I ended creating all my partitions then I select 'finish partitioning and write ...'
but the installer kept complaining about a missing Apple_boostrap partition of
at least 820kb. The problem was that I did created the partition and it was
more than 820kb and it was marked as NewWorld boot partition.

I then switched back to 'partition a hard drive' to manually create a new partition
map and a new Apple_bootstrap partition. When back to 'partition disks' menu
the Apple_bootstrap partition wasn't recognized and partman suggested to use
it as ext3 file system. (Tough it did not reformat that partition but still
complained about the missing Apple_bootstrap partitiotion).


-- System Information:
Debian Release: testing/unstable
  APT prefers testing
  APT policy: (500, 'testing')
Architecture: i386 (i686)
Kernel: Linux 2.6.3-1-k7
Locale: LANG=it_IT.UTF-8@euro, LC_CTYPE=it_IT.UTF-8@euro

Received: (at 244956-done) by bugs.debian.org; 4 May 2004 18:45:55 +0000
>From mckinstry@computer.org Tue May 04 11:45:54 2004
Return-path: <mckinstry@computer.org>
Received: from (coll) [] 
	by spohr.debian.org with esmtp (Exim 3.35 1 (Debian))
	id 1BL4vS-0004I6-00; Tue, 04 May 2004 11:45:54 -0700
Received: by coll (Postfix, from userid 1000)
	id 604B623949; Tue,  4 May 2004 19:54:36 +0100 (IST)
Subject: closing
From: Alastair McKinstry <mckinstry@computer.org>
To: 244956-done@bugs.debian.org
Content-Type: text/plain
Content-Transfer-Encoding: 7bit
Message-Id: <1083696876.3814.7.camel@coll>
Mime-Version: 1.0
X-Mailer: Ximian Evolution 1.5.7 
Date: Tue, 04 May 2004 19:54:36 +0100
Delivered-To: 244956-done@bugs.debian.org
X-Spam-Checker-Version: SpamAssassin 2.60-bugs.debian.org_2004_03_25 
	(1.212-2003-09-23-exp) on spohr.debian.org
X-Spam-Status: No, hits=-2.0 required=4.0 tests=BAYES_00 autolearn=no 
X-CrossAssassin-Score: 1

- Alastair

Reply to: