[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#246959: d-i beta4 boot problem with sun sparc60

Thomas Poindessous (thomas@poindessous.com) wrote:
> On Sun, May 02, 2004 at 02:19:10PM -0400, Joey Hess wrote:
> > > This is a known problem. You can bypass it by giving a param at silo
> > > boot :
> > > 
> > > linux ramdisk_size=8000
> > 
> > Should this be added to debian-cd?
> maybe, yes.
> but I'm not sure that 8000 is the right value. 

Using 'linux ramdisk_size=8000' initialliy made it boot ok.  Then I ran into
the issue that the SCSI CD-ROM was not detected.  I also noticed that the kernel
at first didn't see the SCSI HD's.

After reseeding those I did a normal reboot and then the unconfigured Solaris 8
on the 1st HD kicked in.  I answered all the questions, so I now've got a working
Solaris 8 system (by the way, it's an Ultra60, not a Sparc60).

Then back to booting debian.  After 'boot cdrom' and 'linux ramdisk_size=8000' it
initially worked except for detecting the SCSI CD-ROM.  I bailed out there by
forcing the box to go back to the 'ok' prompt.

I rebooted back into Solaris and verified I could read CD's.  That worked.

Back into booting debian from the image I get the following error:

    [ ENTER - Boot install ]   [ Type "rescue" - Boot into rescue mode ]
    boot: linux ramdisk_size=8000
    Allocated 8 Megs of memory at 0x40000000 for kernel
    Loaded kernel version 2.4.24
    Loading initial ramdisk (1808523 bytes at 0x40C00000)...
    Illegal Instruction
    {0} ok 

The same happens with the business card image, and also when just using 'linux'.

So, it's one step forward and two steps back. :-(

Ardo van Rangelrooij                                     Debian XML/SGML Group
<ardo@debian.org>              <debian-xml-sgml-devel@lists.alioth.debian.org>
http://people.debian.org/~ardo/      http://debian-xml-sgml.alioth.debian.org/

Reply to: