[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#246327: installation-reports

Package: installation-reports

  Snapshot from 2004-04-27


uname -a: (for now)
  Linux nesini 2.4.25-1-386 #2 Wed Apr 14 19:38:08 EST 2004 i686 GNU/Linux

Date: 2004-04-27

Method: CD/net

Machine:     Dell Dimension 8300 Series
Processor:   Pentium 4 3.0 GHz w/ HT
Memory:      2 Gb DDR

Root Device: SATA disk #2
Root Size/partition table:
  #1 primary 119.4 Gb  ext3  /
  #5 logical 509.9 Mb  swap swap

  [will need to repartition the disk, though]

Output of lspci:
pcilib: Cannot open /sys/bus/pci/devices
0000:00:00.0 Host bridge: Intel Corp. 82875P Memory Controller Hub (rev 02)
0000:00:01.0 PCI bridge: Intel Corp. 82875P Processor to AGP Controller (rev
0000:00:1d.0 USB Controller: Intel Corp. 82801EB/ER (ICH5/ICH5R) USB UHCI #1
(rev 02)
0000:00:1d.1 USB Controller: Intel Corp. 82801EB/ER (ICH5/ICH5R) USB UHCI #2
(rev 02)
0000:00:1d.2 USB Controller: Intel Corp. 82801EB/ER (ICH5/ICH5R) USB UHCI #3
(rev 02)
0000:00:1d.3 USB Controller: Intel Corp. 82801EB/ER (ICH5/ICH5R) USB UHCI #4
(rev 02)
0000:00:1d.7 USB Controller: Intel Corp. 82801EB/ER (ICH5/ICH5R) USB2 EHCI
Controller (rev 02)
0000:00:1e.0 PCI bridge: Intel Corp. 82801BA/CA/DB/EB/ER Hub interface to
PCI Bridge (rev c2)
0000:00:1f.0 ISA bridge: Intel Corp. 82801EB/ER (ICH5/ICH5R) LPC Bridge (rev
0000:00:1f.1 IDE interface: Intel Corp. 82801EB/ER (ICH5/ICH5R) Ultra ATA
100 Storage Controller (rev 02)
0000:00:1f.2 IDE interface: Intel Corp. 82801EB (ICH5) Serial ATA 150
Storage Controller (rev 02)
0000:00:1f.3 SMBus: Intel Corp. 82801EB/ER (ICH5/ICH5R) SMBus Controller
(rev 02)
0000:01:00.0 VGA compatible controller: nVidia Corporation NV34 [GeForce FX
5200] (rev a1)
0000:02:01.0 Modem: Intel Corp.: Unknown device 1080 (rev 04)
0000:02:02.0 Multimedia audio controller: Creative Labs [SB Live! Value]
0000:02:02.1 Input device controller: Creative Labs [SB Live! Value] Input
device controller
0000:02:08.0 Ethernet controller: Intel Corp. 82562EZ 10/100 Ethernet
Controller (rev 02)

Base System Installation Checklist:

Initial boot worked:    [O] [comment]
Configure network HW:   [O]
Config network:         [O]
Detect CD:              [O]
Load installer modules: [O]
Detect hard drives:     [O]
Partition hard drives:  [O] [comment]
Create file systems:    [O]
Mount partitions:       [O]
Install base system:    [O]
Install boot loader:    [O] [comment!]
Reboot:                 [O] [comment!]
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it


* Note on initial boot:
  I tried the initial boot with the linux26 option, but quickly ran
  into trouble when d-i could not detect my CD-ROM drive.

* Partition hard drives
  - d-i claims that 510 MB is the largest swap partition possible,
    which is ludicrous.  (Even Windows has created a ~2 Gb swapfile
    given memory and disk space.)

* Install boot loader

  - Background: I have two disks SATA #1 and #2 and want to use the
    BIOS to switch between boots.  Windows is on #1 and GRUB/Linux
    should be on #2.

  - During installation of GRUB, d-i incorrectly thought that Debian
    was the only OS on the system.  (Windows is on SATA #1.)  I've
    learned that what it really meant is that it was the only OS on
    the *hard drive* (SATA #2).  This is a big difference, because
    eventually it will ask to install GRUB on the MBR of hd0, which
    sounds like it wants to clobber SATA #1!  After playing with GRUB
    edit, I eventually figured out that in this context hd0 apparently
    means Linux disk 0 or SATA #2 instead of SATA #1.

  - What is really scary about this confusion is that d-i then asks
    where to install GRUB using hdn or /dev notation.  I chose hd1,
    intending SATA #2.  For some reason -- and thankfully! -- it
    proceeded to install GRUB on SATA #2.  But, as I explain below, on
    the reboot, GRUB interpreted hd1 as SATA #1!

* Reboot:

  - Initially, there was a major problem.  Here's the error message:
    root (hd1,0)
     Filesystem type unknown, partition type 0xde
    kernel /boot/vmlinuz-2.4.xxx root=/dev/hde1 ro

    Error 17: Cannot mount selected partition

    After liberal use of <TAB> within grub edit, I concluded that GRUB
    thought hd1 was SATA #1, which is why it saw a Dell (0xde) and
    NTFS (0x7) partition, respectively.  When I edited the line to
    boot (hd0,0), Debian proceeded to boot normally.

  - MAJOR BUG: As explained above, I chose to install GRUB on hd1
    (intending SATA #2), but on reboot, GRUB interpreted hd1 as (SATA
    #1).  While I admit I may be confused -- I don't pretend to be an
    expert on boot loaders -- clearly either d-i or GRUB is also
    confused.  This could have really drastic consequences!

Aptitude was setup for woody/stable.  After fixing this to point to
testing, I was able to download some packages.  It seems to work very

  - repartition the disk to create a sane swap file
  - get a 2.6 kernel for HT and memory support
  - fix X; it is dying <sigh>

Reply to: