[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#245012: installation-reports: d-i permit to create file systems not mountable when rebooted

Package: installation-reports
Version: daily 20040419
Severity: important


Debian-installer-version: daily 20040419
uname -a: 
Date: 2004-apr-21 02:00 CET
Method: netinst CD image
Machine: Apple PowerBook G4 15"
Processor: 1 PowerPC @ 867Mhz
Memory: 512Mb
Root Device: 
Root Size/partition table:
Output of lspci:
Base System Installation Checklist:

Initial boot worked:    [O]
Configure network HW:   [O]
Config network:         [O]
Detect CD:              [O]
Load installer modules: [O]
Detect hard drives:     [O]
Partition hard drives:  [O]
Create file systems:    [O]
Mount partitions:       [O]
Install base system:    [O]
Install boot loader:    [E]
Reboot:                 [O]
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it


I installed the complete system on a new XFS partition but was unable of
install yaboot because of #244957. So I rebooted the system using the
installation disk and typed, at the boot prompt:

hd:4 root=/dev/hda4 rw

but the kernel was unable to mount the root partition probably because
XFS isn't compiled into the default kernel (2.4.25-powerpc-pmac).
I reinstalled everthing using ext3 and the new system mounted the root
partition correctly.

I believe that all filesystems offered during the installation need to
be compiled *into* the kernel.

When rebooting (with ext3) I found that /etc/fstab contained only one

After rebooting I kept the installation process until prompted for APT
sources. The system found the installation CD inserted so it indexed it,
but then I was unable to specify a different CD I have because I couldn't
eject the first CD. I had to switch to the second console, login as root,
execute eject, read the error message, find out the device name for the
cdrom, execute 'eject /dev/hdc', switch back to the first console.

Then I selected to do not use aptitude, dselect or apt-get and I still
got a message about installing popularity-context but APT stopped
asking for a cdrom but it couldn't mount it because of the wrong /etc/fstab

After creating /etc/fstab, APT worked correctly.


-- System Information:
Debian Release: testing/unstable
  APT prefers testing
  APT policy: (500, 'testing')
Architecture: i386 (i686)
Kernel: Linux 2.6.3-1-k7
Locale: LANG=it_IT.UTF-8@euro, LC_CTYPE=it_IT.UTF-8@euro

Reply to: