[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#238383: marked as done (Probably it forgets in some circumstances the assigned method and mount point)

Your message dated Sun, 11 Apr 2004 21:47:06 -0400
with message-id <E1BCqXS-00067k-00@newraff.debian.org>
and subject line Bug#238383: fixed in partman-basicfilesystems 22
has caused the attached Bug report to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what I am
talking about this indicates a serious mail system misconfiguration
somewhere.  Please contact me immediately.)

Debian bug tracking system administrator
(administrator, Debian Bugs database)

Received: (at submit) by bugs.debian.org; 11 Mar 2004 23:28:16 +0000
>From tbm@cyrius.com Thu Mar 11 15:28:16 2004
Return-path: <tbm@cyrius.com>
Received: from sorrow.cyrius.com [] 
	by spohr.debian.org with esmtp (Exim 3.35 1 (Debian))
	id 1B1Zb6-0001P3-00; Thu, 11 Mar 2004 15:28:16 -0800
Received: by sorrow.cyrius.com (Postfix, from userid 10)
	id 24D0C64D3A; Thu, 11 Mar 2004 23:28:15 +0000 (UTC)
Received: by deprecation.cyrius.com (Postfix, from userid 1000)
	id 63D88FEC6; Thu, 11 Mar 2004 23:28:03 +0000 (GMT)
Date: Thu, 11 Mar 2004 23:28:03 +0000
From: Martin Michlmayr <tbm@cyrius.com>
To: submit@bugs.debian.org
Subject: inst report: lots of partman and LVM issues
Message-ID: <20040311232803.GA15182@deprecation.cyrius.com>
Mime-Version: 1.0
Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline
User-Agent: Mutt/
Delivered-To: submit@bugs.debian.org
X-Spam-Checker-Version: SpamAssassin 2.60-bugs.debian.org_2004_03_08 
	(1.212-2003-09-23-exp) on spohr.debian.org
X-Spam-Status: No, hits=-7.0 required=4.0 tests=BAYES_00,HAS_PACKAGE 
	autolearn=no version=2.60-bugs.debian.org_2004_03_08

Package: installation-reports


Debian-installer-version: daily sid build from 10-March-2004
uname -a: 2.4.25
Method: boot from IDE CD-ROM, using netinst ISO, installin to SCSI disk

Machine: No-name desktop PC
Processor: P2
Memory: 128 MB
Root Device: SCSI, also has a IDE CD-ROM

Base System Installation Checklist:

Initial boot worked:    [O]
Configure network HW:   [O]
Config network:         [ ] Didn't ask me to configure it even two I have 2 net cards
Detect CD:              [O]
Load installer modules: [O]
Detect hard drives:     [O]
Partition hard drives:  [O] lots of partman and LVM issues
Create file systems:    [O] partman forgot my configurationo
Mount partitions:       [O]
Install base system:    [O]
Install boot loader:    [O]
Reboot:                 [O]
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it


OK, first I wanted to partition the hard drive.  I chose "Automatically
partition a drive", "use entire", "separate partition for $HOME".  Then I
get a menu which says:

 - finish partition and write changes
 - automatically partition
 - undo changes
 - configure lvm

Well, I just did "automatically partition" so I don't think this menu
option should be there again.  Also, the automatic partitioner did not
create a physical volume (PG) for LVM, so the "configure LVM" menu option
should not be there either.

The automatically partitinoner made good default choices, but I don't like
that it decided to use logical partitions.  If it creates 4 or less
partitions, I think only primary partitions should be used.  Instead, it

  #1 primary root
  #5 logical swap
  #6 logical /home

Anyway, I was stupid enough to try LVM (I thought it would allow me to
create a PV), but it only gave me those options:
  Volume Groups
  Logical Volmes

Obviously that failed since I didn't have any Physical Volumes.  Only later
I realized that they have to be created before choosing "configure LVM".
As I said above, this menu entry should not be there if there are no
Physical Volums.

So I choose LVM, and it tell me that it is going to write changes to the
parition before continuing.  Okay.  Then LVM fails because I have no PVs.
So I get back to that menu.  I see those 3 partitions, decide crap, I want
a PV... so I want to configure the partition myself.  I therefore select
"undo changes to partitions", but that does _nothing at all_.   (Later I
realized I could probably have gone to the /home partition, removed it and
created some new stuff; but I didn't realize that I can actually go up
there.)  Anyway, "undo changes" should not be there after the changes have
been written to disk.

Okay, I'm totally confused by now.  I cannot do LVM, undoing my partitions
doesn't undo anything, and I have no idea how to edit my partition.  So I
go to the main menu and choose "Partition disks".  Unfortunately, this
does not start from scratch and ask me if I want to do the automatic stuff
or Be A Man and do it myself... it simply shows me my existing partition.

So I decide to wipe the whole thing with cfdisk and start all over.  Here I
find those menu entries:

    Partition disks
    Partition a hard drive

Very confusing names, imho.  I figured out the former is partman and the
latter cfdisk, but this is not clear to people not familiar with d-i.

Okay, I wipe the disk with cfdisk, and select "Partition disks" again, this
time doing everything myself.  I create a root partition, but decide to say
"do not use".  I create /home, etc... okay, obviously not having a root
sucks, so I go back and say "format", "use XFS" (yeah, I felt
experimental).  When I want to format the partitions, it complains about
XFS being on the root partition, and drops me back.  I choose ext3.  Well,
anyway, I have no idea how I did it, but it simpl forgot that I wanted to
format this partition.  It said "do not use" again, even thought I told
it before to format it.  I saw this several times, so this is not just me.
It complained about "No root file system is defined".

Another thing: when I was so smart not to format my root partition (i.e.
"do not use") the menu showed "ext3" anyway.

Okay, So I have a /, swap and another partition for LVM.  For some reason,
LVM didn't see the PV, so I just ignored LVM for now and decided to go
ahead and format my root partition.  It formats root, checks swap (why does
it check swap?  This is kinda slow), and then installs base.  Okay, but I
really want LVM.  So I choose "Configure LVM" again and now it sees my PV.

So I create a Volume Group (VG).  2 annoying things:
  - this shows devfs style partition names, which so does not fit in with
    part partman showed me before.

  - 1 created one VG, only have one PV, and after creating the VG I was
    back in the "creating and configuring VG groups" menu.  Obviously I
    want to be in the next menu (LV) - I cannot add another VG anyway.

OK, let's create a Logical Volume (LV):

  - I happily type "4GB" - which partman recognizes, but LVM doesn't.
        lvcreate -- ERROR option L argument "4GB"
    Okay, I admit I should have _read_ what the screen says, but this
    feels very awkward.  LVM should recognize the same terms as partman.

  - Also, the size should default to the rest which is still available.
    I had about 6.6 GB in my VG.  So I first did 4G for home, and then
    I wanted to use the rest for scratch.  But I could not easily found
    out _exactly_ what my rest was.  I simply typed 2G, but that left
    100 megs spare.  I think the size question should default to what
    is still available on the VG.

Okay, after doing all of this, and wanting to continue, I get this "No root
file system is defined!" error again.  Again it forgot about my root, which
I had defined.  Okay, let's define it again, format it and the LVM... and
then d-i wants to install GRUB.  Obviously it remembers I installed the
base system before; but I just formated my root, so the base is gone.
well, obviously installing GRUB failed.  So I manually choose "install
base", and installed base and GRUB, and that worked.

Hmm, "install base" installs pcmcia-cs.  This is a desktop PC without

Setting up a user account still does not ask for the real name. (Bug filed
a while ago)

After boot, my LVM physical group was not found.  /etc/lvmtab was empty.

Also, I realize now that the installer never asked me to configure a
network even though I have 2 network cards.

[OK, let's start all over]

Hmm, okay, another issue.  I partition the disk, have a root, swap and one
partition for LVM.  I then configure LVM; it tells me that it has to write
the information to disk, and then happily goes on formating my root
partition.  This skips the usual check asking if you really want to lose
your data.

Oh, it does it again.  I partitioned the disk new, created a root, told it
to use ext3 and use / as mountpoint, then added swap, then a partition for
LVM.  Then I configure LVM, add a VG and some LVs, then get back to the
menu.  I tell it to use the LVs for /home and /scratch, then go to the root
to check, but it says "do not use".  I don't know why it forgets this, but
it seems pretty repeatable.

So I tell it that I really want to us this as root with ext3, go on and
this partition gets formated again.  However, it was formated already when
I chose "configure LVM".  It shouldn't be formated twice.

After reboot, my LVM file systems are again not found.  pvscan simply
doesn't find anything ("no valid physical volumes found"); /dev/sda3 is of
type 83 (Linux LVM), though.   Ohhhhh, probably because lvm10 is installed
instead of lvm2!  Doh!

Hmm, GRUB also uses a difference naming schema for partitions.  partman,
LVM and GRUB/lilo really should use the name schema.

Anyway, partman looks really cute.  There are obviously still some issues,
but that was to be expected.  One thing I felt is that the whole thing felt
rather sluggish.  After making one choice, the whole window is redrawn, and
this seems to be quite slow (and this PC isn't that old).  Also, partman
takes a while to start; but I don't know what exactly it is doing.

Thanks for all the good work.  I'm glad to see cfdisk disappear, at least
on i386 and some other architectures.

Martin Michlmayr

Received: (at 238383-close) by bugs.debian.org; 12 Apr 2004 01:53:02 +0000
>From katie@ftp-master.debian.org Sun Apr 11 18:53:02 2004
Return-path: <katie@ftp-master.debian.org>
Received: from newraff.debian.org [] (mail)
	by spohr.debian.org with esmtp (Exim 3.35 1 (Debian))
	id 1BCqdC-0000h8-00; Sun, 11 Apr 2004 18:53:02 -0700
Received: from katie by newraff.debian.org with local (Exim 3.35 1 (Debian))
	id 1BCqXS-00067k-00; Sun, 11 Apr 2004 21:47:06 -0400
From: Joey Hess <joeyh@debian.org>
To: 238383-close@bugs.debian.org
X-Katie: $Revision: 1.47 $
Subject: Bug#238383: fixed in partman-basicfilesystems 22
Message-Id: <E1BCqXS-00067k-00@newraff.debian.org>
Sender: Archive Administrator <katie@ftp-master.debian.org>
Date: Sun, 11 Apr 2004 21:47:06 -0400
Delivered-To: 238383-close@bugs.debian.org
X-Spam-Checker-Version: SpamAssassin 2.60-bugs.debian.org_2004_03_25 
	(1.212-2003-09-23-exp) on spohr.debian.org
X-Spam-Status: No, hits=-5.0 required=4.0 tests=BAYES_00,HAS_BUG_NUMBER 
	autolearn=no version=2.60-bugs.debian.org_2004_03_25
X-CrossAssassin-Score: 3

Source: partman-basicfilesystems
Source-Version: 22

We believe that the bug you reported is fixed in the latest version of
partman-basicfilesystems, which is due to be installed in the Debian FTP archive:

  to pool/main/p/partman-basicfilesystems/partman-basicfilesystems_22.dsc
  to pool/main/p/partman-basicfilesystems/partman-basicfilesystems_22.tar.gz
  to pool/main/p/partman-basicfilesystems/partman-basicfilesystems_22_all.udeb

A summary of the changes between this version and the previous one is

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 238383@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
Joey Hess <joeyh@debian.org> (supplier of updated partman-basicfilesystems package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)

Hash: SHA1

Format: 1.7
Date: Sun, 11 Apr 2004 21:23:17 -0400
Source: partman-basicfilesystems
Binary: partman-basicfilesystems
Architecture: source all
Version: 22
Distribution: unstable
Urgency: low
Maintainer: Debian Install System Team <debian-boot@lists.debian.org>
Changed-By: Joey Hess <joeyh@debian.org>
 partman-basicfilesystems - Add to partman support for ext2, linux-swap, fat16 and fat32 (udeb)
Closes: 235371 238062 238383 238385 239387
 partman-basicfilesystems (22) unstable; urgency=low
   * Anton Zinoviev
     - the formatting progress bar provides feedback on the mount point
       (when such is assigned).
     - the same change is made to partman-ext3, partman-reiserfs and
       partman-xfs.  Thanks to Sven Luther (closes: #238062).
     - new method `swap'; the swap is not a file system any more.  Thanks
       to Joey Hess (closes: #235371).
     - make the file system name in the check progress bar translatable.
     - the script update.d/swap_mountpoint is obsoleted and removed.
       I hope this closes: #238383, thanks to Martin Michlmayr.
     - show `swap' as mount point for swap partitions.  Thanks to Frans Pop,
       closes: #239387
     - rules: remove .svn directories from the package
     - commit.d/format_*: do not format already formatted partitions for
       second time.
     - the same change is made in partman-ext3, partman-reiserfs and
       partman-xfs.  Thanks to Martin Michlmayr (closes: #238385).
   * Joshua Kwan
     - switch to new debhelper udeb support
   * Updated translations:
     - Czech (cs.po) by Miroslav Kure
     - Danish (da.po) by Claus Hindsgaul
     - Greek, Modern (1453-) (el.po) by Konstantinos Margaritis
     - Basque (eu.po) by Piarres Beobide Egaña
     - French (fr.po) by Christian Perrier
     - Hebrew (he.po) by Lior Kaplan
     - Hungarian (hu.po) by VER�K István
     - Italian (it.po) by Stefano Canepa
     - Japanese (ja.po) by Kenshi Muto
     - Korean (ko.po) by Changwoo Ryu
     - Lithuanian (lt.po) by KÄ?stutis BiliÅ«nas
     - Dutch (nl.po) by Bart Cornelis
     - Polish (pl.po) by Bartosz Fenski
     - Portuguese (pt.po) by Miguel Figueiredo
     - Portuguese (Brazil) (pt_BR.po) by André Luís Lopes
     - Romanian (ro.po) by Eddy Petrisor
     - Slovak (sk.po) by Peter KLFMANiK Mann
     - Albanian (sq.po) by Elian Myftiu
     - Swedish (sv.po) by André Dahlqvist
     - Turkish (tr.po) by Osman Yüksel
     - Ukrainian (uk.po) by Eugeniy Meshcheryakov
     - Simplified Chinese (zh_CN.po) by Carlos Z.F. Liu
     - Traditional Chinese (zh_TW.po) by Tetralet
 289424c2cea48509708e3eb4eb5ed65b 660 debian-installer standard partman-basicfilesystems_22.dsc
 2a94592fb7b238235442e5a8c3314154 64651 debian-installer standard partman-basicfilesystems_22.tar.gz
 ff3035721c474af4951689ff85869566 34146 debian-installer standard partman-basicfilesystems_22_all.udeb
package-type: udeb

Version: GnuPG v1.2.4 (GNU/Linux)


Reply to: