[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#242659: d-i errors on alpha

hey steve,

thanks for your response and usefull bugs pointer!

On Thu, 08 Apr 2004, Steve Langasek wrote:
> > 3) at this stage i strongly missed a menu-entry for aboot at d-i!!
> (!)  I'll have to take a look at this; last I was able to test, aboot
> showed up right where it was supposed to in the menu, you just can't get
> it to run from the menu unless the base install has completed
> successfully.

2 curious questions:
* what is base install supposed to do ..  beside dpkg -i the base deb?
i had at this stage a working chroot with apt-get inside
and could install sshd for example.

* abootconf /dev/sda 2 showed some strange lseek error,
(the machine is abootable .. had previously woody)
swriteboot /dev/sda bootlx vmlinuz -f1
worked (modulo pathes for kernel and bootlx)
at this stage i probably forgot to write a nice aboot.conf
and the INSTALL file from aboot recommends to use
swriteboot -c2 /dev/sda bootlx

the problem now was that the kernel panicked, because it couldn't find
it's root fs .. tried lots of bootargs from aboot 
root=/scsi/host0/bus0/target0/lun0/part2 .. or root=/dev/sda2
in combination with the initrd=/boot/initrd.gz arg.
does a devfs=no help at that point ?
tried also to boot via dka d-i cdrom or a woody rescue floppy disk ..

regards maks

Reply to: