[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#224634: marked as done (discover loads ide-scsi module, which prevents apt from accessing some ide cdroms)

Your message dated Tue, 06 Apr 2004 01:02:07 -0400
with message-id <E1BAiit-0003R2-00@newraff.debian.org>
and subject line Bug#221983: fixed in discover1 1.5-8
has caused the attached Bug report to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what I am
talking about this indicates a serious mail system misconfiguration
somewhere.  Please contact me immediately.)

Debian bug tracking system administrator
(administrator, Debian Bugs database)

Received: (at submit) by bugs.debian.org; 10 Dec 2003 23:36:42 +0000
>From barriedjames@worldonline.co.uk Wed Dec 10 17:36:38 2003
Return-path: <barriedjames@worldonline.co.uk>
Received: from mk-smarthost-3.mail.uk.tiscali.com [] 
	by master.debian.org with esmtp (Exim 3.35 1 (Debian))
	id 1AUCsf-0001rZ-00; Wed, 10 Dec 2003 16:32:29 -0600
Received: from [] (helo=ceredigion.acorns.net)
	by mk-smarthost-3.mail.uk.tiscali.com with esmtp (Exim 4.24)
	id 1AUCsb-0009aL-Lq
	for submit@bugs.debian.org; Wed, 10 Dec 2003 22:32:26 +0000
From: Barrie James <barriedjames@worldonline.co.uk>
To: submit@bugs.debian.org
Subject: Installer Report - CD boot problem, IDE_SCSI module prevents IDE CDROM mounting, and inflexibility in options - but good hardware detection and working sound.
Date: Wed, 10 Dec 2003 22:34:04 +0000
User-Agent: KMail/1.5.4
MIME-Version: 1.0
Content-Type: text/plain;
Content-Transfer-Encoding: quoted-printable
Content-Disposition: inline
Message-Id: <200312102234.05087.barriedjames@worldonline.co.uk>
Delivered-To: submit@bugs.debian.org
X-Spam-Checker-Version: SpamAssassin 
	(1.212-2003-09-23-exp) on master.debian.org
X-Spam-Status: No, hits=-5.0 required=4.0 tests=HAS_PACKAGE autolearn=no 


Debian-installer-version: download 21 November - http://gluck.debian.org/
cdimage/testing/netinst/i386/beta-1/sarge-i386-netinst.iso 100MB
uname -a: Linux localhost 2.4.22-1-386 #9 Sat Oct 4 14:30:39 EST 2003 i686=
Date: 25 or 26 Nov.
Method: Tried to boot CD (see comments), failed, and then used floppy image=
boot the CD.
Machine: Self-build. EPOX 8KHA+ Mobo (VIA KT266A, VT8366A and VT8233 onboar=
Processor: AMD XP 1600+
Memory: 256MB DDR
Root Device: IDE (IBM ATA100 HDD) : /dev/hda13
Root Size/partition table: A 5GB single partition on an existing extended=20
Output of lspci:=20
00:00.0 Host bridge: VIA Technologies, Inc. VT8366/A/7 [Apollo KT266/A/333]
00:01.0 PCI bridge: VIA Technologies, Inc. VT8366/A/7 [Apollo KT266/A/333 A=
00:0d.0 Ethernet controller: 3Com Corporation 3cSOHO100-TX Hurricane (rev 3=
00:11.0 ISA bridge: VIA Technologies, Inc. VT8233 PCI to ISA Bridge
00:11.1 IDE interface: VIA Technologies, Inc. VT82C586A/B/VT82C686/A/B/VT82=
A/C/VT8235 PIPC Bus Master IDE (rev 06)
00:11.2 USB Controller: VIA Technologies, Inc. USB (rev 1b)
00:11.3 USB Controller: VIA Technologies, Inc. USB (rev 1b)
00:11.4 USB Controller: VIA Technologies, Inc. USB (rev 1b)
00:11.5 Multimedia audio controller: VIA Technologies, Inc. VT8233/A/8235 A=
Audio Controller (rev 30)
01:00.0 VGA compatible controller: Matrox Graphics, Inc. MGA G400 AGP (rev =

Base System Installation Checklist:

Initial boot worked: =A0 =A0[E]
Configure network HW: =A0 [O]
Config network: =A0 =A0 =A0 =A0 [E]
Detect CD: =A0 =A0 =A0 =A0 =A0 =A0 =A0[E]
Load installer modules: [O]
Detect hard drives: =A0 =A0 [O]
Partition hard drives: =A0[ ]
Create file systems: =A0 =A0[O]
Mount partitions: =A0 =A0 =A0 [O]
Install base system: =A0 =A0[O]
Install boot loader: =A0 =A0[E]
Reboot: =A0 =A0 =A0 =A0 =A0 =A0 =A0 =A0 [O]
[O] =3D OK, [E] =3D Error (please elaborate below), [ ] =3D didn't try it

1) This is the first CD that has ever failed to boot on my system. It boote=
d a=20
laptop OK, but my system failed completely. I've installed a range of distr=
on this box - Potato, Woody r0, Woody r1, Slackware 8, 9, 9.1, Mandrake 8.1=
8.2, 9 without any problems booting. I had the first few Sarge unofficial C=
from the .hu mirror and the first of these booted fine. The boot device=20
selector floppy image on the installer CD solved the problem and I was able=
to start the process from the CD after booting the floppy.
2) I suffered the IDE-SCSI module problem (which I hadn't seen at the time)=
As I had got a few of the unofficial Sarge CDs I intended to register them =
apt sources during the install, but this failed. Following the reboot it wa=
clear that this was down to the IDE CD not being mounted. I got round it by=
simply removing the IDE-SCSI module and accessing the CD drive was was then=
3) The network configure with dhcp wouldn't let me leave it unconfigured. I=
have a separate Linux firewall connected by ethernet so my system is a stat=
network with NAT on the firewall. I got around the installer throwing me ba=
to the start of the dhcp config section by skipping ahead to network=20
configuration without dhcp and after this it was ok.
4) I tried to avoid LILO but it refused to let me. I didn't want to re-writ=
my mbr so put /dev/fd0 as the LILO target. It didn't like this for some=20
reason. I then skipped ahead to the GRUB section and set this to a floppy=20
which was OK.
5) My onboard VIA8233 sound chip has given quite a few Debian users a probl=
(as a quick google search will show), and the only real solution has been=20
installing ALSA and recompiling the kernel - no big deal, but inconvenient=
compared to other distros which use ALSA and manage to get sound configured=
in the initial install. It's encouraging that the new Debian Installer=20
managed to get sound working, although it uses the VIA 82cxxx module which=
isn't correct (Knoppix will happily boot my machine and also gets sound=20
running on the VIA 82cxxx module) I haven't had a chance yet to really test=
the sound capabilities, but it does seem fine - a great result for a Debian=

Conclusion : I had several problems, and can't say I particularly liked the=
installer. The hardware detection is certainly improved and is a very=20
positive aspect, but the way that a couple of specific steps tried to preve=
me leaving them was a negative. I doubt that a newbie would have a happy ti=
with the installer on my box.

Suggestions : I'm surprised the network config is split into 2 sections, dh=
and static. I would have thought that this would be 2 options in a single=20
section, maybe with dial-up as a further option as a lot of Debian users wi=
have dial-up as their only network connection. I would also make a floppy a=
prominent option for LILO or GRUB - if you already have a working system I=
think it makes more sense to use a floppy for the first couple of boots=20
rather than overwriting the mbr during a new install.

Received: (at 221983-close) by bugs.debian.org; 6 Apr 2004 05:08:04 +0000
>From katie@ftp-master.debian.org Mon Apr 05 22:08:04 2004
Return-path: <katie@ftp-master.debian.org>
Received: from newraff.debian.org [] (mail)
	by spohr.debian.org with esmtp (Exim 3.35 1 (Debian))
	id 1BAioe-0002Xz-00; Mon, 05 Apr 2004 22:08:04 -0700
Received: from katie by newraff.debian.org with local (Exim 3.35 1 (Debian))
	id 1BAiit-0003R2-00; Tue, 06 Apr 2004 01:02:07 -0400
From: David Nusinow <david_nusinow@yahoo.com>
To: 221983-close@bugs.debian.org
X-Katie: $Revision: 1.46 $
Subject: Bug#221983: fixed in discover1 1.5-8
Message-Id: <E1BAiit-0003R2-00@newraff.debian.org>
Sender: Archive Administrator <katie@ftp-master.debian.org>
Date: Tue, 06 Apr 2004 01:02:07 -0400
Delivered-To: 221983-close@bugs.debian.org
X-Spam-Checker-Version: SpamAssassin 2.60-bugs.debian.org_2004_03_25 
	(1.212-2003-09-23-exp) on spohr.debian.org
X-Spam-Status: No, hits=-1.3 required=4.0 tests=BAYES_00,FORGED_YAHOO_RCVD,
	HAS_BUG_NUMBER autolearn=no version=2.60-bugs.debian.org_2004_03_25
X-CrossAssassin-Scores: 10 10

Source: discover1
Source-Version: 1.5-8

We believe that the bug you reported is fixed in the latest version of
discover1, which is due to be installed in the Debian FTP archive:

  to pool/main/d/discover1/discover1-udeb_1.5-8_i386.udeb
  to pool/main/d/discover1/discover1_1.5-8.diff.gz
  to pool/main/d/discover1/discover1_1.5-8.dsc
  to pool/main/d/discover1/discover1_1.5-8_i386.deb
  to pool/main/d/discover1/libdiscover1-dev_1.5-8_i386.deb
  to pool/main/d/discover1/libdiscover1-pic_1.5-8_i386.deb
  to pool/main/d/discover1/libdiscover1_1.5-8_i386.deb

A summary of the changes between this version and the previous one is

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 221983@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
David Nusinow <david_nusinow@yahoo.com> (supplier of updated discover1 package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)

Hash: SHA1

Format: 1.7
Date: Tue,  6 Apr 2004 00:06:52 -0400
Source: discover1
Binary: libdiscover1 discover1 libdiscover1-pic discover1-udeb libdiscover1-dev
Architecture: source i386
Version: 1.5-8
Distribution: unstable
Urgency: low
Maintainer: Debian Install System Team <debian-boot@lists.debian.org>
Changed-By: David Nusinow <david_nusinow@yahoo.com>
 discover1  - hardware identification system
 discover1-udeb - hardware identification library (udeb) (udeb)
 libdiscover1 - hardware identification library
 libdiscover1-dev - hardware identification library development files
 libdiscover1-pic - hardware identification library - static PIC version
Closes: 152604 160658 166460 178944 201695 213866 214622 220704 220936 221983 224634 238472 240308 241840 241841
 discover1 (1.5-8) unstable; urgency=low
   * Petter Reinholdtsen
     - Add lspci(8) in SEE ALSO section of discover.8. (Closes: #213866)
     - Fix SMP CPU detection.  Patch from Thomas Poindessous. (Closes: #160658)
     - Make sure to install /usr/share/discover/linuxrc with execute
       bit set.  (Closes: #152604)
   * David Nusinow
     - Conflicts with libdiscover2; Closes: #241840
     - Translate hyphens to underscores in post-2.4 kernels in order to
       properly detect if they are loaded already
     - Use fantastic reworkings of init script to not require /usr to be
       mounted, as well as allowing multiple modules to be listed on a single
       skip line in discover.conf; Closes: #166460, #214622, #178944
     - skip i810-tco module by default in discover.conf. Also remove example
       foobar module line that was there previously. This keeps the discover
       database complete, which is preferrable; Closes: #238472
     - Check for /dev/sr in addition to /dev/scd; Closes: #201695, #221983
       Closes: #224634, #220936, #220704
   * Translations
     - Eddy Petrysor
       - Updated Romanian program translation (po/ro.po)
     - Javier Fernandez-Sanguino Peña
       - Added Spanish debconf translation (debian/po/es.po). (Closes: #240308)
     - Claus Hindsgaul
       - Updated Danish debconf translation (debian/po/da.po). (Closes: #241841)
 0977505163084a28c70f7a6bb2b9b5ce 1451 admin optional discover1_1.5-8.dsc
 9d3ba7351c840e5ba566dd9e93e96cb4 89219 admin optional discover1_1.5-8.diff.gz
 bd752acc326cff7fb318ca779e16a51a 34174 debian-installer extra discover1-udeb_1.5-8_i386.udeb
 581c963094a6b7a81c2860006a3e0243 78678 admin optional discover1_1.5-8_i386.deb
 a64ad27564ef8091877da60ed975d7e7 82058 libs optional libdiscover1_1.5-8_i386.deb
 b123543a01ee4b35cb7bede2c12bd0be 61392 libdevel optional libdiscover1-dev_1.5-8_i386.deb
 9f41ed42c8ba4396bbc0dc86b5fb31b3 60326 libs extra libdiscover1-pic_1.5-8_i386.deb

Version: GnuPG v1.2.4 (GNU/Linux)
Comment: http://triplehelix.org/~joshk/pubkey_gpg.asc


Reply to: