[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#242064: Kernel doesn't like my IDE chipset

Package: installation-reports
Debian-installer-version: beta3
uname -a: 2.4.25-1-386 #1 Tue Feb 24 00:11:13 EST 2004 i686 unknown
Date: 2004-04-04
Method: Booted off the businesscard CD-ROM (IDE/hdc)
Machine: Custom-made
Processor: Duron 1600
Memory: 256 MB
Root Device: IDE (hda)
Root Size/partition table:  hda1 is 10 GB, but that's not very relevant
Output of lspci: 
| 00:00.0 Host bridge: Silicon Integrated Systems [SiS] 746 Host (rev 10)
| 00:01.0 PCI bridge: Silicon Integrated Systems [SiS] SG86C202
| 00:02.0 ISA bridge: Silicon Integrated Systems [SiS]: Unknown device 0963 (rev 25)
| 00:02.1 SMBus: Silicon Integrated Systems [SiS]: Unknown device 0016
| 00:02.5 IDE interface: Silicon Integrated Systems [SiS] 5513 [IDE]
| 00:02.7 Multimedia audio controller: Silicon Integrated Systems [SiS] Sound Controller (rev a0)
| 00:03.0 USB Controller: Silicon Integrated Systems [SiS] USB 1.0 Controller (rev 0f)
| 00:03.1 USB Controller: Silicon Integrated Systems [SiS] USB 1.0 Controller (rev 0f)
| 00:03.2 USB Controller: Silicon Integrated Systems [SiS] USB 2.0 Controller
| 00:04.0 Ethernet controller: Silicon Integrated Systems [SiS] SiS900 10/100 Ethernet (rev 91)
| 01:00.0 VGA compatible controller: ATI Technologies Inc Radeon RV100 QY [Radeon 7000/VE]
Base System Installation Checklist:
Initial boot worked:    [O]
Configure network HW:   [ ]
Config network:         [ ]
Detect CD:              [O]
Load installer modules: [O]
Detect hard drives:     [O]
Partition hard drives:  [ ]
Create file systems:    [ ]
Mount partitions:       [ ]
Install base system:    [ ]
Install boot loader:    [ ]
Reboot:                 [ ]
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it
When loading the ide-detect module, the kernel logs show that the hard
disk and CD-ROM drive are correctly detected, but then I get lots of
"hda: lost interrupt" (same with hdc).  From then on, no hard disk or
CD-ROM access manages to get through.  I tried not loading the sis5513
module, using the generic module instead, I also tried without even
the generic module, no better.  LKML tells me I should try and disable
DMA at boot time, but I haven't been able to guess how to do that (I
get the same results when using "linux nodma ide=nodma hda=nodma
idebus=nodma" and disabling DMA from the BIOS's setup).

The kernel on beta2 (2.4.21 or 2.4.22, I think) works better on this
particular box (well, at least until network enters the game -- the
on-board LAN chipset uses FF:FF:FF:FF:FF:FF as its MAC address, which
causes problems for data transmission and reception).

Roland Mas

Au royaume des aveugles, il y a des borgnes à ne pas dépasser.
  -- in Soeur Marie-Thérèse des Batignolles (Maëster)

Reply to: