[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#240842: Sarge i386 netinst can't configure PCMCIA network card

Package: installation-reports

Debian-installer-version: http://gluck.debian.org/cdimage/testing/sarge_d-i/i386/beta3/sarge-i386-netinst.iso
uname -a: Linux rumba 2.4.25-1-686 #1 Tue Feb 24 10:55:59 EST 2004 i686 GNU/Linux
Date: 2004-03-29, 10:00 UTC
Method: Boot from above mentioned ISO image

Machine: IBM Thinkpad 600E with xirc2ps_cs network card
Processor: Mobile Pentium II, 400 MHz
Memory: 288884 kB
Root Device: TOSHIBA CD-ROM XM-1902B on /dev/hdc
Root Size/partition table: 
        Filesystem            Size  Used Avail Use% Mounted on
        /dev/hda1             4.2G  2.0G  2.1G  49% /
        tmpfs                 142M     0  142M   0% /dev/shm
        /dev/hda3             4.7G  2.4G  2.1G  54% /home

Output of lspci:

pcilib: Cannot open /sys/bus/pci/devices
0000:00:00.0 Host bridge: Intel Corp. 440BX/ZX/DX - 82443BX/ZX/DX Host bridge (rev 03)
0000:00:01.0 PCI bridge: Intel Corp. 440BX/ZX/DX - 82443BX/ZX/DX AGP bridge (rev 03)
0000:00:02.0 CardBus bridge: Texas Instruments PCI1251A
0000:00:02.1 CardBus bridge: Texas Instruments PCI1251A
0000:00:06.0 Multimedia audio controller: Cirrus Logic CS 4610/11 [CrystalClear SoundFusion Audio Accelerator] (rev 01)
0000:00:07.0 Bridge: Intel Corp. 82371AB/EB/MB PIIX4 ISA (rev 02)
0000:00:07.1 IDE interface: Intel Corp. 82371AB/EB/MB PIIX4 IDE (rev 01)
0000:00:07.2 USB Controller: Intel Corp. 82371AB/EB/MB PIIX4 USB (rev 01)
0000:00:07.3 Bridge: Intel Corp. 82371AB/EB/MB PIIX4 ACPI (rev 02)
0000:01:00.0 VGA compatible controller: Neomagic Corporation NM2200 [MagicGraph 256AV] (rev 20)

Base System Installation Checklist:

Initial boot worked:    [O]
Configure network HW:   [E]
Config network:         [E]
Detect CD:              [O]
Load installer modules: [O]
Detect hard drives:     [O]
Partition hard drives:  [O]
Create file systems:    [O]
Mount partitions:       [O]
Install base system:    [O]
Install boot loader:    [O]
Reboot:                 [E]
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it


The problem was that it couldn't configure the network.  Going into a
shell showed that cardmgr would say "no sockets found!", like this:

    Mar 26 17:22:18 rumba cardmgr[836]: starting, version is 3.1.33
    Mar 26 17:22:19 rumba cardmgr[836]: no sockets found!
    Mar 26 17:22:19 rumba cardmgr[836]: exiting

Originally, I thought it was the wrong kernel module.  I tried many
things, most of which I've forgotten now.  But then, I managed to
upgrade the whole system to unstable, and that did it.  I /think/ it
was the upgrade of pcmcia-cs to 3.2.5-2.5, but of course I'm not sure
whether it was this package or perhaps another package.

I'm reluctant to wipe the installation to try again, with just the
newer pcmcia-cs.  (This is my main machine that I need to work on
every day.)  But if you make a new image with the more recent
pcmcia-cs included, then I can try to boot it to see if that fixes
the problem.

I hope I managed to describe this well enough.  In the best luser
manner, I managed not to keep track of what I did.  Maybe I can
convince myself to try another install, now that I know how to fix


Reply to: