[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#239183: Installation report: beta 3, LVM root and boot.

Package: installation-reports

Debian-installer-version: Beta 3 (2004-03-17)
uname -a: Linux mere-device 2.4.25-1-686 #1 Tue Feb 24 10:55:59 EST 2004 i686 GNU/Linux
Date: 2004-03-20
Method: hd-media, sarge-i386-businesscard.iso, booting with grub.

Machine: Generic Pentium II from 1999, Intel 440BX motherboard
Processor: Pentium II 400MHz
Memory: 128MB
Root Device: LVM volume on IDE hda
Root Size/partition table:
   Device Boot Start     End   #cyls    #blocks   Id  System
/dev/hda1          0+   1202    1203-   9663066   8e  Linux LVM
/dev/hda2          0       -       0          0    0  Empty
/dev/hda3          0       -       0          0    0  Empty
/dev/hda4   *   1203    1231      29     232942+   5  Extended
/dev/hda5       1203+   1231      29-    232911   83  Linux

LVM volumes:
Disk /dev/vg00/root: 32 cylinders, 128 heads, 128 sectors/track
Disk /dev/vg00/var: 128 cylinders, 128 heads, 128 sectors/track
Disk /dev/vg00/usr: 500 cylinders, 128 heads, 128 sectors/track
Disk /dev/vg00/home: 512 cylinders, 128 heads, 128 sectors/track

Output of lspci:
00:00.0 Host bridge: Intel Corp. 440BX/ZX/DX - 82443BX/ZX/DX Host bridge (rev 03)
00:01.0 PCI bridge: Intel Corp. 440BX/ZX/DX - 82443BX/ZX/DX AGP bridge (rev 03)
00:07.0 ISA bridge: Intel Corp. 82371AB/EB/MB PIIX4 ISA (rev 02)
00:07.1 IDE interface: Intel Corp. 82371AB/EB/MB PIIX4 IDE (rev 01)
00:07.2 USB Controller: Intel Corp. 82371AB/EB/MB PIIX4 USB (rev 01)
00:07.3 Bridge: Intel Corp. 82371AB/EB/MB PIIX4 ACPI (rev 02)
00:10.0 PCI bridge: PicoPower Technology PT86C525 [Nile-II] PCI-to-PCI Bridge (rev 01)
00:11.0 Multimedia audio controller: Ensoniq ES1370 [AudioPCI] (rev 01)
00:12.0 Ethernet controller: NetVin NV5000SC
01:00.0 VGA compatible controller: ATI Technologies Inc Rage 128 PF/PRO AGP 4x TMDS
02:08.0 SCSI storage controller: Advanced System Products, Inc ABP940-U / ABP960-U (rev 03)
02:09.0 Multimedia video controller: Zoran Corporation ZR36057PQC Video cutting chipset (rev 02)

Base System Installation Checklist:

Initial boot worked:    [O]
Configure network HW:   [O]
Config network:         [O]
Detect CD:              [ ]
Load installer modules: [O]
Detect hard drives:     [O]
Partition hard drives:  [E]
Create file systems:    [O]
Mount partitions:       [O]
Install base system:    [E]
Install boot loader:    [?]
Reboot:                 [E]
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it


Partition hard drives:

For this installation, I was trying to put all filesystems on LVM.

I created a single primary partition and set it to be an LVM physical volume.
I left hda5 alone as it was mounted for the hd-media install.

I chose to configure LVM and tried to create a volume group, but it said no
physical volumes were found. Console 3 says:
  pvscan -- no valid physical volumes found
So I ran
  pvcreate /dev/hda1
in a shell, and it let me configure LVM and then create the file systems.

Install base system:

When the base system install reached the kernel, I chose
kernel-image-2.4.25-1-686. Installation failed with error
  mkinitrd: constituent device /dev/vg00/root does not exist!

(cf bug 237466).

So I started again, and while the base system installation paused to offer me
a choice of kernel, I did the following:
  mkdir /target/dev/vg00
  cd /target/dev/vg00
  mknod group c 109 0
  mknod root b 58 0
  mknod var b 58 1
  mknod usr b 58 2
  mknod home b 58 3

  chroot /target
  apt-get install lvm-common
  apt-get install lvm10

(This also brings in binutils, file, and libmagic1.)

This time the kernel installed without errors and the base system install

Then I ran
  apt-get install devfsd
inside the chroot, because a debconf note in one of the lvm packages advised it.

Install boot loader:

When it gave me a dialog asking where to install grub, I chose to cancel and
install lilo instead, because I needed support for booting from an LVM volume.

I chose to install lilo from the main menu. I accepted the default selection
for root as /dev/vg00/root. This installation appeared to complete
successfully. But I didn't see an /etc/lilo.conf in the target afterwards, so
I wrote my own and ran lilo by hand:




I chose the reboot option from the main menu.

I was shown a message saying

<< Are you sure you want to reboot now? If you have not finished the install,
your system may be left in an unusable state. >>

As far as I could tell, I had finished the install (there were no further
entries in the main menu), so I chose to reboot.

The machine rebooted successfully, but instead of continuing with base-config,
I was left at the login prompt.

Some things were still unconfigured: /etc/network/interfaces was empty, and
/etc/console/boottime.kmap was missing.

I fixed these and then ran base-config by hand. The installation completed

There is no /var/log/debian-installer, but I have preserved the following logs
from just before the reboot:


In the partitioner, there is a dialog in which you choose the usage method,
file system, mount point and so on for a partition. It would be useful if this
dialog could show somewhere which partition it is manipulating. When I was
using this dialog with the LVM partitions, it was sometimes difficult to
remember which one I was dealing with when I had to select the mount point.

Reply to: