[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#222791: marked as done (INSTALL REPORT - problems)

Your message dated Tue, 16 Mar 2004 00:26:45 -0500
with message-id <20040316052645.GA30950@kitenet.net>
and subject line fixed in beta 3
has caused the attached Bug report to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what I am
talking about this indicates a serious mail system misconfiguration
somewhere.  Please contact me immediately.)

Debian bug tracking system administrator
(administrator, Debian Bugs database)

Received: (at submit) by bugs.debian.org; 3 Dec 2003 11:05:24 +0000
>From jeffw@globaldial.com Wed Dec 03 05:05:23 2003
Return-path: <jeffw@globaldial.com>
Received: from mail45-s.fg.online.no (mail45.fg.online.no) [] 
	by master.debian.org with esmtp (Exim 3.35 1 (Debian))
	id 1ARUot-0008Nz-00; Wed, 03 Dec 2003 05:05:23 -0600
Received: from globaldial.com (ti400720a080-2131.bb.online.no [])
	by mail45.fg.online.no (8.9.3p2/8.9.3) with ESMTP id MAA02262
	for <submit@bugs.debian.org>; Wed, 3 Dec 2003 12:05:17 +0100 (MET)
Message-ID: <3FCDC358.3050209@globaldial.com>
Date: Wed, 03 Dec 2003 12:04:56 +0100
From: Jeff Williams <jeffw@globaldial.com>
User-Agent: Mozilla/5.0 (X11; U; Linux ppc; en-US; rv:1.5) Gecko/20031110 Debian/1.5-3
X-Accept-Language: en
MIME-Version: 1.0
To: submit@bugs.debian.org
Subject: INSTALL REPORT - problems
Content-Type: text/plain; charset=ISO-8859-1; format=flowed
Content-Transfer-Encoding: 7bit
Delivered-To: submit@bugs.debian.org
X-Spam-Checker-Version: SpamAssassin 
	(1.212-2003-09-23-exp) on master.debian.org
X-Spam-Status: No, hits=-4.0 required=4.0 tests=BAYES_99,HAS_PACKAGE 

Package: installation-reports
Version: beta1


Debian-installer-version: beta1
uname -a: Linux killbill 2.4.22-powerpc #1 Sat Sep 27 04:08:08 CEST 2003 
ppc GNU/Linux
Date: 2003-12-2 22:00
Method: Boot from 100 MB CD image, includes Debian base.
    Install from ftp.no.debian.org

Machine: Apple iBook
Processor: /proc/cpuinfo
cpu             : 750FX
temperature     : 14-18 C (uncalibrated)
clock           : 900MHz
revision        : 2.3 (pvr 7000 0203)
bogomips        : 1782.57
machine         : PowerBook4,3
motherboard     : PowerBook4,3 MacRISC2 MacRISC Power Macintosh
detected as     : 257 (iBook 2 rev. 2)
pmac flags      : 0000000b
L2 cache        : 512K unified
memory          : 128MB
pmac-generation : NewWorld
Memory: 128MB
Root Device: IDE /dev/hda
Root Size/partition table:
        #                    type name                 length   base     
( size )  system
/dev/hda1     Apple_partition_map Apple                    63 @ 1        
( 31.5k)  Partition map
/dev/hda2        Apple_Driver_ATA Macintosh                64 @ 64       
( 32.0k)  Unknown
/dev/hda3        Apple_Driver_ATA Macintosh                64 @ 128      
( 32.0k)  Unknown
/dev/hda4           Apple_Patches Patch Partition         512 @ 192      
(256.0k)  Unknown
/dev/hda5               Apple_HFS Untitled           40959297 @ 704      
( 19.5G)  HFS
/dev/hda6         Apple_Bootstrap bootstrap              1600 @ 40960001 
(800.0k)  NewWorld bootblock
/dev/hda7         Apple_UNIX_SVR2 swap                1048576 @ 40961601 
(512.0M)  Linux swap
/dev/hda8         Apple_UNIX_SVR2 root               36129983 @ 42010177 
( 17.2G)  Linux native
Output of lspci:
00:0b.0 Host bridge: Apple Computer Inc. UniNorth/Pangea AGP
00:10.0 VGA compatible controller: ATI Technologies Inc Radeon Mobility 
M7 LW [Radeon Mobility 7500]
10:0b.0 Host bridge: Apple Computer Inc. UniNorth/Pangea PCI
10:17.0 Class ff00: Apple Computer Inc. KeyLargo/Pangea Mac I/O
10:18.0 USB Controller: Apple Computer Inc. KeyLargo/Pangea USB
10:19.0 USB Controller: Apple Computer Inc. KeyLargo/Pangea USB
20:0b.0 Host bridge: Apple Computer Inc. UniNorth/Pangea Internal PCI
20:0e.0 Class ffff: Apple Computer Inc. UniNorth/Pangea FireWire (rev ff)
20:0f.0 Ethernet controller: Apple Computer Inc. UniNorth/Pangea GMAC 
(Sun GEM)

Base System Installation Checklist:

Initial boot worked:    [O]
Configure network HW:   [O]
Config network:         [O]
Detect CD:              [O]
Load installer modules: [O]
Detect hard drives:     [O]
Partition hard drives:  [O]
Create file systems:    [O]
Mount partitions:       [O]
Install base system:    [O]
Install boot loader:    [O]
Reboot:                 [O]
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it


Everything worked ok in the end, but I had a few problems along the way.

1) Language!=keyboard. I wanted to install in english using a norwegian 
keyboard, but I could only get all norwegian or all english.

2) Since I wanted the keys to say what they did I used norwegian bokmaal 
install. This died after looking for a DHCP network showing the console 
screen with:

modprobe: failed to load modules usb-ohci
modprobe: failed to load modules usbkbd
modprobe: failed to load modules keybdev
modprobe: failed to load modules usbserial

3) I was wanting to install sid, so when offered the choice of 
distribution, I choose sid, thinking that base packages would be 
downloaded. But it came to the base installation and told be sid 
packages couldn't be installed and left me at the main menu. From here I 
chose "Choose mirror" (by mistake) but when I chose "Go back" the 
installer hung. Reboot.

4) There is no feedback while the filesystems are created. I thought the 
installer had hung again.

5) I successfully installed the base system and got to the install boot 
loader stage, which complained because I had forgotten to create the 
bootstrap partition. I chose partition again, deleted all of the linux 
partitions and recreated the bootstrap, swap and root partitions. After 
I said ok, the installer returned the the reboot screen, even though I 
had just changed the partitons where debian had been installed. So I 
went back and chose "Configure and Mount partitions" which told me that 
I had "no root partition" and wouldn't let me choose "Continue" or "Go 
back". Reboot.

6) While installing the base system and kernel the progress bar stopped 
at 75%. I changed terminals during the base install if that had 
something to do with it. Made the background go red.

7) A debconf config screen appeared after the reboot screen, but the 
machine was already rebooting, so nothing could be set.

Successful boot of harddisk!

7) Long time waiting for exim to start

8) base-config did not configure the hostname.

9) I would like the option of running dselect after tasksel. I use 
tasksel to select packages in broad strokes and then use dselect to chop 
out stuff I don't need. After running tasksel though, it wanted to 
install everything straight away.

Anyway, after quitting the apt-get for tasksel, setting the hostname and 
manually apt-get'ing everything I wanted, the system has been fine.


Received: (at 222791-done) by bugs.debian.org; 16 Mar 2004 05:27:24 +0000
>From joey@kitenet.net Mon Mar 15 21:27:24 2004
Return-path: <joey@kitenet.net>
Received: from kitenet.net [] (postfix)
	by spohr.debian.org with esmtp (Exim 3.35 1 (Debian))
	id 1B376q-0002Xk-00; Mon, 15 Mar 2004 21:27:24 -0800
Received: from dragon.kitenet.net (dial174.pm3bloun1.bloun.naxs.com [])
	(using TLSv1 with cipher DHE-RSA-AES256-SHA (256/256 bits))
	(Client CN "Joey Hess", Issuer "Joey Hess" (verified OK))
	by kitenet.net (Postfix) with ESMTP id 41AAA17FED
	for <222791-done@bugs.debian.org>; Tue, 16 Mar 2004 05:27:23 +0000 (GMT)
Received: by dragon.kitenet.net (Postfix, from userid 1000)
	id BEAE26E118; Tue, 16 Mar 2004 00:26:45 -0500 (EST)
Date: Tue, 16 Mar 2004 00:26:45 -0500
From: Joey Hess <joeyh@debian.org>
To: 222791-done@bugs.debian.org
Subject: fixed in beta 3
Message-ID: <20040316052645.GA30950@kitenet.net>
Mime-Version: 1.0
Content-Type: multipart/signed; micalg=pgp-sha1;
	protocol="application/pgp-signature"; boundary="pf9I7BMVVzbSWLtt"
Content-Disposition: inline
User-Agent: Mutt/
Delivered-To: 222791-done@bugs.debian.org
X-Spam-Checker-Version: SpamAssassin 2.60-bugs.debian.org_2004_03_12 
	(1.212-2003-09-23-exp) on spohr.debian.org
X-Spam-Status: No, hits=-2.0 required=4.0 tests=BAYES_00 autolearn=no 

Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline
Content-Transfer-Encoding: quoted-printable

Hello, a while ago you reported a problem with the Debian Installer. I
think that your problem is fixed in the just released beta 3 of the
installer. If you're still able to install to the hardware you tried it on,
please download it from http://www.debian.org/devel/debian-installer/, and
try it again. Feel free to file another installation report.

A few of the new features of beta 3 include:

  - new easy to use partitioner that supports automatic partitioning and LVM
  - grub as the default boot loader on i386
  - wireless networking support
  - 2.4.25 kernel, with SATA support and security fixes
  - support for the XFS filesystem

Note that your original installation report may have been split up into
multiple individual bug reports. If so this message closes only one bug,
and not other issues you reported.

see shy jo

Content-Type: application/pgp-signature; name="signature.asc"
Content-Description: Digital signature
Content-Disposition: inline

Version: GnuPG v1.2.4 (GNU/Linux)



Reply to: