[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#237398: marked as done (Prints message "Error while runing modprobe -v ......")

Your message dated Mon, 15 Mar 2004 23:37:40 -0500
with message-id <20040316043740.GA29184@kitenet.net>
and subject line fixed in beta 3
has caused the attached Bug report to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what I am
talking about this indicates a serious mail system misconfiguration
somewhere.  Please contact me immediately.)

Debian bug tracking system administrator
(administrator, Debian Bugs database)

Received: (at submit) by bugs.debian.org; 10 Mar 2004 01:36:04 +0000
>From gwolf@gwolf.cx Tue Mar 09 17:36:04 2004
Return-path: <gwolf@gwolf.cx>
Received: from upn1-25.ajusco.upn.mx (shmate.cabraslocas.upn.mx) [] 
	by spohr.debian.org with esmtp (Exim 3.35 1 (Debian))
	id 1B0sdg-0005NM-00; Tue, 09 Mar 2004 17:36:04 -0800
Received: by shmate.cabraslocas.upn.mx (Postfix, from userid 1000)
	id 81332233BD; Tue,  9 Mar 2004 19:30:34 -0600 (CST)
Content-Type: text/plain; charset="us-ascii"
MIME-Version: 1.0
Content-Transfer-Encoding: 7bit
From: Gunnar Wolf <gwolf@debian.org>
To: Debian Bug Tracking System <submit@bugs.debian.org>
Subject: Ultra Enterprise 450 installation report
X-Mailer: reportbug 2.50
Date: Tue, 09 Mar 2004 19:30:34 -0600
Message-Id: <[🔎] 20040310013034.81332233BD@shmate.cabraslocas.upn.mx>
Delivered-To: submit@bugs.debian.org
X-Spam-Checker-Version: SpamAssassin 2.60-bugs.debian.org_2004_03_08 
	(1.212-2003-09-23-exp) on spohr.debian.org
X-Spam-Status: No, hits=-5.0 required=4.0 tests=HAS_PACKAGE autolearn=no 

Package: installation-reports
Version: 20040309
Severity: normal


Debian-installer-version: 2004-03-09,
uname -a: Linux refri 2.4.24-refri #1 SMP Fri Jan 16 14:06:22 CST 2004 sparc64 GNU/Linux
Date: 2004-03-09
    Booted from the CDROM mini ISO. The machine is connected directly to
    the network, no proxies intervening

Machine: Sparc Ultra Enterprise 450
Processor: 4xUltraSparc-II 480MHz
Memory: 4 GB
Root Device: SCSI, installed on fourth drive (/dev/sdd)
Root Size/partition table:  

    Partitioning was carried out using the automatic option in d-i (see
    the comments further down)

    Disk /dev/sdd (Sun disk label): 27 heads, 107 sectors, 24620 cylinders
    Units = cylinders of 2889 * 512 bytes

       Device Flag    Start       End    Blocks   Id  System
    /dev/sdd1             0      2875   4152937+   1  Boot
    /dev/sdd2          2875     13371  15161472   82  Linux swap
    /dev/sdd3             0     24620  35563590    5  Whole disk
    /dev/sdd4         13371     24620  16249180+  83  Linux native

    Filesystem            Size  Used Avail Use% Mounted on
    /dev/sdd1             3.9G  280M  3.5G   8% /
    /dev/sdd4              16G   33M   15G   1% /home

Output of lspci:

    00:00.0 Host bridge: Sun Microsystems Computer Corp. Psycho PCI Bus Module
    01:00.0 Host bridge: Sun Microsystems Computer Corp. Psycho PCI Bus Module
    02:00.0 Host bridge: Sun Microsystems Computer Corp. Psycho PCI Bus Module
    03:00.0 Host bridge: Sun Microsystems Computer Corp. Psycho PCI Bus Module
    04:00.0 Host bridge: Sun Microsystems Computer Corp. Psycho PCI Bus Module
    04:01.0 Bridge: Sun Microsystems Computer Corp. EBUS (rev 01)
    04:01.1 Ethernet controller: Sun Microsystems Computer Corp. Happy Meal (rev 01)
    04:02.0 SCSI storage controller: LSI Logic / Symbios Logic 53c875 (rev 03)
    04:03.0 SCSI storage controller: LSI Logic / Symbios Logic 53c875 (rev 03)
    04:04.0 Display controller: Texas Instruments TVP4020 [Permedia 2] (rev 11)
    05:00.0 Host bridge: Sun Microsystems Computer Corp. Psycho PCI Bus Module

Base System Installation Checklist:

Initial boot worked:    [O]
Configure network HW:   [O]
Config network:         [O]
Detect CD:              [ ]
Load installer modules: [O]
Detect hard drives:     [O]
Partition hard drives:  [E]
Create file systems:    [O]
Mount partitions:       [O]
Install base system:    [E]
Install boot loader:    [E]
Reboot:                 [O]
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it


There were a couple of minor quirks which did not affect the
installation process, but would scare away novice users - For example,
at bootup, at the first HW detection phase, I got an "Error while
running 'modprobe -v sr_mod'". This message, as well as "Error while
running 'modprobe -v ide-cd'", appeared again, also under the title
'hardware detection', after setting up the network. 

Now, for the more important points:

- At first, I was trying to set up the network incorrectly. I was
  assigned a x.x.x.20/28 IP address, and -mistakenly- was looking for
  the router in x.x.x.31, which is unreachable and produces a
  'SIOCADDRT: Network is unreachable' message. I didn't note the exact
  message, but d-i just told me ther was an error while configuring the
  network. This should probably be informed in a more granular way,
  maybe telling that 'there was a problem with the gateway you
  specified'. Using the correct network configuration, of course, solved
  the problem.

- Partitioning: The system has 4x36.4GB hard disks, I decided to install
  only in the fourth disk. If I ask the installer to 'Create new
  partition' and accept the default (36.4GB) value, I get immediately
  two error messages saying "ERROR!!! Can't have the end before the
  start!", and then "Unable to satisfy all constraints on the
  partition". This does not happen if I ask the partition to be only
  30GB - Might it have something to do with the Sun disklabel scheme?

- Partitioning: If I got the last message once, I will get it again and
  again no matter what I choose in the partitioning module. In order to
  partition my disk, I have to leave the module (with 'Go back') and get
  back in. I chose automatic partitioning. If I ask the partitioner to
  use the scheme with many partitions (/usr, /usr/local, /var, /var/mail,
  etc.), and got an error telling me there was no space to create the
  last (eigth) partition. The installer took sdd3 (which should be a
  wholedisk partition) - Of course, I cancelled the partitioning and
  proceeded with the simpler root-and-home scheme offered. This time, it
  worked correctly.

  In /var/log/partman, I got:
  parted_server: OUT: 8   21607686144-22032207359 424521216       primary ext3       /dev/scsi/host    1/bus0/target3/lun0/part8  
  parted_server: OUT: -1  22032207360-36417116159 14384908800     primary    free    /dev/scsi/host    1/bus0/target3/lun0/part-1

  The problem seems to be parted (or one of the d-i modules) not being
  able to see beyond three bits worth of partitions :(

- Install base system: I chose unstable, and I think that was my main
  mistake. After downloading all the needed packages and installing part
  of them, I got a "Base system installation error - The debootstrap
  program exited with an error (return value 127) Check
  /var/log/messages or see virtual console 3 for the details". In VC3, I

  Errors were encountered while processing:
  /usr/sbin/debootstrap: 1: sleep: not found

  Looking at /var/log/mesages, I found several cases such as:

  dpkg: dependency problems prevent configuration of exim4-daemon-light:
   exim4-daemon-light depends on libgnutls7 (>= 0.8.12-2); however:
    Package libgnutls7 is not installed.
  dpkg: error processing exim4-daemon-light (--configure):
   dependency problems - leaving unconfigured

  Once again, this might have been caused by my choice of 'unstable'. I
  will try to do this installation again with 'testing' and report back
  on this bug (although it might take some days).

- After failing on the base system install (although mostly everything
  was in place), whenever I chose to install the boot loader, the
  installer tried again to install the base system, and bombed in its
  way out. No kernel was installed in the system. 

I eventually gave up and booted the system using a kernel of my own
(that was on another of the machine's hard drives). I was not asked to
go through the second phase of the installation, although I ran it with
'base-config'. The machine is running perfectly now.

All in all, d-i performed _way_ better than what I expected in Sparc,
even with the few glitches (some of them attributable to me, I agree).

-- System Information:
Debian Release: testing/unstable
  APT prefers unstable
  APT policy: (500, 'unstable')
Architecture: i386 (i686)
Kernel: Linux 2.6.3-shmate
Locale: LANG=en_US, LC_CTYPE=en_US

Received: (at 237398-done) by bugs.debian.org; 16 Mar 2004 04:38:26 +0000
>From joey@kitenet.net Mon Mar 15 20:38:26 2004
Return-path: <joey@kitenet.net>
Received: from kitenet.net [] (postfix)
	by spohr.debian.org with esmtp (Exim 3.35 1 (Debian))
	id 1B36LS-0001Dc-00; Mon, 15 Mar 2004 20:38:26 -0800
Received: from dragon.kitenet.net (dial174.pm3bloun1.bloun.naxs.com [])
	(using TLSv1 with cipher DHE-RSA-AES256-SHA (256/256 bits))
	(Client CN "Joey Hess", Issuer "Joey Hess" (verified OK))
	by kitenet.net (Postfix) with ESMTP id 8D15D186E8
	for <237398-done@bugs.debian.org>; Tue, 16 Mar 2004 04:38:22 +0000 (GMT)
Received: by dragon.kitenet.net (Postfix, from userid 1000)
	id 510256E118; Mon, 15 Mar 2004 23:37:41 -0500 (EST)
Date: Mon, 15 Mar 2004 23:37:40 -0500
From: Joey Hess <joeyh@debian.org>
To: 237398-done@bugs.debian.org
Subject: fixed in beta 3
Message-ID: <20040316043740.GA29184@kitenet.net>
Mime-Version: 1.0
Content-Type: multipart/signed; micalg=pgp-sha1;
	protocol="application/pgp-signature"; boundary="ikeVEW9yuYc//A+q"
Content-Disposition: inline
User-Agent: Mutt/
Delivered-To: 237398-done@bugs.debian.org
X-Spam-Checker-Version: SpamAssassin 2.60-bugs.debian.org_2004_03_12 
	(1.212-2003-09-23-exp) on spohr.debian.org
X-Spam-Status: No, hits=-2.0 required=4.0 tests=BAYES_00 autolearn=no 

Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline
Content-Transfer-Encoding: quoted-printable

Hello, a while ago you reported a problem with the Debian Installer. I
think that your problem is fixed in the just released beta 3 of the
installer. If you're still able to install to the hardware you tried it on,
please download it from http://www.debian.org/devel/debian-installer/, and
try it again. Feel free to file another installation report.

A few of the new features of beta 3 include:

  - new easy to use partitioner that supports automatic partitioning and LVM
  - grub as the default boot loader on i386
  - wireless networking support
  - 2.4.25 kernel, with SATA support and security fixes
  - support for the XFS filesystem

Note that your original installation report may have been split up into
multiple individual bug reports. If so this message closes only one bug,
and not other issues you reported.

see shy jo

Content-Type: application/pgp-signature; name="signature.asc"
Content-Description: Digital signature
Content-Disposition: inline

Version: GnuPG v1.2.4 (GNU/Linux)



Reply to: