[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Install fails: can't find kernel module for via-rhine Ethernet



On Wed, Mar 03, 2004 at 12:52:56AM +0100, Frans Pop wrote:
> 
> Hi,
> 
> After an installation-report for a mostly successful install using Beta-2, I 
> received a suggestion from Erich Waelde to try:
> http://gluck.debian.org/cdimage/testing/sarge_d-i/i386/current/
> (I downloaded today's build: Mar. 2 2004)
> 
> However, this fails during hardware detect. It looks like my Ethernet card is 
> recognized correctly, but the installer can't load the kernel module.
> 
> I noticed that on the cdrom the contents of the /install directory have been 
> reorganized when compared to Beta-2: some .img files moved to subdir floppy.
> Could this be the cause of the problem.

Drivers for ethernet devices are split, for space reasons, into two udeb packages.
The first udeb has the popular drivers.
The second udeb gets retrieved after CDrom detect,
because it is on the CDrom.

Did you let Debian-Installer run cdrom-detect?
Failed the loading of network drivers again after retrieving udebs?

> 
> Output from lspci:
<snip/>
> 00:0e.0 Network controller: Eicon Technology Corporation: Unknown device e005 
> (rev 01)
> 00:0f.0 Ethernet controller: VIA Technologies, Inc. Ethernet Controller (rev 
> 43)

Please also provide the IDs for those cards
 ( lspci -n | grep 0200 )


Cheers
Geert Stappers

Attachment: pgph6jRih1_Um.pgp
Description: PGP signature


Reply to: