[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#230705: installation-reports: d-i beta2 on powerbook G4 ppc



Package: installation-reports

INSTALL REPORT

Debian-installer-version: beta-2 PPC netinst
uname -a: Linux trogon 2.4.22-powerpc #1 jeu d©c 18 10:17:34 CET 2003 ppc GNU/Linux
Date: 24 January 2004
Method: boot from CD, then packages from linux.csua.berkeley.edu

Machine: Apple PowerBook G4 ("PowerBook6,2 macRISC3 Power Macintosh")
Processor: 1GHz G4 PPC
Memory: 256 MB
Root Device: IDE, /dev/hda4
Root Size/partition table:

 output from echo "p" | mac-fdisk -r /dev/hda:

        #                    type name                  length   base      ( size )  system
/dev/hda1     Apple_partition_map Apple                     63 @ 1         ( 31.5k)  Partition map
/dev/hda2         Apple_Bootstrap bootstrap               1600 @ 64        (800.0k)  NewWorld bootblock
/dev/hda3         Apple_UNIX_SVR2 swap                 2097152 @ 1664      (  1.0G)  Linux swap
/dev/hda4         Apple_UNIX_SVR2 root                91548544 @ 2098816   ( 43.7G)  Linux native
/dev/hda5               Apple_HFS Apple_HFS_Untitled_3  62654112 @ 93647360  ( 29.9G)  HFS
/dev/hda6              Apple_Free                           16 @ 156301472 (  8.0k)  Free space

Block size=512, Number of Blocks=156301488
DeviceType=0x0, DeviceId=0x0

hda2 is the bootloader, hda5 is the OS-X partition

Output of lspci:
00:0b.0 Host bridge: Apple Computer Inc. UniNorth 2 AGP
00:10.0 VGA compatible controller: nVidia Corporation: Unknown device 0329 (rev a1)
10:0b.0 Host bridge: Apple Computer Inc.: Unknown device 0035
10:17.0 Class ff00: Apple Computer Inc.: Unknown device 003e
10:18.0 USB Controller: Apple Computer Inc.: Unknown device 003f
10:19.0 USB Controller: Apple Computer Inc.: Unknown device 003f
10:1a.0 USB Controller: Apple Computer Inc.: Unknown device 003f
10:1b.0 USB Controller: NEC Corporation USB (rev 43)
10:1b.1 USB Controller: NEC Corporation USB (rev 43)
10:1b.2 USB Controller: NEC Corporation USB 2.0 (rev 04)
20:0b.0 Host bridge: Apple Computer Inc.: Unknown device 0036
20:0d.0 Class ff00: Apple Computer Inc.: Unknown device 003b
20:0e.0 FireWire (IEEE 1394): Apple Computer Inc. UniNorth 2 FireWire (rev 81)
20:0f.0 Ethernet controller: Apple Computer Inc. UniNorth 2 GMAC (Sun GEM) (rev 80)

Base System Installation Checklist:

Initial boot worked:    [O]
Configure network HW:   [O]
Config network:         [O]
Detect CD:              [O]
Load installer modules: [O]
Detect hard drives:     [O]
Partition hard drives:  [O]
Create file systems:    [O]
Mount partitions:       [O]
Install base system:    [O]
Install boot loader:    [E]
Reboot:                 [E]
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it

Comments/Problems:

Overall I was very happy that THE INSTALL WAS BORING.  The
instructions on getting this model loaded with Woody are
horrid, but d-i was very close to just working, in fact
THE D-I BETA 2 IS EASIER TO USE THAN THE POTATO INSTALLER!

I'll flag things with "doc-->", "bug-->" and "annoy-->"
depending on who needs to worry about them.

doc--> I used OS-X to partition into a two HFS+ partitions,
       one for OS-X, one for Debian.  (Branden Robinson's
       notes are helpful here.)

doc--> I needed to hold "C" while booting to hit the CD

annoy--> Why does "American English" suggest a European keyboard?

doc--> Branden Robinson has some good instructions on how to
       partition the disk using mac-fdisk.  Yes, you need to
       partition twice, once under OS-X, once under d-i.

annoy--> make filesystems took a long time and gave no
	 feedback it was doing something.

annoy--> the OS-X partiton wasn't automatically added to
	 /etc/fstab (I know, current kernel can't mount HFS+)

bug--> yaboot installed fine, but I later discovered it
       didn't set the nvram to point at yaboot.

bug--> the system failed to reboot.  instead I was left
       looking at a weird debconf question about priority.
       typing apple-ctrl-fun-power rebooted.

doc--> I had to type apple-alt-o-f to get into openfirmware
       and keep OS-X from booting.

doc--> I used "boot hd:2,\\:tbxi" to start the first-stage bootloader.
       IMPORTANT: most documentation says to use "boot hd:2,\\yaboot"
       which also works but hits the second-stage bootloader.

at this point I got into base config

bug--> after selecting apt http it did an update (from
       linux.csua.berkeley.edu) and then brought me back to
       the same menu.  I had to edit sources.list by hand.

doc--> added "macosx=/dev/hda5" to /etc/yaboot.conf and ran "ybin -v"
       this lets the first stage bootloader switch between OS-X and Debian

doc--> I still need to set the nvram environment to use yaboot, so
       I don't have to type apple-alt-o-f at bootup.

doc--> I've noticed some problems warm booting from OS-X into Debian.
       this may be because I've got too old a kernel.

annoy--> the default kernel doesn't support various powersaving features

annoy--> this machine requires Xfree 4.1.3, which is still
	 in experimental, discover didn't recognize the video
	 hardware (on the up side, 4.1.3 just worked, though
	 I still need to learn how to disable the trackpad
	 when a mouse is plugged in)




Reply to: