[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#230674: Multiple problems, installer fails


Thanasis Chrysos writes:
 > Package: installation
 > Version: sarge-i386 built 2004-01-31
 > * The system fails to install. Examining the debootstrap.log file shows:
 > ln: /target/usr/bin/awk: File exists
This happens when you install base-system a second time without
reformatting the partition. Known, somewhat infamous bug.

 > * I removed awk and tried again, and this time the error is
 > bootstrap: 1: sleep: not found
This error message is a consequence of an error that happened before. Most
probably like so:
 libgnutls7 depends on libopencdk8; however:
 Package libopencdk8 is not installed.
  Errors were encountered while processing:
  /usr/sbin/debootstrap: 1: sleep: not found

 > * I copied sleep from /target/bin to /bin, and still have an error:
 > libc6 is not installed, and the final message is
 > cannot load shared lib librt.so.1: not found.
  cp /target/bin/sleep /bin
  cp /target/lib/librt* /lib
This has fixed it for me, however, the sleep is usually not the problem. 

Please retry with erased / partition. The error mentioned above would show
on console 3 or 4 (Alt-F3 or Alt-F4) or in /target/var/log/debootstrap.* if
I remember correctly.
Please specify the exact image and download location, so we can check this


Reply to: