[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#228870: Can't mount partition on hdb as /



On Wed, Jan 21, 2004 at 01:54:55PM +0100, Eugenia Franzoni wrote:
> Package: debian-installer
> Version: 20040120

> I downloaded the Sarge Net installer from
> http://gluck.debian.org/cdimage/testing/netinst/i386/20040120/sarge-i386-netinst.iso
> The computer I tried it on has 2 disks (hda and hdb). I tried the
> installationon hdb. The partitioning went ok, the disk is recognized as
> /dev/ide/host0/bus0/target1/lun0/disc (QUANTUM FIREBALL_TM2110A)

> - note: it is an old HD on a new controller (VIA
> VT82C586A/B/VT82C686/A/B/VT823x/A/C)
> So "disk partitioning" went ok. The partition table I created is:

> part1     Linux Swap
> part2     Linux (bootable)

> The problem is that these partitions (either of them) are not included in the
> list of the partition in the "configure and mount partitions" step, so I
> can't use them for the installation.

> Accessing them manually (i.e. mkswap on the first partition and mke2fs on
> the second, via the console in F2) was successful. Even after creating
> the filesystem, the partitions are not listed in "configure and mount
> partitions"

Do these partitions overlap in the partition table?  Is this a BSD
disklabel-using disk (probably not) that has a partition overlapping the
beginning of the disk?

I've found that libparted is very particular about only working with
properly defined partitions.

-- 
Steve Langasek
postmodern programmer

Attachment: pgpVKyWgYcsHj.pgp
Description: PGP signature


Reply to: