[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

generally successful install report from usb keychain

Debian-installer-version: today's (second build) netinst CD from manty's home dir
Method: booting from a 128 mb usb keychain with hd-media initrd I built,
        and the d-i ISO on it

Machine: LC2000 laptop from LinuxCertified, Inc.
Processor: 2.66 Ghz P4
Memory: 516 mb
Root Device: 36 gb IDE

Base System Installation Checklist:

Initial boot worked:    [O]
Configure network HW:   [O]
Config network:         [O]
Detect CD:              [O]
Load installer modules: [O]
Detect hard drives:     [O]
Partition hard drives:  [ ]
Create file systems:    [O]
Mount partitions:       [O]
Install base system:    [O]
Install boot loader:    [O]
Reboot:                 [O]
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it

Total time to install Debian: 5 minutes 15 seconds
Number of keystrokes required in d-i: 34


I noticed that bugreporter-udeb was looking in the wrong place for the
install-report.template. This will be fixed in 0.10, but I didn't get such
a template in /root/ in the installed system.

The installer finds my USB and internal NIC ok on this laptop. When I
insert an old wavelan card, cardmgr notices it and loads the right module,
but I get this error and the card never comes on:
  klogd: orinoco_cs: RequestIRQ: Resource in use
Not sure what do to about that. I've googled around but have not found
anything that has helped.

The install properly configured my network (internal NIC), did not ask me
about mirror (good, this is a netinst CD), and finished quickly. I did
notice the long pause while it was formatting the disk, with only a blue
screen displayed, and again a several seconds pause with a blue screen in
the middle of a deboostrap run, right after the "Extracting packages"

I have figured out the base-config debconf priority problem. A workaround 
will be in prebaseconfig 0.47. I applied this workaround before finishing
the install.

Some ugly things during boot:

  - discover decided I should have a i810_rng module, but this module
    failed to load with "No such device".
  - While starting pcmcia, I got the error "a module named pcmcia_core
    already exists".
  - Also while starting pcmcia, I got unresolved symbols in i82365.o. The
    symbol is isapnp_find_dev_R27cb2cad. That is in the isa-pnp module,
    which was not loaded at the time.
  - I still get the same "orinoco_cs: RequestIRQ: Resource in use" when
    inserting my wavelan card.

base-config came up in high priority. It did time zone config, with default
to Africa, which is silly. It needs to use d-i's location informaiton

At high priority base-config insists that I configure an apt source, which
is hard since I have no CD, no network cable, and only a USB keychain. This
will be fixed in base-config 2.04; for now I hit the cancel button to get
to the menu and continued from there.

exim4 has a very strange default mail name: localhost
What on earth? Taking a look at /etc/mailname, I see:	localhost	debian. debian

Something is _very_ broken here. FWIW, my /etc/hosts has the same.
/etc/hostname has "debian."; I don't know why the period is there.

Lacking a network, I did not try to get X working. discover did load an
i180_audio driver, so I tried to cat /etc/passwd to /dev/audio. This
resuled in a fairly appropriate noise, but also some DMA overrun error
messages. I had better luck with /vmlinuz, no DMA overrun messages. And my
cat left the room, too. :-)

Though USB obviously worked during the install, discover did not load
the usb-ochi module for it, nor was usb-storage loaded. I think this was
fixed in a recent upload of discover by its new maintainer though, and
is only waiting for that to get into testing. After manually loading the
modules, I was able to re-mount my keychain.

see shy jo

Attachment: signature.asc
Description: Digital signature

Reply to: