[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#224620: dhcp & lvm problems, partconf & GRUB wishlist

Package: installation-reports


Debian-installer-version: daily built from 17-Dec-2003
sarge-i386-netinst.iso      17-Dec-2003 07:34   120M
uname -a: 2.4.22
Date: Sat Dec 20 18:07:00 CET 2003
Method: boot from IDE CD-ROM, using netinst ISO

Machine: No-name desktop PC
Processor: K6-2 400 MHz
Memory: 128 MB
Root Device: IDE, also has a SCSI CD-ROM

Base System Installation Checklist:

Initial boot worked:    [O]
Configure network HW:   [O]
Config network:         [E]
Detect CD:              [O]
Load installer modules: [O]
Detect hard drives:     [O]
Partition hard drives:  [O]
Create file systems:    [O]
Mount partitions:       [O]
Install base system:    [O]
Install boot loader:    [O]
Reboot:                 [O]
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it


Why do you ask for the debconf priority at the beginning?  I think it
should just be "high" by default and people who want something lower can
pass "DEBCONF_PRIORITY".  I guess/hope this is currently only asked for
testing, and that it will be disabled later.  I chose "high".

Apparently, it looks for DHCP automatically.  While the PC had a network
card, it was not connected anywhere.  So I got the following error:

  Configure the network using dynamic addressing (DHCP)
  An error occured and the network configuration process has been aborted.

Since I didn't chose DHCP, it would be good if a short explanation could be
offered.  What DHCP is and why we tried to use it.  Some people might not
know what DHCP is.

Since I didn't have or want a network, I wanted to choose "Detect and mount
CD-ROM" next.  However, that would show the DHCP error again.  I could only
continue after manually configuring an IP address.  Please don't assume I
want a network just because I have a network card.  Also, why is the
"manually configure network" so much further down the menu?

At some point I went into the partition a hard drive menu.  It showed me:
    <info on my hard drive>
I chose my hard drive, got into cfdisk, did my stuff and quit.  After that,
the menu was on the hard drive again.  I think it should be one menu item
further down (on "Finish" in my case, or on the 2nd hard drive if I had one).

Before formating the hard drive, I got:
    WARNING: This will destroy all data on the partitions you have assigned
    file systems to.
    Ready to create file systems and mount partitions

I told partconf to format one partition (/dev/hda1) while leaving the rest
alone (/dev/hda5 was to be mounted as /home; this was a hard drive which
had some Linux stuff on it already).  So obviously it is only going to
format _one_ partition, while mounting more than one.  It would be nice if
this warning would show me exactly which partitions it is going to format.
   Formating and mounting:
       /dev/hda1 (ext3)
   Just mounting:

(It did the right thing, though, and only formated the first partition.)

Why is LILO installed by default?  I thought the decision was to go with

After rebooting:

/etc/mailname was "(none)" even though /etc/hosts contained the name of my
machine.  Also, /etc/hostname contained "localhost" instead of the correct

The <up> key does not work in debconf to go to the last menu item.  I never
noticed this before, but this is really annoying.

No install-report.template file was in /root.


OK, then I tried another installation on the same box, this time with
debconf priority "medium".

I chose the lvm udeb, but when I wanted to create LVM partitions it told
me: The current kernel doesn't support the Logical Volume Manager.
And yes, there was no lvm-mod module anywhere.

Also, why is lvm10 used instead of lvm2?  2.4.23-1 will have the
device-mapper patch included so I hope we can switch to lvm2 then.

I chose GRUB this time; it asked me on which device I want to install it.
It gave me (hd0) as default and had some info about GRUB having a different
device schema as Linux.  Who cares?  It would be much nicer if it would
display a list of hard drives (a la partconf) and then translated it to
GRUB's name itself.

I chose reiserfs for the root partition this time.  After reboot, I saw:
    fsck.reiserfs: not found
I guess reiserfsprogs should be installed if any reiserfs partition is

Also, from LVM I got "modprobe: modprobe: Can't locate module block-major-114".
dmesg said:
    loop: loaded (max 8 devices)
    md: md driver 9.90.0 MAX_MD_DEVS=256, MD_SB_DISK=27
    modprobe: modprobe: Can't locate module block-major-114
    [repeat ~40-50 times]
    vgcan -- "/etc/lvmtab" and "/etc/lvmtab.d" succesfully created

Martin Michlmayr

Reply to: