[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#222458: installation-reports: installation report could not load driver ide-mod ide-probe-mod ide-floppy

Package: installation-reports
Version: Debian-Installer beta 1
Severity: important



uname -a: Linux maral.shabdiz 2.4.20 #1 Tue Mar 18 16:13:35 PST 2003 i686 unknown unknown GNU/Linux
Date: 29 Nov 2003
Method: CDROM, default install

Machine: IBM ThinkPad A31 Notebook
Processor: P4 1.8 Ghz
Memory: 256 MB DDRSD RAM

Output of lspci:
	00:00.0 Host bridge: Intel Corp. 82845 845 (Brookdale) Chipset Host
	Bridge (rev                                04)
	00:01.0 PCI bridge: Intel Corp. 82845 845 (Brookdale) Chipset AGP Bridge
	(rev 04                               )
	00:1d.0 USB Controller: Intel Corp. 82801CA/CAM USB (Hub #1) (rev 02)
	00:1d.1 USB Controller: Intel Corp. 82801CA/CAM USB (Hub #2) (rev 02)
	00:1d.2 USB Controller: Intel Corp. 82801CA/CAM USB (Hub #3) (rev 02)
	00:1e.0 PCI bridge: Intel Corp. 82801BAM/CAM PCI Bridge (rev 42)
	00:1f.0 ISA bridge: Intel Corp. 82801CAM ISA Bridge (LPC) (rev 02)
	00:1f.1 IDE interface: Intel Corp. 82801CAM IDE U100 (rev 02)
	00:1f.3 SMBus: Intel Corp. 82801CA/CAM SMBus (rev 02)
	00:1f.5 Multimedia audio controller: Intel Corp. 82801CA/CAM AC'97 Audio
	(rev 02                               )
	00:1f.6 Modem: Intel Corp. 82801CA/CAM AC'97 Modem (rev 02)
	01:00.0 VGA compatible controller: ATI Technologies Inc Radeon Mobility
	M7 LW [R                               adeon Mobility 7500]
	02:00.0 CardBus bridge: Ricoh Co Ltd RL5c476 II (rev 80)
	02:00.1 CardBus bridge: Ricoh Co Ltd RL5c476 II (rev 80)
	02:02.0 Network controller: Harris Semiconductor Prism 2.5 Wavelan
	chipset (rev                                01)
	02:08.0 Ethernet controller: Intel Corp. 82801CAM (ICH3) PRO/100 VE
	(LOM) Ethern                               et Controller (rev 42)

Output of fdisk -l:
	Disk /dev/hda: 40.0 GB, 40007761920 bytes
	240 heads, 63 sectors/track, 5168 cylinders
	Units = cylinders of 15120 * 512 = 7741440 bytes

	   Device 	Boot    Start       End    Blocks   Id  System
	   /dev/hda1   *         1       867   6554488+  83  Linux
	   /dev/hda2           868      3847  22528800   83  Linux
	   /dev/hda3          3848      4808   7265160    f  Win95 Ext'd (LBA)
	   /dev/hda4          4809      5168   2721600   eb  BeOS fs
	   /dev/hda5          3848      3928    612328+  82  Linux swap
	   /dev/hda6          4403      4808   3069328+  83  Linux 
	   /dev/hda7          3929      4402   3583408+  83  Linux

	   Partition table entries are not in disk order

	/dev/hda6 was mounted as / and /dev/hda2 as /data

Root Device: IDE IBM 40 GB

Output of ide_info /dev/hda :

Base System Installation Checklist:

	Initial boot worked:    [O]
	Configure network HW:   [E]
	Config network:         [E]
	Detect CD:              [O]
	Load installer modules: [O]	
	Detect hard drives:     [ ]
	Partition hard drives:  [O]
	Create file systems:    [O]
	Mount partitions:       [O]
	Install base system:    [E]
	Install boot loader:    [O]
	Reboot:                 [O]
	[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it


The initial boot didn't have any problems. After selecting the language
the system did some hardware auto detection untill I faced a red screen
with an alarming error message telling me to please feel free to rtry.
It was a very confusing error message as it didn't mention where things
had gone wrong, and the user has no clue as to what the error message is
about. I later found out it is about a failure in configuring network
via DHCP, or atleast that's what I think it is.

At the time of the install my system was connected to the ineternet but
there is no DHCP here, so naturaly the installer should fail trying to
use DHCP. How ever what I find confusing is why does the installer tries
to detect network settings and DHCP in the first place? Many times (most
of the times) the system that the OS is being installed on is not
connected to the net. I suggest the installer should first ask the user
wether he/she wants to configure network. If yes, then go to DHCP, if it
fails, don't show that alarming error message, but go to static
configuration instead. 

Detection of network hardware gave the following error message: Unable
to load the following modules: 'ide-mod' 'ide-probe-mod' 'ide-floppy'

Trying to configure the network staticaly also failed with the same red
error message.

Installing the base system gave me a kind of unreadable error message. I
couldn't read it because the screen was all mixed up, I just could see a
'continue' and a 'go back' option. I selected continue, again without
any idea as to where things have gone wrong.

Loading installer modules, installing boot loader (I tried both Lilo and
Grub), creating filesystems, mounting partitions, and rebooting; all went
without a problem.

Also of note: I know that the post configuration tasks are not related
to debian-installer, but just wanted to mention here that after reboot
and setting up accounts and everything, when I setup apt, and was given
the message: Please Insert Disct Labeled .... 
Although the mentioned disc was in the drive, but pressing the return
key didn't do anything, and apt couldn't read the contents of the media.
Maybe it's because of base system not installing correctly.

-- System Information:
Debian Release: testing/unstable
Architecture: i386
Kernel: Linux maral.shabdiz 2.4.20 #1 Tue Mar 18 16:13:35 PST 2003 i686

Reply to: