[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Installation report



Hello!

Last week-end, I tried the new debian-installer on my old notebook
without success :

Debian-installer-version: 
Beta1 : http://http.us.debian.org/debian/dists/unstable/main/installer-i386/20031109/images/
Daily build (15/11/03) : http://people.debian.org/~sjogren/d-i/images/daily/
Date: 15/11/2003
Method: I tried to install with boot floppy and can't start the debian
installer (see below).
Machine: Notebook compaq contura ( http://www.geocities.com/dueze/contura430c.html )
Processor: 486 DX4 100
Memory: 16 Mo
Root Device: ide, /dev/hda
Root Size/partition table: 
Disk /dev/hda: 32 heads, 63 sectors, 700 cylinders
Units = cylinders of 2016 * 512 bytes

   Device Boot    Start       End    Blocks   Id  System
   /dev/hda1   *         1       444    447520+   6  FAT16
   /dev/hda2           445       460     16128   82  Linux swap
   /dev/hda3           461       700    241920   83  Linux

Output of lspci: no PCI

Base System Installation Checklist:

Initial boot worked:    [O]
Configure network HW:   [ ]
Config network:         [ ]
Detect CD:              [ ]
Load installer modules: [E]
Detect hard drives:     [O]
Partition hard drives:  [ ]
Create file systems:    [ ]
Mount partitions:       [ ]
Install base system:    [ ]
Install boot loader:    [ ]
Reboot:                 [ ]
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it

Comments/Problems:

With beta1 floppy I've got a kernel panic :
after the boot, I have :
[...]
VFS: Mounted root (ext2 filesystem).
Trying to move old root to /initrd ... okay
Mounted devfs on /dev
Freeing unused kernel memory: 76k freed
mount: Mounting devfs on /dev failed: Device or ressource busy
loop: loaded (max 8 devices)
[...]
USB Mass Storage suppot registered.

I don't take care of the USB problem and I insert the root floppy.
Debian Installer is loading after there is a lot of errors on cp (no 
space left) and :

starting the installer....
SIGBUS (6 times)
puis /sbin/init: 178: cannot open dev/console: No such file
Kernel panic: Attempted to kill init!


After that, I've tried to boot with BOOT_DEBUG=3 :

the mount command, just after the boot gives :
/dev/root.old on /initrd type ext2 (rw)
/dev/root..old on / type ext3 (rw)
none on /dev type devfs (rw)
/proc on /proc type proc (rw)

After that I type exit to launch hardware detection that seems to run
successfully. I type exit again to launch the installer and :
Setting up filesystem...
+ umount /initrd
+ mount -o loop mnt/tmp-initrd /initrd
+ cp -a /initrd/bin /initrd/dev [...] /initrd/var mnt
cp: Write Error: No space left on device
[Un grand nombre de fois]
+ rm -f mnt/tmp-initrd
+ umount /initrd

Then I'am on a debug shell :
mount give :
/dev/root.old on / type ext2 (rw)
none on /dev type devfs (rw)
/proc on /proc type proc (rw)
shm on /mnt type shm (rw)

(free, df and ls don't work)

exit
+ umount proc
+ echo Starting the installer...
Starting the installer...
+ cd mnt
+ pivot_root . initrd
+ mount -t proc proc proc
SIGBUS
+ mount -t devfs devfs dev
SIGBUS
+ [ ! -x /usr/bin/chroot ]
SIGBUS
+ rm -f sbin/init
SIGBUS
+ ln -s ../bin/busybox sbin/init
SIGBUS
+ debugshell before chroot
+ [ 3 -gt 2 ]
SIGBUS
/sbin/init: 178: cannot open dev/console: No such file
+ exec /usr/sbin/chroot . /sbin/init
Kernel panic: Attempted to kill init!


I've also tried with devfs=nomount at the boot :

- It doesn't ask me for another floppy after booting (Nothing else on
  the screen after USB Mass Storage support registered) but seems to
  look for a floppy....
- If I put the root floppy, it loads it and :
  Kernel panic: Attempted to kill init!

After that I've tried with the last version available :

http://people.debian.org/~sjogren/d-i/images/daily/

(no MD5SUMS are available so I don't check it)

- Same error about devfs at the boot (Mounting devfs on /dev failed:
  Device or ressource busy)
- The mount command give the same result as before
- Same error with cp (No space left)
- No error after starting the installer
- The installer is not able to load vesafb and re-tries, re-tries, etc...
  (what about vga16-fb ?)
- If I rename vga16-fb to vesafb (hum...) I obtain a white screen with :
/usr/share/debconf/frontend: error while loading shared librairies:
/usr/lib/cdebconf/libdebconf.so: file too short

As I don't know which packages this bugs belong to, I propose to open
free bugs on the installation package :

- devfs problem
- vesafb problem
- libdebconf problem

What are you thinking about this ?

-- 
Djoumé SALVETTI

Attachment: pgp42u1QA381h.pgp
Description: PGP signature


Reply to: