[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#221266: 'images-1.44/rescue.bin bug

On Mon, Nov 17, 2003 at 09:13:32AM -0600, Tarun Kundhi wrote:
> Package: boot-floppies
> Version: 3.0r1(Disk 2)
> flavor:        vanilla
> architecture:  i386
> model:         Intel, PIII
> memory:        512 RAM
> scsi:          none
> cd-rom:        TDK, ATAPI
> network card:  Intel on motherboard D815EEA and a Linksys WMP11
> pcmcia:        none
> I am attempting to install Debian onto an Western Digital IDE drive
> (40G). Problem occurs when attempting "install the kernel step": Install
> Kernel and Driver Modules
> Step 1 - Select the medium to use: cdrom (this is listed)
> Message: Please place the first Debian CD-ROM in the CD-ROM drive
> <Continue>
> Step 2 - Message: "Please select the directory containing a file
> images-1.44/rescue.bin that you will use to install the kernel and
> modules."
> There are two options
> list:  Choose from a list of all likely directories
> manually: Enter the directory manually
> Regardless of which method selected and error is returned indicating
> file is not found.  If I allow the program to search for the file the
> following error message is returned:
> ------------------
> File not found!
> The installation program couldn't find and directory containing the
> files rescue.bin, drivers.tgz
> ------------------
> If I try to manually give it the path but it doesn't like it either.
> I've tried the following:
> boot
> boot/
> boot/rescue.bin
> /boot
> /boot/
> /boot/rescue.bin
> The install program always wants to add /instmnt/ as a prefix. The
> closest I've come is with 'boot' . The path is then correct but the
> error message is as follows:
> ------------------
> File not found!
> /instmnt/boot/ does not contain the file
> images-1.44/rescue.bin that is needed to install the kernel and modules
> ------------------
> I can't find 'images-1.44/rescue.bin' anywhere on my CD, but I do find
> 'rescue.bin' under the following path /boot/

It is buried way down in the CD. But if the CD is built correctly,
it should find it just by pointing at the CD, because it knows the
standard path. For your case, the path is


This will appear inside the /instmnt directory, because that's where
the installer mounts your CD within the ramdisk file system. So, if
you're navigating manually, navigate to the 'current' folder; that's
what should contain 'images-1.44/rescue.bin'.
> Searching the web I found reference to a similar bug in 2000 but it
> appears the problem was solved. There wasn't a work around that I came
> across.  I'm new to linux, if I'm barking up the wrong tree I would be
> happy to review any documentation that would point me to a solution. So
> far, I haven't found any. I even thought I a may have pulled down a bad
> iso image but I've downloaded a second iso image and get the same exact
> result.  Any guidance would be appreciated.

There was a bug at one time, but since late 2001 it's been working great.
Are you inserting CD #2, not CD #1? CD #2 is only used for _booting_ the
vanilla flavor; the kernels are all there on CD #1 though in the right
folder structure.
> Also, I can't find any 'drivers.tgz' file on the iso image. This is
> another file that is mentioned in the error message if you allow the
> install program to search for the files itself.

The drivers.tgz is in the current folder within the path above.

Debian GNU/Linux Operating System
  By the People, For the People
Chris Tillman (a people instance)
   toff one at cox dot net

Reply to: