[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Bug#220163: installation-reports: netboot install attempt via PXE (fwd)

Am Die, den 11.11.2003 schrieb Joe Nahmias um 09:16:

> Alright, here are the highlights of how this install went:
> 0) OK, after much struggling (and dealing with my nemesis error message
> 'VFS: Cannot open root device "" or 3a:04') I managed to get the d-i
> netboot image to work via PXE.  For posterity (and the installation
> guide) the magic kernel options I needed to make this work are
> "ramdisk_size=8192 root=/dev/ram0".  If anyone would like assistance
> setting up a PXE testbed or copies of various configs I use please don't
> hesitate to ask.
It would be nice, if you could write a short addition to the
INSTALLATION-HOWTO about your way to install d-i via PXE boot. There is
already a very short section on netbooting the installer. If you send a
patch to debian-boot, I will look at it and commit it to CVS.
> 1) Install boots into the main menu.  Interface looks alot snazzier than
> the old text interface, however the line-drawing characters are all
> messed up on my terminal (corners are displayed as '>', &c.)  Known bug?
not know bug, please file one. Sorry I don't know which package to blame
for that. 
btw the installation should not boot into main-menu but directly go into
> 2) Picking "Choose language" doesn't get very far.  This is what I can
> piece together from syslog:
> DEBUG: Menu item 'languagechooser' selected
> DEBUG: configure languagechooser, status: 4
> WARNING **: Configuring 'languagechooser' failed with error code 1
> WARNING **: Menu item 'languagechooser' failed.
> Any ideas?  Known unfiled bug?  File a new bug against languagechooser?
bug not know. You should have languagechooser 1.03 on your image, which
is the same as on the beta1 which works for most people. Please file a

> 3) After doing 'Select a Keyboard Layout', I chose 'Detect network
> hardware'.  This generated the following two (fatal looking) errors:
>   a. An error occured while running 'modprobe -v floppy false`.
>   b. An error occured while running 'modprobe -v ide-cd false`.
> Since this is a netboot install, these errors should not be fatal.
please file a bug on hw-detect (or ethdetect?). It's strange that these
are tried for network hardware detection. Probably the installer tries
to load additional modules from a floppy?

> 4) When finally presented with a list of ethernet drivers to pick from,
> the requisite driver for this laptop -- b44 -- is missing.  I tried
> switching to vc2 and doing 'modprobe -v b44', but this fails since the
> module doesn't exist on the image.  How do we get it added?
known bug. As of linux-kernel-di 0.12 this driver is in
nic-extra-modules. This means you have to load it from an additional
floppy. If this is a common NIC then we could add it to nic-modules,
which is on the netboot initrd.

> PS - This particular laptop doesn't have a serial port, so all
> output/error messages are hand-typed and subject to typos, &c.
You could try to save /var/log/messages and /var/log/syslog to an
already formatted partition. 


Reply to: