[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

install report - bochs cd install

Debian-installer-version: sarge-i386-netinst.iso daily build circa 30 Oct 2003
Method: bochs CD install

Machine: bochs
Processor: bochs (slow..)
Memory: 32 and later 64 mb
Root Device: blank 256 and later 512 MB pseudo-ide device, set up by bximage

Base System Installation Checklist:

Initial boot worked:    [O]
Configure network HW:   [ ]
Config network:         [ ]
Detect CD:              [O]
Load installer modules: [E]
Detect hard drives:     [O]
Partition hard drives:  [O]
Create file systems:    [E]
Mount partitions:       [O]
Install base system:    [E]
Install boot loader:    [ ]
Reboot:                 [ ]
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it


My first failure was with bochs and only 32 mb of memory. The error message
when loading installer modules and it runs out of memory and thus disk
space is very bad; it suggested that one of the udebs was corrupt. I intend
to file a proper bug later.

My second try was with bochs and 64 mb of memory, and a 256 mb hard
drive. This makes bochs run nuch more slowly, apparently plex86 only
supports up to 32 mb of memory. :-(

The partitioner worked, and I made 1 big 256 mb partition, type 83.
partconf failed: After selecting my partition, I was thrown into the
main menu with no indication what went wrong. Syslog said it exited with
exit code 30. I looked into it and this is apparently bug #218190, and I
had an old partconf 0.11, so I will assume my problem is fixed by the
new 0.12. Matt Kraai is always two steps ahead of me..

Picked autopartkit instead. It complained that it could not allocate space
for swap (128 mb!), and gave up.

My next try was with a 512 mb disk. partconf failed again of course,
autopartkit succeeded. Its time estimates were even fairly accurate.

debootstrap's progress bar is rather blocky. 45 minutes between updates
in bochs, with jumps from 20 to 50 percent, etc.

After running overnight, debootstrap exited with an error (127) with
only 98 MB of disk used. debootstrap.log ended in it unpacking psmisc,
pcmcia-cs, ipchains, iptables, and failing while unpacking

Unpacking uptables (from ../iptables_1.2.8-4_i386.deb) ...
Errors were encountered while processing:
/usr/sbin/debootstrap: 1: sleep: not found

The sleep thing is in the call to repeat() in debootstrap's functions
file. Perhaps we should turn on bb sleep? However that is only called if
something fails.

I tried installing console-common manually chrooted into target, and it
worked; I was stepped through the debconf setup. I don't know why it
failed under debootstrap -- is this a known problem?

Continuing, I noticed something interesting. The scroll bar had been
broken in main-menu as it always seems to be under frame buffer, with
only the "#" showing. But now the full scroll bar showed up.

Anyway, I gave up here, since installing a kernel depended on installing
base, which takes 3 hours and will probably just fail again.

see shy jo

Attachment: signature.asc
Description: Digital signature

Reply to: