[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#212445: marked as done (grub install failure, cannot find device for /boot)

Your message dated Tue, 7 Oct 2003 09:33:30 +0200
with message-id <E1A6mLa-00052i-00@saruman.uio.no>
and subject line grub-installer problems should be fixed now
has caused the attached Bug report to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what I am
talking about this indicates a serious mail system misconfiguration
somewhere.  Please contact me immediately.)

Debian bug tracking system administrator
(administrator, Debian Bugs database)

Received: (at submit) by bugs.debian.org; 16 Sep 2003 05:56:02 +0000
>From jlquinn@optonline.net Tue Sep 16 00:55:57 2003
Return-path: <jlquinn@optonline.net>
Received: from mta8.srv.hcvlny.cv.net [] 
	by master.debian.org with esmtp (Exim 3.35 1 (Debian))
	id 19z8of-0005c9-00; Tue, 16 Sep 2003 00:55:57 -0500
Received: from smaug (ool-182c9efb.dyn.optonline.net [])
 by mta8.srv.hcvlny.cv.net
 (iPlanet Messaging Server 5.2 HotFix 1.16 (built May 14 2003))
 with ESMTP id <0HLA00AQZLS1F3@mta8.srv.hcvlny.cv.net> for
 submit@bugs.debian.org; Tue, 16 Sep 2003 01:55:13 -0400 (EDT)
Received: from jlquinn by smaug with local (Exim 3.36 #1 (Debian))
	id 19z8qK-000882-00	for <submit@bugs.debian.org>; Tue,
 16 Sep 2003 01:57:40 -0400
Date: Tue, 16 Sep 2003 01:57:40 -0400
From: Jerry Quinn <jlquinn@optonline.net>
Subject: Install report - further this time
To: submit@bugs.debian.org
Message-id: <16230.42580.457463.302713@gargle.gargle.HOWL>
MIME-version: 1.0
X-Mailer: VM 7.17 under Emacs 21.3.2
Content-type: text/plain; charset=us-ascii
Content-transfer-encoding: 7BIT
Delivered-To: submit@bugs.debian.org
X-Spam-Status: No, hits=-3.8 required=4.0
X-Spam-Checker-Version: SpamAssassin 2.53-bugs.debian.org_2003_9_14 (

Package: installation-reports


Debian-installer-version: 09-15-2003 http://gluck.debian.org/cdimage/testing/netinst/i386/sarge-i386-netinst.iso
uname -a: 2.4.20-1-386
Date: 9-15-03 10:30
Method: How did you install?  What did you boot off?  If network
      install, from where?  Proxied?

Booting from CD.  I used the "net" method.

Machine: Thinkpad T30
Processor: 1.8GHz Pentium4
Memory: 768MB
Root Device: IDE
Root Size/partition table:  Feel free to paste the full partition
      table, with notes on which partitions are mounted where.
Output of lspci:

Base System Installation Checklist:

Initial boot worked:    [O]
Configure network HW:   [O]
Config network:         [O]
Detect CD:              [O]
Load installer modules: [O]
Detect hard drives:     [O]
Partition hard drives:  [O]
Create file systems:    [O]
Mount partitions:       [O]
Install base system:    [O]
Install boot loader:    [E]
Reboot:                 [ ]
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it


As with 'linux' install, the net install only has e100.  However, it
seems to get much futher more easily.  The display works ok for
starters, although the # char scroll bar is not displayed correctly.

Detect hardware and load kernel still results in error messages on VC4
about missing eepro100 and orinoco_pci drivers.  But no user messages
are sent back.

Installing the base system worked, but VC4 showed a whole pile of
messages from the installer:

WF: Retrying failed download of %s

I tried to install grub as the bootloader without sucess.  There are a
bunch of syslog errors on VC4 during this operation.  VC3 has:

Probing devices to guess BIOS drives. This may take a long time.
Could not find device for /boot: Not found or not a block device.

On VC4:

end_request: I/O error, dev 02:00 (floppy) sector 0
end_request: I/O error, dev 02:00 (floppy) sector 0
end_request: I/O error, dev 02:00 (floppy) sector 2
end_request: I/O error, dev 02:00 (floppy) sector 4
end_request: I/O error, dev 02:00 (floppy) sector 6

My machine only has a CD installed - the ultrabay floppy is currently
not in the machine.

I then tried installing LILO, which went perfectly.

Until I rebooted and system got as far as printing "Booting the
kernel" and doing a warm reboot immediately.

Received: (at 212445-done) by bugs.debian.org; 7 Oct 2003 07:33:35 +0000
>From pre@saruman.uio.no Tue Oct 07 02:33:35 2003
Return-path: <pre@saruman.uio.no>
Received: from pat.uio.no [] 
	by master.debian.org with esmtp (Exim 3.35 1 (Debian))
	id 1A6mLe-0007Wt-00; Tue, 07 Oct 2003 02:33:34 -0500
Received: from mail-mx6.uio.no ([] ident=[spfQUOy/UjkQUHNrpU5sWv5XDNevIwPs])
	by pat.uio.no with esmtp (Exim 4.20)
	id 1A6mLd-0001z5-GM; Tue, 07 Oct 2003 09:33:33 +0200
Received: from saruman.uio.no ([])
	by mail-mx6.uio.no with esmtp (Exim 4.14)
	id 1A6mLa-0001uN-Fq; Tue, 07 Oct 2003 09:33:30 +0200
Received: from pre by saruman.uio.no with local (Exim 2.12 #7)
	id 1A6mLa-00052i-00; Tue, 7 Oct 2003 09:33:30 +0200
To: 199973-done@bugs.debian.org, 211067-done@bugs.debian.org,
  212445-done@bugs.debian.org, 187135-done@bugs.debian.org
Subject: grub-installer problems should be fixed now
From: Petter Reinholdtsen <pere@hungry.com>
Message-Id: <E1A6mLa-00052i-00@saruman.uio.no>
Sender: Petter Reinholdtsen <petter.reinholdtsen@usit.uio.no>
Date: Tue, 7 Oct 2003 09:33:30 +0200
X-MailScanner-Information: This message has been scanned for viruses/spam. Contact postmaster@uio.no if you have questions about this scanning.
X-UiO-MailScanner: No virus found
Delivered-To: 212445-done@bugs.debian.org
X-Spam-Status: No, hits=0.0 required=4.0
X-Spam-Checker-Version: SpamAssassin 2.53-bugs.debian.org_2003_10_05 (

The problems in install-grub should be fixed in version 0.19, with the
code to update /target/etc/mtab.

Reply to: