[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: new installer



On Thu, Oct 02, 2003 at 09:16:52AM +0200, Sven Luther wrote:

> Notice that when i asked about this on debian-powerpc, i was told that
> the 2.4 kernel could be made to fit on 1.44 floppy disks. In fact, if i
> look at the kernel-image-2.4.21 packages, i find that :
> 
>   - /boot/vmlinux.coff-2.4.21-powerpc is of size : 1299802
> 
>   - the .coff kernels don't have a udeb at all.

a .coff kernel won't autoboot, the user would have to manually get
into OpenFirmware and boot it explicity.

the current miboot boot floppies require the vmlinux binary, which may
be gzipped.

also .coff kernels don't even work until 2.4.23 (maybe).

> This comes together with a general effort i am doing to get all powerpc
> subarches supported by the powerpc kernel, since right now, only newpmac
> is supported in the udeb, and only oldpmac and newpmac are supported in
> the deb.
> 
> Notice also that i asked questions about this on the debian-powerpc
> mailing list, and _nobody_ replied, so i guess nobody really cares, and
> thus has the right to make critics here.

yup, nobody cares about doing installer stuff.  i myself have zero
desire to do that again, i fixed woody for you folks, now its somebody
elses turn.

-- 
Ethan Benson
http://www.alaska.net/~erbenson/

Attachment: pgpZjQlp1vrws.pgp
Description: PGP signature


Reply to: