[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Installer not recognizing SCSI disks after manually inserting modules


I'm trying to install Woody on an Compaq Prosignia VS. This system has a
NCR53C710 SCSI controller with 2 disks (1G and 4,5G) connected to it.
There's also a CDROM on the SCSI chain. Both disks and the CDrom work
fine under DOS (with the appropriate drivers).
When starting the install I do so from a small DOS (6.22) partition on
the 1G disk starting with loadlin from a batch-file made from boot.bat
(from \install of the first Woody CD).

I'm booting the kernel from kernel-image-2.4.16-386_2.4.16-1. Using another Linux machine I changed the installation ramdisk to contain the
following modules from this kernel-image package:

    (for the SCSI controller).
    (SCSI midlevel drivers right?)
    (for SCSI disk support).
    (for the NIC on the motherboard)

After the "Configuring the Keyboard" step I switch to the second console
and do:
insmod scsi_mod
insmod sim710 sim710="addr:0x8000 irq:11
ïnsmod sd_mod
and verify with dmesg the SCSI disks are recognized by the kernel. I can see the disks, make partitions on them etc. If I return to the Installation menu to initialize and activate swap and to initialize the root partition, it still says that there are no disks. I suggests the "Preload essential modules from floppy" step. I tried this but it does not recognize the floppy either, that's why I started putting together my own installation ram-disk in the first place. I also tried restarting the installation system to get it to recognize the disks and partitions.

So my question is: Which command or action can I execute to make the installation system recognize the disks/partitions? Or do I need more modules?

Thanks in advance, Erik.
Erik C.J. Laan				elaan at dds.nl
Please reply below the message,	 please cut unrelevant pieces from a reply.

Reply to: