[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#189311: marked as done (debootstrap segfaults in just_get() during d-i install)

Your message dated Wed, 30 Apr 2003 23:35:10 -0400 (EDT)
with message-id <[🔎] 20030501033510.5B4A5E80D@a750.nahmias.net>
and subject line Install report (2003-04-30)
has caused the attached Bug report to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what I am
talking about this indicates a serious mail system misconfiguration
somewhere.  Please contact me immediately.)

Debian bug tracking system administrator
(administrator, Debian Bugs database)

Received: (at submit) by bugs.debian.org; 15 Apr 2003 01:49:46 +0000
>From joe@nahmias.net Mon Apr 14 20:49:46 2003
Return-path: <joe@nahmias.net>
Received: from user-0ccerf2.cable.mindspring.com (a750.nahmias.net) [] 
	by master.debian.org with esmtp (Exim 3.12 1 (Debian))
	id 195FZx-0000qh-00; Mon, 14 Apr 2003 20:49:45 -0500
Received: by a750.nahmias.net (Postfix, from userid 1000)
	id 39892E80D; Mon, 14 Apr 2003 21:49:13 -0400 (EDT)
From: Joe Nahmias <joe@nahmias.net>
To: Debian Bug Tracking System <submit@bugs.debian.org>
Subject: base-installer segfaults during install
X-Mailer: reportbug 1.50
Date: Mon, 14 Apr 2003 21:49:13 -0400
Message-Id: <[🔎] 20030415014913.39892E80D@a750.nahmias.net>
Delivered-To: submit@bugs.debian.org
X-Spam-Status: No, hits=-0.2 required=4.0

Package: base-installer
Version: 0.020 (from /var/lib/dpkg/status.udeb); reported 2003-04-14
Severity: grave
Justification: renders package unusable


After working around previously reported bugs (189054 and 186443), when
I try to install the base system, base-installer gets a Segmentation
fault.  Here is the output as best I can reproduce it (ie. modulo typos,

Prompt: 1 - 22> 16
P: 0 100 Downloading Release file
I: Retrieving http://ftp.us.debian.org/debian/dists/sarge/Release
P: 0 100 Downloading Release file
P: 100 100 Downloading Release file
I: Validating /target/debootstrap.invalid_dists_sarge_Release
P: 100 100 Downloading Release file
P: 0 8040907 Downloading Packages files
I: Retrieving http://ftp.us.debian.org/debian/dists/sarge/main/binary-i386/Pakcages.gz
Segmentation fault
base-installer's postinst exited with status 35584
installer[44]: Configuring 'base-installer' failed with error code 256
installer[44]: Menu item 'base-installer' failed.

Any ideas?

Joe Nahmias, DD wannabe

-- System Information
Debian Release: testing/unstable
Architecture: i386
Kernel: Linux a750.nahmias.net 2.4.20 #1 Thu Jan 9 11:22:09 EST 2003 i686

Received: (at 189311-done) by bugs.debian.org; 1 May 2003 03:35:46 +0000
>From joe@nahmias.net Wed Apr 30 22:35:43 2003
Return-path: <joe@nahmias.net>
Received: from user-0ccerf2.cable.mindspring.com (a750.nahmias.net) [] 
	by master.debian.org with esmtp (Exim 3.12 1 (Debian))
	id 19B4rH-0002uM-00; Wed, 30 Apr 2003 22:35:43 -0500
Received: by a750.nahmias.net (Postfix, from userid 1000)
	id 5B4A5E80D; Wed, 30 Apr 2003 23:35:10 -0400 (EDT)
Subject: Install report (2003-04-30)
To: debian-boot@lists.debian.org
Date: Wed, 30 Apr 2003 23:35:10 -0400 (EDT)
Cc: tfheen@debian.org
Reply-To: debian-boot@lists.debian.org
X-message-flag: Formating hard disk. please wait...   10%...   20%...
X-Mailer: ELM [version 2.4ME+ PL100 (25)]
MIME-Version: 1.0
Content-Transfer-Encoding: 7bit
Content-Type: text/plain; format=text; x-action=sign; charset=US-ASCII
Message-Id: <[🔎] 20030501033510.5B4A5E80D@a750.nahmias.net>
From: joe@nahmias.net (Joe Nahmias)
Delivered-To: 189311-done@bugs.debian.org
X-Spam-Status: No, hits=-6.7 required=4.0
X-Spam-Checker-Version: SpamAssassin 2.53-bugs.debian.org_2003_04_23 (

Hash: SHA1

Hello again everyone!

I'm back with another installation report; and this one can finally be
called an installation since I managed to get all the way through <the
crowd goes wild!>.

I did this install using a PXE boot of the daily snapshot from today
(2003-04-30).  Although I was able to get a working install, I ran into a
number of issues.  Here's the list:

0) debootstrap now works!  WooHoo!!!  In celebration, I'm bcc-ing
{189058,189311}-done@bugs.debian.org.  Many thanks to everyone who helped
with this!

1) Ethdetect still attempted to load the eepro100 module for my network
card instead of e100 (see bug #189054).  I checked, and it seems that
version 0.23 of ethdetect was used in the daily image, not 0.25 (the
latest) which has a fix for this.  Upon investigation, it seems that the
daily build has been failing since April 19...Tollef??

2) mkswap wasn't found which caused much evil :-(  I worked around this by
not declaring any swap partitions, so it wasn't attempted.  I guess this
is because we are back to using busybox (1:0.60.5-2) instead of
busybox-cvs; Is this intentional?  Should I file another bug against
busybox?  against anna (?) for not using -cvs?  Add confirmation to bug
#183597?  Ignore it because busybox-cvs will (soon) be the default?

3) Bug #186443 is still alive and ticking since /target/etc/fstab is still
not being generated after the partitions are mounted.  I will do some more
detective work to see if I can nail this down.  Something still doesn't
make sense to me...  Can anyone confirm that it is partconf.postinst that
should be running /usr/lib/prebaseconfig.d/40fstab?

4) When I told lilo-installer (0.0.11) to install lilo into the new root
partition (call me old fashioned, but I don't like overwriting my MBR when
dual-booting), it didn't prompt me to set that partition as active for the
reboot/base-config.  I checked/fixed this before rebooting during my
install, otherwise this would have left me in a bad state and I'd have to
re-install.  I think that if lilo is installed anywhere except the MBR,
there should be a prompt offering to do this for the user (defaulting to
yes).  Agree/Disagree?  This situation/argument would be equally
applicable to grub-installer, I suppose.  After examination, I see that
this is listed in the TODO for lilo-installer with a possible solution; I
will file a bug and see if I can send in a patch to implement this as

5) After the reboot, the console had some problems.  First of all,
lilo-installer decided to set ttyS0 as the console -- without so much as a
message to that effect.  Luckily, I had the necessary cable so that I
could continue base-config via minicom, but this was definately a rude
suprise.  After examination, I see this happened b/c my PXE server sends
two console options to the kernel when booting -- one for the serial port
and one for vc0.  Since vc0 is last, that is the one used by linux, but
lilo-installer only checks if the serial is defined -- not if it is the
default.  There seems to be an easy patch for this, which I will send in a
bug report against lilo-installer.

6) Also, if we are going under the assumption that there is a serial
console, why isn't a login prompt generated on the serial port after
base-config finishes?  As it worked out, no getty was run on the serial
port, instead vc0 got a login prompt and console messages were still sent
to the serial port!  Should I file a bug against base-config or does some
other package handle setting up /etc/inittab (dpkg -S couldn't tell me)?

7) Another thing, after reboot the network was unavailable since the
proper module (e100) for eth0 wasn't loaded.  Perhaps the reboot step
should get the output of lsmod and append it to /target/etc/modules,
before rebooting.  Note hw-detect-full cannot do this (as would be
logical) since /target isn't created/mounted at that point.  File a bug?
Against which package?

8) I don't know if this is d-i related, but after I did a modprobe e100 to
correct the above (#7), ifup eth0 (?) wasn't run properly and failed to
properly configure the network.  I ended up doing ifdown eth0; ifup eth0;
which fixed it.  Any ideas what caused this?  Where should I file a bug?

Overall, I'd say d-i seems to be inching towards what I would consider
beta status.  Then again, I'm only using it on i386; I'm sure the other
ports are in worse shape (unfortunately, all I have is i386 to test on).

Anyways, I hope all this helps.  Thanks again for all your efforts!

Joe Nahmias, DD wannabe
Version: GnuPG v1.2.1 (GNU/Linux)


Reply to: