[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

[d-i] make demo errors, no frontends in cdebconf udeb

I tried to do a make demo 

* first I installed cdebconf to /usr/local/. I rebuild cdebconf*.udeb,
  ethdetect*.udeb, choose-mirror*.udeb, main-menu and wget-retriever and I
  copied them to localudebs
* I modified the Makefile to do a mklibs -L /lib:/usr/lib:/usr/local/lib
  (bug filled because -L /usr/local/lib should have worked)
* I did a fakeroot make TYPE=net
* I tried to do a make demo as root :

* first error, there are some missing symlinks for libs (ldd bin/sh)
ld-linux.so.2 -> ld-2.2.5.so
libc.so.6 -> libc-2.2.5.so
libdl.so.2 -> libdl-2.2.5.so

And last error :
frontend.c:213 (frontend_new): Cannot load frontend module /usr/lib/cdebconf/frontend/slang.so:

There is no frontends in cdebconf*.udeb

Am I missing a step ?

Thomas Poindessous

To UNSUBSCRIBE, email to debian-boot-request@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Reply to: