[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#121177: boot-floppies: can't install dpkg

Package: boot-floppies
Version: 3.0.17-2001-11-18
Severity: critical

trying to install debian "woody" on my test machine (386DX-40, 8mb ram) results
in this error (on tty4):

-- snip --
Preparing to replace dpkg 1.9.18 (using .../archives/dpkg_1.9.18_i386.deb) ...
Unpacking replacement dpkg ...
dpkg-deb: subprocess paste killed by signal (Broken pipe)
dpkg: error processing /var/cache/apt/archives/dpkg_1.9.18_i386.deb (--install): subprocess dpkg-deb --fsys-tarfile returned error exit status 2
Errors were encountered while processing:
-- snip --

the installation system reports: "Failure trying to run: chroot /target dpkg"

then: "debootstrap exited with an error (return value 1)"

at which point it takes me back to the b-f menu where i can try to install the
base system again.

i'm installing on to a 4gb ide drive; it's partitioned with a 50mb /boot, a
16mb swap partition, and the rest on the root. i'm installing over the network
with a 3c509 isa board, from bigfoot.eecs.umich.edu. i'm connected to the 'net
via dsl.

this bug may actually belong to dpkg.

incidentially, it would be _great_ if the .debs that were downloaded were used
if i tried the installation again; i got the error once, then tried it again.
the installer downloaded all the packages _again_. this is not a Nice Thing(tm)
to do, considering that it takes well over an hour to download & verify all
those packages on such a slow system.

-- System Information
Debian Release: testing/unstable
Kernel Version: Linux proton 2.2.19-udma100-ext3 #1 SMP Fri Sep 28 22:56:58 CEST 2001 i686 unknown

Reply to: