[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#120480: boot-floppies: pcmcia removal problems

Package: boot-floppies
Version: 3.0.17 (udma100-ext3)

While installing the udma100-ext3 flavour of 3.0.17 boot-floppies on a
Toshiba Satellite Pro 4300, I ran into some problems with the PCMCIA

I configured PCMCIA support which worked fine (correct modules loaded
etc.), I then went to configure the network which also went okay until
at the end when it tried to reload the pcmcia modules.  This failed.
In the syslog, I got (rough transcription):

| dbootstrap: ds: device or resource busy
| dbootstrap: i82365: device or resource busy
| dbootstrap: pcmcia_coure: device or resource busy
| insmod: insmod: a module named pcmcia_core already exists
| user.err dbootstrap: an error encountered while trying to load and configure the pcmcia modules

cat /proc/modules showed (again, rough transaction):

| serial_cs 0 (unused)
| 3c574_cs 0 (unused)
| ds 0 [serial_cs 3c574_cs]
| i82365 22704 2
| pcmcica_core 0 [serial_cs 3c574_cs ds i82365]

I removed the modules byhand in the correct order and reran the
'configure pcmcia support' step which got me working networking.

This is reproduceable (this is my second install since I didn't take
notes first time round), and if you need more info, I can probably
reinstall again to get more details if you tell me what you need.


Reply to: