[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

[fw: Re: Problems with first boot of Debian (No AT keyboard, yet scans for one)]

I didn't seee a cc for debian-boot on this one, any ideas? Anyone?


----- Forwarded message from Astardok <astardok@hotmail.com> -----

From: "Astardok" <astardok@hotmail.com>
Subject: Re: Problems with first boot of Debian (No AT keyboard, yet scans for one)
To: "David Kimdon" <David_Kimdon@alumni.hmc.edu>
X-Originating-IP: []
X-OriginalArrivalTime: 12 Oct 2001 07:29:47.0886 (UTC) FILETIME=[ABF758E0:01C152EF]
X-UIDL: 1002871797.49495.limousin.fr.clara.net

OK...  As far as I got in the installation was right after I installed all
the drivers/base system files, and it restarted, and the next thing it's
prompting me for regards the Md5 passwords.  However, the problem is that
ever since that first reboot, regardless of which disk I use (the rescue
disk, the regular boot disk, or a regular boot from the hard drive), I get
the AT keyboard error.  Because of this, I can get no further in my Linux
installation; the keyboard stops responding completely (even to caps/num
lock) once Linux searches for an AT keyboard.

Also, the keyboard works perfectly fine for Lilo, and for passing arguments
to the kernel at bootup via the boot disk (speaking of which, the
root=/dev/XXXX didn't work out).  It's after that where it ceases to

Not sure what to do from here.  Any other ideas?

- Paul Goins

...And just for those who didn't quite get where I am in the installation
process, a brief outline of what I've done thus far:
(I have a PS/2 keyboard, and there is no AT port on my motherboard (Asus

0. Tried installing SuSE Linux off of a friend's CD.  Keyboard worked for
the initial menu, but once the temporary kernel was loaded, received a "No
AT keyboard present" error.  (Otherwise, this has happened with another
distro as well.)

1. Downloaded the most recent Debian off of debian.org (1.44 floppy version)
and wrote the images to disk using rawrite2.
2. Booted into Linux setup via a rescue disk.  (Kernel loaded fine, keyboard
works without a hitch until further notice)
3. Set up Linux fairly standard.  Regular US keyboard setup, swap partition
of about 250 megs or so, 9.75 gigs for the main linux partition (sloppy I
know, but it shouldn't impact simply getting Linux up and running).
4. The only customization I can remember is adding vfat support, as my
system is a dual-boot with media files stored on one of my 15 gig fat32
5. After installing the full base system, removed disk from floppy drive,
restarted and booted off of hard disk.
6. While booting up, kernel searches for AT keyboard, cannot find one.
Keyboard stops responding.  Forced to restart computer at Md5 password
7. Tried rescue disk to attempt to edit settings.  Upon loading of the
kernel, AT keyboard once again undetected, and keyboard ceases to f unction
until next reboot.
8. Overwrote Lilo with Boot Manager from Ranish Partition Manager, in order
to be able to boot into Windows.  (Keyboard works perfectly fine for all of
9. Attempted to boot via the regular Linux boot floppy, failed due to
non-recognition of an AT keyboard.
10. Attempted to pass root=/dev/XXXX to kernel, nothing happened (kernel
didn't accept the command, don't recall exact error message)
11. (Where I am now.)

----- Original Message -----
From: "David Kimdon" <David_Kimdon@alumni.hmc.edu>
To: "Astardok" <astardok@hotmail.com>
Cc: <debian-boot@lists.debian.org>
Sent: Thursday, October 11, 2001 5:39 PM
Subject: Re: Problems with first boot of Debian (No AT keyboard, yet scans
for one)

> Wed, Oct 10, 2001 at 10:29:49PM -0700 wrote:
> > I just recently installed Debian GNU/Linux off of a downloaded floppy
> > (vanilla), and am having some problems.  Although the actual install
> > without a hitch, and my keyboard worked fine, when Debian tried to load
> > itself from the hard drive after being installed from the floppies, it
> > getting the same error:
> >
> > keyboard timeout: no AT keyboard present
> > keyboard timeout: no AT keyboard present
> >
> > Despite the fact that I'm using a ps/2 keyboard (and that I have no AT
> > to begin with), the kernel continues to persist in looking for an AT
> > keyboard.  Also, when I put the rescue disk in, the same error occurs,
and I
> > am unable to change anything in my installation.
> I'm confused.  Does this mean you could first boot off the rescue disk
> to complete the initial install, and now you can no longer boot off
> the rescue disk?
> If you can still boot off the rescue disk (or a boot floppy that you
> may have created at installation) perhaps by passing an appropriate
> root=/dev/XXXX to the kernel?  I'm not sure why Linux is hanging there
> though.
> -David

----- End forwarded message -----

Reply to: