[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

debootstrap stalls

I tried installing the latest woody floppies (3.0.14-2001-09-15).
The target machine is an IBM PS/2 55sx (486 without fpu),12Mb RAM,
500Mb disk and an MCA bus etherexpress network card.

The kernel booted and reached the first message screen. This screen
of text is bigger than the window. I wanted to read the rest of it
but when I tried space or return (went through the install twice here)
was unable to read the rest of the text, just got kicked to the next stage.

Install then proceeded normally to recognize already existing partitions
mount root and swap and load drivers from the four driver floppies.
Driver floppies loaded ok and got to scan through all the available
modules. Why do some of the modules have no description? What really
comes to mind are the character set modules, none of them are labelled.
I distinctly remember that descriptions for these modules are present
when kernel compile options are selected with make menuconfig. These
same modules were unlabelled in the potato boot floppies, no improvememt
here. If it is of any help I can type these in somewhere.

The network card module installed fine. The module installer did report
a disturbing message about a file having the wrong time.

Selected a base system install via network. Got the network configured
with a static ip and on console 2 ifconfig reports a working network.
Chose to download from http://http.us.debian.org with proxy set to none.
Nameservice and connectivity works as I can ping http.us.debian.org
(50ms echo time) from console 2. A nice thing I noticed is that console 2
is noticeably more functional than on the potato install floppies.

Another nice improvement seems to be memory usage, since on this somewhat
low memory machine the potato install floppies did not get this far, the
kernel froze with some VM error.

The install then stalls at debootstrap. The first time it could not connect
at all, retried and it got further and began to try to get base-passwd.
After a period of no obvious activity from the install screen an error
message returns saying "couldn't download base-passwd". Going back to base
system and trying again eventually gets the file downloaded. Repeating this
procedure several more times has gotten me up to trying to load bsdutils.

At this rate debootstrap might get the base system loaded by next year
if I am patient enough :)

So I guess my report is negative. What is wrong? Are there further things
I can try from console 2 to give more information or to fix the problem?

Cheers Hugo Graumann

Reply to: