[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

ae can't open terminal

Hi All,
I'm trying to create a rescue disk for myself using ae as an editor on
the rescue disk.  I compiled and tested ae and it seemed to work fine on
my development system so I mounted the rootdisk that I'm creating as a
loop device:

	#mount -o loop /tmp/fs /mnt

and chrooted to /mnt

	#chroot /mnt

Now ae says it can't open the terminal when it was working fine before.

	# ae
	Error opening terminal: xterm.

I also tried this from tty1 instead of through X and I got basically the
same error:

	# ae
	Error opening terminal: Linux.

I'm using busybox as a shell and basic system and I've also installed
the following libraries:

	# ls lib
	ld-2.2.3.so        libc-2.2.3.so      libncurses.so.5
	ld-linux.so.2      libc.so.6          libncurses.so.5.2

I didn't install slang because "#ldd ae" returned:

	libncurses.so.5 => /lib/libncurses.so.5 (0x4001f000)
	libc.so.6 => /lib/libc.so.6 (0x4005f000)
	/lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0x40000000)
I also tried adding libslang but the results were the same.

Any help would be greatly appreciated.


P.S. I did create the filesystem by hand.  Could I be missing a device
for the display or something?

Reply to: