[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#105451: installation impasse

Package: boot-floppies
Version: stable, kernel 2.2.19pre17
flavor: compact
architecture: i386
model: AMD 486 DX4-100 (clone)
memory: 24MB
scsi: none
cd-rom: none
network card: none
pcmcia: none

I'm trying to migrate from an old Slackware system with kernel version
1.2.9 to something stable and more modern, so I tried to install the
current Debian release, using two empty 360-MB partitions on hda --
one for /, one for /usr.

Making the root, boot, driver and 11 base-system floppies went smoothly.
The install script was easy to follow, and I ended up with the new
system on the two partitions without disturbing the old system.

When I booted from the custom recovery floppy and tried to configure
the system, I ran into a snag: I need to download the rest of the stuff
over a PPP connection, but my modem is on cua14 on the old system,
using port 0x2f0 and irq 2.  (COM1 at 3f8, irq 4 is the mouse; COM2 at
2f8, irq 3 is a serial line my wife logs in on with an old glass tty.)

Because of the need to set up ttyS14 for the modem by hand, I couldn't
use the ppp setup script (and anyway the chat script I have to use is
too complicated for the automatic installation script to configure).
So this basically halted the installation at that point.  I went to
another virtual console and tried to set it up by hand.

I figured

	mknod /dev/ttyS14 c 4 78

would create the special file, and it appeared to.  I set the
permissions and ownership to match the other COM ports (root:dialout
660) by hand, and tried to configure the port with

	setserial /dev/ttyS14 uart 16550A port 0x2f0 irq 2

which is the same as the line in rc.serial on the old system that sets
this port, except for using ttyS14 instead of cua14.  But I get

	No such device: /dev/ttyS14

back from setserial.

After an extensive Google search for "Debian" and "ttyS14", which
turned up lots of other people (most of them trying to install modems
in laptops) with similar problems, but no solution, I figured that the
problem might be a missing serial-port module: lsmod shows no modules
at all, and there was an error message complaining that there was no
driver for char-major-4, which is aliased to "serial" in modules.conf.

The serial-port driver for kernel 2.2.19 seems to be generic_serial.o
instead of the serial.o used in versions 2.2.18 and earlier.  I grabbed
a kernel package that had this in and tried inserting it into the
kernel, which then complained that there was already a serial-port
driver loaded.  Either way, the symptoms remain unchanged.

I tried configuring the port at boot time by uncommenting the line for
it in serial.conf and filling in the proper values, but this only added
the "No such device" complaint to the boot log.  However, forcing the
module to load at boot time by adding a line for it in modules.conf
makes lsmod say that generic-serial is (unused) -- but maybe that's
just because it was already compiled into the kernel, so the loaded
copy is redundant.

I also tried extracting a copy of serial.o from one of the 2.2.18
kernel packages, but that turns out to have a dozen or more undefined
references and won't load; it is clearly incompatible with the 2.2.19
kernel.  Has anyone actually verified that generic_serial can correctly
set up ttyS14 in the 2.2.19 kernel?  I am getting the impression that
the generic_serial driver in 2.2.19 can't handle ttyS14.

I have succeeded in making Lilo boot the new kernel from the hard disk
so I don't have to wait for the incredibly slow floppy to boot; it
seems to take 5 or 10 seconds per track to load.  So the box is now
dual-boot, with the old 1.2.9 Slackware kernel the default, and
"debian" an additional choice.  This should make the migration easier
*IF* I can ever get the modem working under Debian, so I can finish
building the new system.  Then I should be able to just add the old
/home filesystem to fstab, make the new kernel the default, and be in

The modem is a no-name clonemaker's special; I can't even find the
booklet that came with it that tells how to set the jumpers, so I'm
stuck with the port and interrupt.

The only other thing I can think of that might contribute to the
problem is that the filesystems were built on the debian partitions by
the old Slackware system; but presumably as they are regular ext2
filesystems that should not cause problems.  If this interfered with
device files, I shouldn't be able to read the hard-disk partitions from
the new system.

Any suggestions on how I can finish the debian installation on this box
will be very welcome.

		-- Andy Young

Reply to: