[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

bootfloppies 2.3.6 problems installing woody


I have just spent some time installing woody on an Athlon 1.4GHz with
ASUS A7V133-C motherboard. I found some glitches, maybe these are known
in which case this message was deprecated before it was actually written

I used the idepci flavour of 2.3.6 boot-floppies, the machine has a 20Gb
IBM HD and no scsi, no sound, no mouse.

Boot went ok along with everything up until installing kernel and
I tried network after which I had to set up network (of course).
This should be with static address which appeared to work ok. More on
this later.
Giving the http address to my local mirror produced an error (but I know
it is there and working), apparently the install system was unable to
lookup my mirror from the DNS. I changed to an official mirror
(ftp.se.debian.org) outside our firewall and added the gateway.
Downloads fine.
Installs and downloads base system fine as well as booting up again.

Now two problems revealed themself. 

Apparently the dhcp-client package beleived it should give my machine a
dhcp address, went ahead and did so. It seemed to destroy the
resolv.conf file in the process ,by adding \000 directly after my
This happened several times because I did the inital install three times
for reasons I now come to. So I am fairly certain that it was the case.

The second problem was that during downloading and installing the
standard packages,
one comes to the question if gpm should be reconfigured. 
As the computer should have no mouse (it is a sort of a beowulf node)
(and I forgot to unselect gpm) I just say no to reconfiguring.
Then the keyboard goes dead and it is impossible to answer the next
config question
(which incidently is if I should have american or british standard
dictionary for ispell). First time it happened I thought my keyboard or
keyboard port dropped dead,
and didn't unselect gpm for my next install. (If anything goes severly
wrong during the install process I redo from the beginning to save
possible future problems, not so efficient for very configured systems
So second time around I experienced the dhcp problems as seen above
(although I did not solve them until the third time) and the keyboard
(actually another keyboard) died immediately after not changing

Now I saw the pattern, and the third install with a short visit in
dselect for unselecting gpm worked well, except it left the machine
having IPnumber x.x.64.203 instead of the one specified in
/etc/network/interfaces as x.x.64.103.
I admitt the similarities between the addresses confused me quite a bit,
but double-checking three times and finding that dhcp-client was
installed by looking at the output from dpkg --get-selections. It also
seemed to be the one screwing up resolv.conf as the problem vanished
once I purged dhcp-client.

my 0.02

Reply to: