[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Install Report II (The Revenge; bf 3.0.7 (beta); Acer Laptop; floppy/basedebs)


(cc'ed to -boot for courtesy reasons only; it's probably best if reports
go straight to -testing, and get discussed there until the problems are
understood well enough for bugs to be filed, rather than having all this stuff
go in multiple lists and such)


Machine Type: i386
Processor: Pentium III (Coppermine) 547MHz
Memory: 64MB
Root Device: IDE
Root Size: 300MB
Boot Device: floppy

Boot-floppies 3.0.7-2001-06-30, downloaded from
1.44 MB idepci floppy images.


Boot Complete      [X]
Keyboard Config    [X]
Create Partitions  [X]
Install kernel     [X]
Install drivers    [X]
Config drivers     [ ] -- unnecessary on this system
Config Network     [X]
Install Base       [X]
Config Base        [ ] -- this happens after the first reboot now
Create boot disk   [ ] -- skipped, will just use rescue.bin
Make bootable      [ ] -- skipped, will just use rescue.bin
Reboot             [X]

Used GNU parted to resize the Windows FAT32 partition from the full 4.6GB down
to 4.2GB. Lovely, lovely tool, although the interface is kinda sucky.

The boot-time fbcon (?) logo had dodgy colours. It had them on a variety of
machines that I've booted now. Tacky.

Partitioned into /dev/hda2 = 400MB linux; /dev/hda3 = 65MB swap. Made
swap, made ext2fs. Mounted root.

When installing kernel and modules, it reads from /dev/fd0 *before*
prompting you to insert the rescue disk. It probably doesn't need to
and shouldn't.  The "the is disk 1 of 1 in the drv14idepci series"
note and progress bar is kinda nice.

Switched to VC2, noted that ifconfig -a listed eth0, so didn't setup
any modules. Went to configure the network, tried DHCP, waited for a
few minutes (which seems very dodgy) got told it had been successfully
configured, switched to VC2, noted that eth0 didn't have an IP address.
Fixed DHCP server, tried again. This time it took only a couple of seconds,
and actually did work.

Decided to simulate a mounted/NFS install using the new basedebs tarball
(thats a .tgz containing all the debs debootstrap would download). This
isn't for the faint of heart yet, but should be nicely integrated soon.

So, switched to VC2, set my http_proxy, cd'ed into /target to get some
disk space, and ran:
	wget http://penguinppc.org/~eb/debian/i386/basedebs.tgz
Then ran:
	debootstrap --download-only --arch i386 \
		--unpack-tarball /target/basedebs.tgz \
		woody /target null:
and got told:
	E: /pool/main/r/rp-pppoe/pppoe_3.0-2_i386.deb was not pre-downloaded
so the basedebs tarball is missing pppoe atm. Tsk tsk. Ran:
	debootstrap --download-only --arch i386 woody /target \
which downloaded pppoe for me and finished successfully.

Switched back to VC1, chose install the base system, with a network
install, and tried setting my download URL to be "null:". This appeared
to work happily. The debootstrap "Please Wait" display is a bit ugly now as
far as the progress display is concerned :-/. Seemed to work though.

Rebooted the system.


This is more free form but should contain the following:

Installation process: LAN

Installation experience:

Rebooted with rescue floppy, "rescue root=/dev/hda2". Miscoloured Tux logo
again. Boot was otherwise pretty fine.

Lied and said the hware clock was GMT. How's it going to know I'm not in
England anyway? Well, apart from the fact that it asks me where I live,
anyway. :)

Enabled md5 passwords and shadow passwords. Tried leaving the root
password blank, wasn't allowed to. Made it some other lame thing
instead. Skipped the user account. Said no to PPP. Told it to use http,
yes to non-US, no to non-free/contrib. Had to once again tell base-config
I'm in Australia. Changed my mind and entered the info by hand. Got asked
for http proxy information. Entered it. apt-get update was run, using the
proxy. Didn't add another apt source. Did you security updates. Updated
again, also using the proxy. Ran tasksel. Was surprised to see some
tasks listed -- tasksel in woody's broken atm, but apparently the bind
and news-server tasks are in the security area. Ran dselect. Chose to
install all of optional. Ignored the dep/conflict screens as best I could.
Got told: "Need to get 2066MB of archives. After unpacking 6158MB will
be used". On a 300MB /? apt aborted. :) base-config asked me I wanted
to retry.  Said yes. It didn't let me go back to dselect, it just ran
apt again. Lame.  Said "No". Said "Ok". Got a login prompt. Without
having anything but base, had 111MB used. rm'ed basedebs.tgz (20MB)
and ran apt-get clean. Hrm. base-config doesn't get rid of the
debootstrap.invalid files in /var/lib/apt/lists; apt-get update does,
though. Wonder what's with that. Ended up with 68MB used. So 100MB is
probably about minimal for an install, with more than that if you want
to actually do anything. /var/lib/dpkg and /var/lib/apt use up a fair
amount of that though :)

There didn't seem to be any bad permissions this time, either.

Still looking good. If someone can fix basedebs.tgz to include pppoe,
we're well on our way to supporting all our installation methods except

What do people think of this format of report? Can we put this up on a
webpage somewhere official, with any appropriate modifications?


Anthony Towns <aj@humbug.org.au> <http://azure.humbug.org.au/~aj/>
I don't speak for anyone save myself. GPG signed mail preferred.

``_Any_ increase in interface difficulty, in exchange for a benefit you
  do not understand, cannot perceive, or don't care about, is too much.''
                      -- John S. Novak, III (The Humblest Man on the Net)

Attachment: pgpVh0dRpuj2q.pgp
Description: PGP signature

Reply to: