[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Install Report, powerpc oldworld 2.3.6 dtd 6/21 06:11 (woody)

> On Mon, Jun 25, 2001 at 09:08:24PM -0700, Chris Tillman wrote:
>> The symlink was generated, I verified it was there. modules.dep was
>> definitely not there.
> probably because you have such serious filesystem corruption that
> depmod puked.
>> Wouldn't filesystem corruption be solved by re-initializing the disk? Well
>> unless badblocks not working means it's trying to use bad blocks in the fs.
>> I didn't have that problem with 2.2.19, I'll go back and try an install with
>> the 2.2.19 floppies I still have to see if the disk is really bad.
> if your disk or controller are seriously hosed you will have data
> corruption no matter how many time you run mkfs.  those kernel
> messages you posted about b0rked inodes and whatnot is CERTAINLY
> filesystem corruption, beleive me i have had much more experience then
> i would prefer in that area....
> that and it looks like the filesystem drivers.tgz was living on was
> corrupt as well.  what filesystem is that?  if its hfs try something
> real, hfs is a flaky.

Well, i tried installing from the 2.2.23 floppies and all went well. That
was on the exact same partition that 2.3.6 had so much trouble with. BTW, I
pointed the installer at the exact same folder on my HFS drive as I did for
the other install. It installed 2.2.19, no errors.

I also did a fsck on the root partition /dev/sdb4 and it said it was clean.

Then I went back to 2.3.6 and installed on a different partition than I had
previously. I got the same results, various zcat format, crc, length errors.
Also an unexpected EOF. It had the same trouble reading the files off the
HFS drive also.

I tried fsck under 2.3.6, it was not found (no symlink in the new b-f
apparently), so I tried e2fsck on /dev/sdb5 (which was the partition I was
installing 2.3.6 on). It just said
ext2fs library version out of date! (emphasis not mine, and then)
e2fsck-1.21-WIP, 14-Jun-2001 ...
Using EXT2FS Library version 1.19, 13-Jul-2000

Then I booted back in under the 2.2.23 b-f, and did fsck -v /dev/sdb5 with
e2fsck-1.18, (on the partition which I had tried to install from 2.3.6). It
//dev/sdb5 contains a filesystem with errors, check forced.
Checking inodes, blocks, and sizes.
Checking directory structure
Directory inode 26417, block 0, offset 0: directory corrupted
Missing '.' in directory inode 26417
Setting filetype in entry '.' in ??? (26417) to filetype 2.
Missing '..' in directory inode 26417
Setting filetype in entry '..' in ??? (26417) to filetype 2.
(repeat above for 2 other nodes 30481, 32513)
Pass 3: Checking directory connectivity
'..' in /lib/modules/2.2.19/block (26417) is <The NULL inode> (0), should be
/lib/modules/2.2.19 (24385)
'..' in /lib/modules/2.2.19/ipv4 (30481) is <The NULL inode> (0), should be
/lib/modules/2.2.19 (24385)
'..' in /lib/modules/2.2.19/ipv6 (32513) is <The NULL inode> (0), should be
/lib/modules/2.2.19 (24385)
Pass 4: Checking reference counts
Inode 2 ref count is 4, should be 7. Fix(y)?
Inode 24385 ref count is 9, should be 6. Fix(y)?
Unattached inode 26418
(same for 17 other inodes)
Summary: 74 inodes used
51 regular files
13 directories
1 symbolic link (1 fast symbolic link)
47 files

I then initialized a 3rd partition /dev/sdb6 with the e2fsck-1.18 and
rebooted with the 2.3.6 boot-floppy. I mounted sdb6 as root, without
re-initializing and went straight to Install Operating System. similar
errors were again generated, bad tar headers, input/output errors.

Interestingly, it's always the modules that have difficulty, the kernel
installation doesn't give errors.

I re-initialized sdb5 using b-f-2.3.6, then went back in with b-f-2.2.23 and
ran fsck on that partition, it was clean. So it's apparently not mke2fs
that's having a problem, even though fixing the bad blocks scan would
probably be a good idea.

I really think there must be some problem with the module installation code,
some change between b-f-2.2.23 and b-f-2.3.6. Somehow it's fscking up the
filesystem, writing over . and .. , etc.

|  .''`.  | Debian GNU/Linux: <http://www.debian.org>            |
| : :'  : | debian-imac:    <http://debian-imac.sourceforge.net> |
| `. `'`  |      . oo       Chris Tillman                        |
|   `-    |     (   -)      tillman@azstarnet.com                |

Reply to: