[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Install Report, powerpc oldworld 2.3.6 dtd 6/21 06:11 (woody)



On Sun, Jun 24, 2001 at 03:21:20PM -0700, Chris Tillman wrote:
> These are some notes as I attempted to install the woody b-f.
> 
> After selecting Partition a Hard Disk, an alert advised about there
> being no need for a boot partition and "... and the root partition
> must be on the first disk". I have had Debian installed on this
> machine before, on the second external SCSI drive (address 6), so I
> think this message might be in error? I'm not sure what the 'first
> disk' would mean except only sda, not sdb or sdc.

its for quik, many versions of OldWorld BrokenFirmware(TM) are
incapable of booting from anything but the master IDE disk, im not
sure if that matters on scsi or not, maybe we can kill the check for
scsi systems.  

> There is a "please wait" message after completing partitioning that
> flips by so fast it's unreadable.

thats just what it puts up saying its determining the current status
of installation or something like that.  normally you never see it
unless there is some delay, such as a CDROM spinning up or such.  

> I noticed, this has probably always been a feature, that if you're
> heavy handed with the enter key, it's easy to skip steps, or rather,
> have them performed as default. For example, if you don't have a
> CD-ROM installed, try holding down the enter key at 'Install Operating
> System' and watch it loop.

i don't think i understand...

> When installing the kernel, choosing a location is a two step process. 
> First you're asked to choose the directory where the Debian archive 
> resides, then you're asked to select a directory containing a file 
> powermac/images-1.44/rescue.bin. This seems redundant, why not skip 
> the first question and get right to the point.

i have never liked the way this worked, but im not sure of a better
way.  

> The message displayed while the kernel is being installed is 
> "Installing the Rescue Floppy ...". this is confusing to beginners, 
> they start looking for a floppy disk they think it will be making. 
> I think it should change to "Installing the Linux Kernel ..."

remember that debian also supports the GNU/Hurd kernel so we have to
be careful about hard coding references to linux.  but in any event it
should be simple to reword this to something like: Installing
Operating System Kernel..."

> The first module install seemed to be successful, but when I tried to 
> install ipddp it said 
> Can't open dependencies file /lib/modules/2.2.19/modules.dep
>   (No such file or directory)
> and -> Installation failed. 

thats odd..  can you check that /lib/modules gets symlinked to
/target/lib/modules and that modules.dep was generated?

> In the module installation screen it said
> Architecture-specific modutils config not found, using defaults 
> EXT2-fs error (devce sd(8,20)): ext2-readdir: bad entry in directory 
>    #38609: rec_len % 4 !=0 -offset=0, inode=2880897209, 
>    rec_len = 54986, name_len=164
> depmod: /lib/modules/2.2.19/fs/fat.o is not an ELF file
> depmod: multiply defined
> segmentation fault

aieee! this looks like filesystem corruption, wonder how that happened....

> I verified there was indeed no modules.dep to be found there, and 
> then noted the previous error messages on tty3:
> 
> installing kernel and modules from /instmnt
> kernel and module install was successful
> moving away /lib/modules to /lib/modules.old
> making /lib/modules a link to /target/lib/modules
> depmod: /lib/modules/2.2.19/fs/fat.o is not an ELF file

ah here is the problem.. strange i don't think i had this problem in
my last test.  

> It looked to me like a disk reading problem, so I went back to 
> Initialize a Partition and re-initialized the intended root partition. 
> This time I chose to do the bad blocks scan, and noted this error 
> message within the ext2fs screen (mke2fs 1.21-WIP): 
> badblocks: error while loading shared libraries: badblocks:
>    undefined symbol: ext2fs_sync_device

yeah we know about this, i don't think anyone has figured out what
went wrong yet though. 

> After this I re-tried installing the kernel, this time I got
> 
> tar: Bad tar header, skipping
> There was a problem installing the Drivers from /instmnt/ppowermac/drivers.tgz
> extracting Drivers ... failed with 1
> /lib/modules/2.2.19/ipv6/bsd-comp.o: input/output error
> depmod: local symbol ^D8 with index 60 exceeds local_symtab_size 25

yes you definitly have a seriously corrupted filesystem.  this time
its the filesystem you have drivers.tgz on.  

> I retried again, initializing without the bad blocks test. This time
> the installer thought it had succeeded, but the same errors appeared on 
> tty3:
> 
> /lib/modules/2.2.19/ipv6/bsd-comp.o: input/output error
> depmod: local symbol ^D8 with index 60 exceeds local_symtab_size 25

filesystem corruption

> After this, I chose Configure Drivers and got a segmentation fault, 
> followed by a quick display of all the /lib/modules/2.2.19 folders, 
> each followed by : input/output error, and the next dialog came up 
> with the first item in the list labeled "block/2.2.19 .2.19"  

almost certainly due to filesystem corruption. 

> I tried yet again after re-initializing the disk, and got YA error:
> 
> zcat: Invalid zcat magic

filesystem corruption

> Then i tried moving the install files to /target/tmp, when I tried 
> it with that setup I got 
> 
> zcat: invalid compressed data -- crc error
> zcat: invalid compressed data -- length error

filesystem corruption.

> I figured that was enough for one night...

you hardware has said enough of that for one(all) night(s) im afraid :(

-- 
Ethan Benson
http://www.alaska.net/~erbenson/

Attachment: pgpeokcG7nzAw.pgp
Description: PGP signature


Reply to: