[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#101632: Problems installing Kernel and drivers in Linux 2.1

Package: Installation
Version: 2.1

Kernel Version : 2.0.x
Source : Installation CD-ROM received with the book
?Installing Debian GNU/Linux ? The Authoritative
Solution? by Thomas Down. Published by SAMS

Hardware Details

Processor : PII 300 MHz
Manufacturer : Micronix
RAM : 64 MB
Hard Disk Type : IDE (no SCSI)
O.S. : Windows 2000
Hard Disk Space : 8 GB
CD-ROM : Mitsumi CD-ROM FX320S (IDE)

Steps Followed :

1. Before installing Windows 2000, I had partitioned
my hard disk and created 2 partitions of 5 GB (C:) and
3 GB (D) respectively.  I installed Windows 2000 on C:
and kept the second empty. Windows 2000 has run
successfully on my system for the last 2 months.

2. I decided to try and install Linux on the second
partition (D:).

3. Specifying the CD-ROM drive as the first drive to
search for in the CMOS, I inserted the Debian
Installation CD and re-booted the system.

4. I was able to get to the boot prompt and
successfully deleted the Windows partition on D:. I
then proceeded to create a primary and 3 logical
partitions in this space (3 MB). Details of the
partitions are provided below.
Name	Flags	Part Type	FS Type		Label		Size (MB)
hda1	Boot	Primary		NTFS				4996.78
hda2		Primary		Linux		 /		996.22
hda5		Logical		Linux		/usr		1004.07
hda6		Logical		Linux		/home		933.47
hda7		Logical		Linux Swap			125.51		

5. All the partitions were then initialised and

6. The next step was to load the OS Kernel and the
Device Drivers. This was where I ran into problems. I
am providing the steps followed below :
(a) Provided confirmations of filesystems mounted
(b) Choose the type of interface to load from. I chose
the CD-ROM
(c) My CD-ROM device happened to be /dev/hdd
(d) Then I was asked to select the directory on the
CD-ROM containing the file resc1440.bin.
- I specified / and then tried to select from the
automatic list. It did not work.
- In the next try, I tried providing the path. The
actual path on the CD-ROM was
/dists/slink/main/disks-i386/2.1.9-1999-03-03. When I
tried the auto list, it prefixed the path with
/instmnt and says that this path has been mounted. It
then refused to find the files. In the manual mode, I
entered the same directory but was faced with an error
stating that the files did not exist in the directory
(even though they were there).
- In all the automatic cases, the final error message
was ?The attempt to extract the Drivers Floppy

7. The next attempt was to try and create a Rescue
floppy and Drivers Floppy using Rawrite2 from the
CD-ROM. I used resc1440.bin for the rescue floppy and
drv1440.bin for the drivers floppy.  I booted the
system with the CD-ROM and used it until I got to the
Kernel loading point. I then selected the first floppy
drive and was asked to insert the rescue floppy. The
files were loaded and I was then asked to insert my
Drivers floppy. I did that and the system promptly
failed to load the driver files. The final error
message was ?The attempt to extract the Drivers Floppy

8. I thought that the error was due to the fact that
resc1440.bin and drv1440.bin were unacceptable to my
system. I tried creating floppies using
resc1440tecra.bin and drv1440tecra.bin. I could not
even create the driver floppy using rawrite2.

In most of the cases, the error message has been :


Also, would I have to mount /dev/hdd as a filesystem
before the path is recognized. If Yes, how would I do
this? There are no options to perform this action.
Actually, the CD-ROM did get read when I specified
/dev/hdd as the device file.

I am stuck and vexed. I would appreciate any help to
get out of this situation.

Many thanks in advance.

Sudhir Rao
London (United Kingdom)

Sudhir Rao
Cell : (44) 794 110 8347
Home : (44) 20 8795 3731
5 Bramley Lodge, Sudbury Ave
N. Wembley, Middx HA0 3AN
United Kingdom

Do You Yahoo!?
Get personalized email addresses from Yahoo! Mail

Reply to: