[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#98522: marked as done (boot-floppies: [woody] weird problems (cannot load base from network,cannot make bootdisk,..))

Your message dated Mon, 11 Jun 2001 03:02:57 +1000
with message-id <20010611030257.A5287@azure.humbug.org.au>
and subject line Weird debootstrap/busybox bug
has caused the attached Bug report to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what I am
talking about this indicates a serious mail system misconfiguration
somewhere.  Please contact me immediately.)

Darren Benham
(administrator, Debian Bugs database)

Received: (at submit) by bugs.debian.org; 23 May 2001 16:31:29 +0000
>From grin@rulez.tolna.net Wed May 23 11:31:29 2001
Return-path: <grin@rulez.tolna.net>
Received: from rulez.tolna.net [] 
	by master.debian.org with esmtp (Exim 3.12 1 (Debian))
	id 152bXl-0008ST-00; Wed, 23 May 2001 11:31:29 -0500
Received: from grin by rulez.tolna.net with local (Exim 3.22 #1 (Debian))
	id 152bXj-00006k-00; Wed, 23 May 2001 18:31:27 +0200
From: grin@tolna.net
Subject: boot-floppies: [woody] weird problems (cannot load base from network,cannot make bootdisk,..)
To: submit@bugs.debian.org
X-Mailer: bug 3.3.9
Message-Id: <E152bXj-00006k-00@rulez.tolna.net>
Sender: grin <grin@rulez.tolna.net>
Date: Wed, 23 May 2001 18:31:27 +0200
Delivered-To: submit@bugs.debian.org

Package: boot-floppies
Version: 20010518
Severity: important


tried to install using 2.3.2-2001-05-18 but I had to go back to
potato bootdisks because I was unable to install no matter my
efforts. It is naturally always a possibility that I am the one
to blame.

I tried to install from compact image (using rtl8139 nic), the
system started, network was ok, so I tried to use http:// from
a local mirror, the default (us) mirror, any mirror... but it
failed, retrieved the first Packages file then said:

cannot retrieve adduser (or like that)

Trying several url's I realized that sometimes the installer just
restarts (I guess a segfault somewhere) when it doesn't like the
url, or the result it got.

Later on in the install there was a point to create a boot disk.
Disk was inserted, the result was: unable to write, maybe you didn't
insert it in the first drive (or like that). Naturally I did, but
it seemed that it doesn't even try to format the disk (neither low
level (superformat) nor logical (mke2fs/mkdosfs/mformat/..). Since
the partition was above 1024 neither lilo norr bootdisk was present,
booting with rescue disk isn't nice.

...and I realized that it didn't work either, as "cannot open initial
console" message informed me about /dev/ being empty. But I bet it was
because I tried to force base*.tgz by hand and maybe I messed it up.

All in all - I had to start from scratch with the potato disks, which
installed base from tgz and not by deb's (as I noticed at the new bootdisk),
which went flawlessly.

This bugreport was created mostly because I'm a debian developer and a
debian fan, and just before the install a friend heard that I am going to
install debian and commented "I heard from several others and I tried
myself that since some time debian cannot be installed so I went on
[insert alternative distro here]." I strongly have disagree but then I
tried to install it and... oops. :-S

Standard disclaimer: since the install's done (potato disks) I cannot repeat
it so if the provided information wasn't detailed enough to fix te bugs
please close the bug. If you need more info (not much I can provide tho)
feel free to ask.

-- System Information
Debian Release: testing/unstable
Kernel Version: Linux rulez 2.2.19 #1 Wed May 23 01:09:48 CEST 2001 i586 unknown

Received: (at 98522-done) by bugs.debian.org; 10 Jun 2001 17:03:06 +0000
>From aj@azure.humbug.org.au Sun Jun 10 12:03:06 2001
Return-path: <aj@azure.humbug.org.au>
Received: from (azure.humbug.org.au) [::ffff:] 
	by master.debian.org with esmtp (Exim 3.12 1 (Debian))
	id 1598cD-0003zL-00; Sun, 10 Jun 2001 12:03:05 -0500
Received: from aj by azure.humbug.org.au with local (Exim 3.12 #1 (Debian))
	id 1598c5-0001Nd-00; Mon, 11 Jun 2001 03:02:57 +1000
Date: Mon, 11 Jun 2001 03:02:57 +1000
To: 98522-done@bugs.debian.org, control@bugs.debian.org
Subject: Weird debootstrap/busybox bug
Message-ID: <20010611030257.A5287@azure.humbug.org.au>
Mime-Version: 1.0
Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline
User-Agent: Mutt/1.2.5i
Organisation: Lacking
X-PGP: http://azure.humbug.org.au/~aj/aj_key.asc
From: Anthony Towns <aj@azure.humbug.org.au>
Delivered-To: 98522-done@bugs.debian.org

reassign 98522 boot-floppies

This bug is apparently fixed in current busybox, and thus in current
builds of boot-floppies. Reassigned to boot-floppies so that it can
be reasonably reopened if the diagnosis isn't correct.


Anthony Towns <aj@humbug.org.au> <http://azure.humbug.org.au/~aj/>
I don't speak for anyone save myself. GPG signed mail preferred.

``_Any_ increase in interface difficulty, in exchange for a benefit you
  do not understand, cannot perceive, or don't care about, is too much.''
                      -- John S. Novak, III (The Humblest Man on the Net)

Reply to: