[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: m68k boot-floppies for woody

On Mon, Jun 04, 2001 at 08:23:24PM -0400, Adam Di Carlo wrote:
> Are you applying this patch or do you need someone to apply it?
> If you are sending patches to this need that need applying, please
> make it very clear, perhaps with subject of [APPLY PATCH PLS].
I applied the subarch/system patch and the patch for the hfsutils, might
have to replace sudo by $ROOTCMD though... but does it matter?:
ROOTCMD         := $(shell [ 	d -u = 0 ] || echo sudo)
Guess it will fail when I build as root, and no sudo is installed. 

What is still missing is the location of m68k-vme-tftplilo_*.deb. Currently
it is searched in  $archive/admin/m68k-vme-tftplilo_*.deb, which was working
in the potato boot-floppies. But the meaning of archive seems to have
changed a bit, for me s/"admin"/"download/archives" (off my head) and copying
the deb there worked. I don't know how to test for the deb to be there
before spending hours building and then failing here. A patch for the test
and downloading (in online mode only!) the deb to there would be more than

Besides that m68k suffers from a busybox<->linux-2.2 incompatiblity, Richard
is working on a fix. I guess I may not tell more right now ;-)

Oh, and I found a cosmetic problem. All the *manpage.txt files (amiga,
atarai, mac, etc) for m68k say: manpage not found. We had that earlier in
potato bf, and we had it fixed. Seems it needs to be refixed for woody. But
I'll look into that only after the busybox problem is solved.

A little more than cosmetic is probably the m68k specific documentation. I
have absolutely no time to spend onto that. I propose to delete the m68k
specific quickinstall files completely, since they were not updated since
about one year. Not sure how much has changed for a woody installation, but
now is the time to get rid of that hack and integrate the m68k specifics
into the main documentation, that will save a lot of time in the long run,
or to have no m68k specific documentation at all.


Reply to: