[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

PPC boot-floppy building

I figured the best way to get my feet wet would be to checkout and build the
latest cvs woody boot floppies for PPC -- so here goes.

The first problem I ran into is due to a change in the 2.4 version of
<asm/unaligned.h> included in utilities/libfdisk/partbl_msdos.c. If __KERNEL__
is not defined, then nothing gets defined in <asm/unaligned.h>, in particular

I don't know if you'd prefer another way, but here's a patch.

Index: utilities/libfdisk/partbl_msdos.c
RCS file: /cvs/debian-boot/boot-floppies/utilities/libfdisk/partbl_msdos.c,v
retrieving revision 1.7
diff -u -u -r1.7 partbl_msdos.c
--- utilities/libfdisk/partbl_msdos.c    2001/01/18 23:23:20      1.7
+++ utilities/libfdisk/partbl_msdos.c    2001/04/11 19:46:38
@@ -22,6 +22,10 @@
  * frequently the case with the nr_sects and start_sect partition
  * table entries.
+#include <linux/version.h>
+#define __KERNEL__
 #include <asm/unaligned.h>

 #define SYS_IND(p) (get_unaligned(&p->sys_ind))

The next thing I ran into was due to my system apt_preferences conflicting with
the apt-get call in common.sh. So, here's a patch for that (pointing to a
perhaps fictional preferences.apt file in the boot-floppy root).

Index: common.sh
RCS file: /cvs/debian-boot/boot-floppies/common.sh,v
retrieving revision 1.32
diff -u -u -r1.32 common.sh
--- common.sh  2001/04/08 16:52:51 1.32
+++ common.sh  2001/04/11 19:45:18
@@ -17,6 +17,7 @@
 arch=${architecture-$(dpkg --print-architecture)}


 # abort on any non-zero exit value
 set -e
@@ -224,7 +225,8 @@
     local APT_GET="apt-get $APT_QUIET --yes
         -o Dir::Etc::SourceList=${SOURCES_LIST} \
     -o Debug::NoLocking=true -o Dir::Cache=${archive}/cache \
-        -o Dir::State::status=${DPKG_STATUS} -o
+        -o Dir::State::status=${DPKG_STATUS} -o
Dir::State::Lists=${archive}/lists" \
+    -o Dir::State::preferences=${PREFERENCES_LIST}

     # check if we're in offline mode
     if grep '^offline_mode[[:space:]]*:\?=[[:space:]]*true' config >/dev/null;

Finally, the make proceeds to converting keymaps and exits with
utiliites/writemaps/loadkeys mac-de-latin1-nodeadkeys.kmap.gz:11: adding map 3
violates explicit keymaps line. This would seem to be an outstanding bug (50588)
in console-data nearly one and a half years old. Any ideas how to proceed?



Stephen R. Marenka

Reply to: