[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#93362: getpwuid() doesn't work

On Mon, Apr 09, 2001 at 12:33:33AM -0700, David Whedon wrote:
> This is the root cause of the 'id -u' problem.  I don't believe the problem is
> with busybox, I think we are missing something on our filesystem, a library, a
> config file, I don't know which.
> At the end of this messages I have a program that demonstrates the problem.
> Test it on a working system and you get something like:
> # ./a.out 
> you are root
> #
> Test it is a chroot'ed root.bin[1] and you get:
> # ./a.out
> failure.
> # 

I tried the root.bin at
and was able to reproduce the above failure.  However, when I ran
the busybox id included on that root.bin, it succeeded.  It
appears to be busybox version 0.43, which contained its own files
for parsing /etc/passwd and did not rely on the name service
switch.  More recent versions of busybox allow you to choose
between this homegrown implementation and the name service switch
support.  My guess is that it somehow switched to the nss version,
which fails due to missing libraries and configuration files.  So
this bug should probably be reassigned to busybox, with a request
to build it with USE_SYSTEM_PWD_GRP=false.


Reply to: