[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

UDMA66 boot problem /HPT370

When I try installing Debian 2.2r2 on my HPT370 Raid/UDMA100 controller, with the UDMA66 boot floppies, the system halts during the boot process. Why? Thnanks for any help. I´m sorry this description got so long, but if someone really wants to help he might need some of the info below.

I´m booting debian from the UDMA66 rescue disk. The disk works fine at my friends computer (Promise UDMA 66 onboard) and I tried several ones with the same result.

When I boot from the Debian 2.2r2 CD I can successfully load the kernel and get into the install menu, but I have no harddisk detected. I tried loading modules from the UDMA66 driver1-4 disks but then I receive an error message saying : "Unable to mount disk".

I also tried booting the UDMA flavor from DOS (loadlin) but then I receive the exact same result as shown below.

If someone knows some really good boot parameters (and exact use) that will get my HPT370 controller to work with the standard flavor, that might also help.

Those are the last boot messages I received. The earlier ones seemed unimportant.



RAM disk driver initialized: 16 RAM disks of 16384K size

loop: registered device at major 7

Uniform Multi-Platform E-IDE driver Revision: 6.30

ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx

VP_IDE: IDE controller on PCI bus 00 dev 39

VP_IDE: chipset revision 16

VP_IDE: not 100% native mode: will probe irqs later

VP_IDE: VIA vt82c686a IDE UDMA66 controller on pci0:7.1

ide0: BM-DMA at 0xc000-0xc007, BIOS settings: hda: DMA, hdb: DMA

HPT370: IDE controller on PCI bus 00 dev 98

HPT370: chipset revision 3

HPT370: not 100% native mode: will probe irqs later

ide2: BM-DMA at 0xe400-0xe407, BIOS settings: hde: DMA, hdf: pio

ide3: BM-DMA at 0xe408-0xe40f, BIOS settings: hdg: pio, hdh: pio



ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx



>>This is were the system stops working. Nothing happens from here on.

At a friends computer the last line was followed by some lines referring to his harddrive : Maxtor ... 512K cache ...

I already tried adding idebus=33 as a boot parameter, but the system just stopped one line earlier.

I´m not running a raid array. I just connected my one and only harddrive to the HPT370 controller to take advantage of the UDMA100 burst speed.

I had the second ide channel (ide1) disabled in the BIOS in case someone wondered.


Here´s a summary of my system

Athlon TB 900

Abit KT7-Raid Motherboard

IBM DTLA 307030 30GB UDMA100 harddrive connected

to HPT370 onboard Raid controller (ide2 master)


Soundblaster PCI 128

Geforce II MX 32MB AGP video card

SMC 1211TX EZ-Card - PCI network card

USB Mouse


Thanks a lot. If you are reading this line, I know that you tried.


Attachment: udma66.doc
Description: Binary data

Reply to: